summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-romulus
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2019-09-17 05:32:20 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-18 16:06:01 +0300
commita91c80cd8ec6223d8ab651bc882466ced120a656 (patch)
treefa013c391281b2fda625b39b390312d8650d8a94 /meta-ibm/meta-romulus
parentb809eb9d31058aad51fb82ff321a6bef45b23e58 (diff)
downloadopenbmc-a91c80cd8ec6223d8ab651bc882466ced120a656.tar.xz
meta-romulus: Remove cooling-type
The cooling-type in phosphor-fan is optional, and Romulus is a air-cooled system and does not require cooling-type application at all. Remove the cooling-type app and the related configuration files. Tested: Verify the generated phosphor-fan related hpp and cpp files are identical as before, and the system is able to power on and do fan monitor/control without problem. (From meta-ibm rev: 3168f5e5fb59bd37eed1600d42a8d6fc02875fea) Change-Id: I30f47ef63f4ff5bea89f31966273930baaf070ea Signed-off-by: Lei YU <mine260309@gmail.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-romulus')
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config/zone_conditions.yaml9
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/obmc/phosphor-fan/phosphor-cooling-type-0.conf3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service15
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend21
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend2
6 files changed, 1 insertions, 50 deletions
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend
deleted file mode 100644
index 781af4fcf..000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config/zone_conditions.yaml b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config/zone_conditions.yaml
deleted file mode 100644
index 7dc99b6a2..000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config/zone_conditions.yaml
+++ /dev/null
@@ -1,9 +0,0 @@
-conditions:
- - name: air_cooled_chassis
- type: getProperty
- properties:
- - property: WaterCooled
- interface: xyz.openbmc_project.Inventory.Decorator.CoolingType
- path: /xyz/openbmc_project/inventory/system/chassis
- type: bool
- value: false
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/obmc/phosphor-fan/phosphor-cooling-type-0.conf b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/obmc/phosphor-fan/phosphor-cooling-type-0.conf
deleted file mode 100644
index 21fcfcb49..000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/obmc/phosphor-fan/phosphor-cooling-type-0.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-OBJPATH="--path=/system/chassis"
-AIR="--air"
-
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service
deleted file mode 100644
index 9232b13fc..000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=Phosphor Cooling Type
-Wants=mapper-wait@-xyz-openbmc_project-inventory.service
-After=mapper-wait@-xyz-openbmc_project-inventory.service
-ConditionPathExists={envfiledir}/obmc/phosphor-fan/phosphor-cooling-type-%i.conf
-
-[Service]
-Type=oneshot
-RemainAfterExit=yes
-EnvironmentFile={envfiledir}/obmc/phosphor-fan/phosphor-cooling-type-%i.conf
-ExecStart=/usr/bin/env phosphor-cooling-type ${{OBJPATH}} ${{AIR}}
-SyslogIdentifier=phosphor-cooling-type
-
-[Install]
-RequiredBy=multi-user.target
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
deleted file mode 100644
index 3ec031946..000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ /dev/null
@@ -1,21 +0,0 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
-
-# Package configuration
-FAN_PACKAGES += " \
- phosphor-cooling-type \
-"
-
-PACKAGECONFIG_append_romulus = " cooling-type"
-
-TMPL_COOLING = "phosphor-cooling-type@.service"
-INSTFMT_COOLING = "phosphor-cooling-type@{0}.service"
-COOLING_TGT = "multi-user.target"
-FMT_COOLING = "../${TMPL_COOLING}:${COOLING_TGT}.requires/${INSTFMT_COOLING}"
-
-FILES_phosphor-cooling-type = "${bindir}/phosphor-cooling-type"
-SYSTEMD_SERVICE_phosphor-cooling-type += "${TMPL_COOLING}"
-SYSTEMD_LINK_phosphor-cooling-type += "${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}"
-
-COOLING_ENV_FMT = "obmc/phosphor-fan/phosphor-cooling-type-{0}.conf"
-
-SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type_append_romulus = " ${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index 920e529a5..6380ac256 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1,2 +1,2 @@
-RDEPENDS_${PN}-inventory_append_romulus = " openpower-occ-control phosphor-cooling-type id-button"
+RDEPENDS_${PN}-inventory_append_romulus = " openpower-occ-control id-button"
RDEPENDS_${PN}-extras_append_romulus = " phosphor-webui phosphor-image-signing"