summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2019-03-12 00:35:35 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-25 20:00:03 +0300
commit8baeb194a9ef56183fbb1a1669353a530fdfd2a0 (patch)
tree34f160c0bec1bd11c6a7a6432501dc68e9583783 /meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
parent5896a23a772947bb149670beecf8a7178f78eca6 (diff)
downloadopenbmc-8baeb194a9ef56183fbb1a1669353a530fdfd2a0.tar.xz
Add witherspoon inventory associations
Add the inventory association definitions for witherspoon. With these, phosphor-inventory will create the org.openbmc.Associations interface on the specified inventory paths such that the object mapper will create the association D-Bus objects. These associations are used to associate inventory paths to their fans, sensors, and LEDs. (From meta-ibm rev: 1b3a22abadee18beae8307d1b76e701733281717) Change-Id: I63d65ce81ee9d0dabe7c2f99d919bd7b115ded66 Signed-off-by: Matt Spinler <spinler@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
new file mode 100644
index 000000000..5e3aff476
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+PACKAGECONFIG_append = " associations"
+SRC_URI += "file://associations.json"
+
+do_install_append() {
+ install -d ${D}${base_datadir}
+ install -m 0755 ${WORKDIR}/associations.json ${D}${base_datadir}/associations.json
+}