summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor/inventory
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-23 04:40:54 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 19:39:42 +0300
commit194ff4f1f5d44b12e9cb06ddafa6adb20174a13c (patch)
tree823835cd29daf8901a31ac14c7e6534abf199be3 /meta-ibm/meta-witherspoon/recipes-phosphor/inventory
parent4feb727cd6b77a68bdaca63e121b378d814f5eaf (diff)
downloadopenbmc-194ff4f1f5d44b12e9cb06ddafa6adb20174a13c.tar.xz
[Subtree] Bring openbmc machines to top level
The new subtree model brings the subtrees up from the openbmc-machines layer. Change-Id: I58a03ae1be374bc79ae1438e65e888375d12d0c0 Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor/inventory')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb15
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml27
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bbappend1
3 files changed, 43 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb
new file mode 100644
index 000000000..6efde485f
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Copy Witherspoon inventory cleanup yaml for inventory manager"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-inventory-manager
+
+SRC_URI += "file://inventory-cleanup.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${base_datadir}/events.d/
+ install ${S}/inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
+}
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml
new file mode 100644
index 000000000..01632e6d8
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml
@@ -0,0 +1,27 @@
+description: >
+ Witherspoon inventory fixups
+
+events:
+ - name: Remove power_supplies
+ description: >
+ Remove the deprecated 'power_supply' objects
+ type: startup
+ actions:
+ - name: destroyObjects
+ paths:
+ - /system/chassis/power_supply0
+ - /system/chassis/power_supply1
+ - /system/chassis/powersupply0
+ - /system/chassis/powersupply1
+
+ - name: Remove fan1
+ description: >
+ Remove all fan1 associated objects and have fan presence and
+ fan monitor create it based on cooling type.
+ type: startup
+ actions:
+ - name: destroyObjects
+ paths:
+ - /system/chassis/motherboard/fan1/fan1_0
+ - /system/chassis/motherboard/fan1/fan1_1
+ - /system/chassis/motherboard/fan1
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bbappend
new file mode 100644
index 000000000..d9304c045
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bbappend
@@ -0,0 +1 @@
+PHOSPHOR_INVENTORY_MANAGER_CONFIGS += "inventory-cleanup-native"