summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor/inventory
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-18 00:35:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-24 04:18:54 +0300
commita29c2d5e6187adb2c309d049226085eb1283b555 (patch)
tree0fa19fd4aa4a95779e503e235109b769a013138d /meta-ibm/meta-witherspoon/recipes-phosphor/inventory
parentead9ee683e5829b00afae3032df6d4e505f492b6 (diff)
downloadopenbmc-a29c2d5e6187adb2c309d049226085eb1283b555.tar.xz
meta-ibm: use ibm-ac-server MACHINEOVERRIDE
Use an override in bbappends in meta-witherspoon as described and recommended in the "following best practices when creating layers" section of the the Yocto development tasks manual. ibm-ac-server represents common machine configuration shared by all of IBMs "Accelerated Compute" class of servers. Apply it wherever any variables are un-bounded by any override. This enables more flexible use of meta-witherspoon in build configurations, and easy addition of machines to the layer. (From meta-ibm rev: bb0e1d0699a4b9905c053c94af7d882cd71779fc) Change-Id: I82f7338b0d7a64b5e7a67e19bcdff07f48a332d4 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor/inventory')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
index 39f87342e..bdc3912d5 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -1,11 +1,11 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PACKAGECONFIG_append = " associations"
-SRC_URI += "file://associations.json"
+PACKAGECONFIG_append_ibm-ac-server = " associations"
+SRC_URI_append_ibm-ac-server = " file://associations.json"
-DEPENDS_append = " inventory-cleanup"
+DEPENDS_append_ibm-ac-server = " inventory-cleanup"
-do_install_append() {
+do_install_append_ibm-ac-server() {
install -d ${D}${base_datadir}
install -m 0755 ${WORKDIR}/associations.json ${D}${base_datadir}/associations.json
}