summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi
diff options
context:
space:
mode:
authorBen Pai <Ben_Pai@wistron.com>2020-03-31 11:34:40 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-07 02:47:30 +0300
commita8c7bfccb9eb23ea5bc68d3d72c29b90dba3a6ae (patch)
treec8b3f12475fc21401630a18023db4177b44ffb23 /meta-ibm/meta-witherspoon/recipes-phosphor/ipmi
parent5c8a528e637704814511ac66dab5f118516ba647 (diff)
downloadopenbmc-a8c7bfccb9eb23ea5bc68d3d72c29b90dba3a6ae.tar.xz
meta-ibm: Add mihawk ipmi oem command
In order to detect the riser card on the mihawk platform. (From meta-ibm rev: a50f69fb50ab68137ce1b95d79ccb703c97e47c4) Change-Id: Ief0019f08cc14f3733ba5db67fcf218f46812bb2 Signed-off-by: Ben Pai <Ben_Pai@wistron.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor/ipmi')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb
new file mode 100644
index 000000000..2281192fe
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Wistron OEM commands"
+DESCRIPTION = "Wistron OEM commands"
+HOMEPAGE = "https://github.com/openbmc/wistron-ipmi-oem"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "phosphor-ipmi-host"
+DEPENDS += "autoconf-archive-native"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/wistron-ipmi-oem"
+SRCREV = "44cee319dd113335a7885a1ff63a287dc7706682"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+HOSTIPMI_PROVIDER_LIBRARY += "libwistronoem.so"