summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor/network
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-18 00:35:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-24 04:18:54 +0300
commita29c2d5e6187adb2c309d049226085eb1283b555 (patch)
tree0fa19fd4aa4a95779e503e235109b769a013138d /meta-ibm/meta-witherspoon/recipes-phosphor/network
parentead9ee683e5829b00afae3032df6d4e505f492b6 (diff)
downloadopenbmc-a29c2d5e6187adb2c309d049226085eb1283b555.tar.xz
meta-ibm: use ibm-ac-server MACHINEOVERRIDE
Use an override in bbappends in meta-witherspoon as described and recommended in the "following best practices when creating layers" section of the the Yocto development tasks manual. ibm-ac-server represents common machine configuration shared by all of IBMs "Accelerated Compute" class of servers. Apply it wherever any variables are un-bounded by any override. This enables more flexible use of meta-witherspoon in build configurations, and easy addition of machines to the layer. (From meta-ibm rev: bb0e1d0699a4b9905c053c94af7d882cd71779fc) Change-Id: I82f7338b0d7a64b5e7a67e19bcdff07f48a332d4 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor/network')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/network/first-boot-set-mac_%.bbappend2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/network/phosphor-network_%.bbappend6
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/network/first-boot-set-mac_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/network/first-boot-set-mac_%.bbappend
index 29d23c8c4..cb167ee3f 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/network/first-boot-set-mac_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/network/first-boot-set-mac_%.bbappend
@@ -1 +1 @@
-SYSTEMD_SERVICE_${PN} += "first-boot-set-mac@eth0.service"
+SYSTEMD_SERVICE_${PN}_append_ibm-ac-server = " first-boot-set-mac@eth0.service"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/network/phosphor-network_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/network/phosphor-network_%.bbappend
index 5137f4e00..ba6e393bb 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/network/phosphor-network_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/network/phosphor-network_%.bbappend
@@ -1,8 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/network:"
-SRC_URI += "file://ncsi-netlink.service"
-SYSTEMD_SERVICE_${PN} += "ncsi-netlink.service"
+SRC_URI_append_ibm-ac-server = " file://ncsi-netlink.service"
+SYSTEMD_SERVICE_${PN}_append_ibm-ac-server = " ncsi-netlink.service"
-do_install_append() {
+do_install_append_ibm-ac-server() {
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/ncsi-netlink.service ${D}${systemd_system_unitdir}
}