summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/console
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2021-08-06 19:25:30 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 20:28:12 +0300
commitb96c75046da8f72359d101c813f0694409bbe0d1 (patch)
treeab68b1d00b439d9a09f5b6743e8a8bfa1e8e7087 /meta-ibm/recipes-phosphor/console
parent8c6707f0dcab30d2c0d818b455b030b5d7e7091c (diff)
downloadopenbmc-b96c75046da8f72359d101c813f0694409bbe0d1.tar.xz
meta-ibm: prep for new override syntax
Change-Id: I9116ed7260e369136acb39eec15075db2d4dbeba Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/console')
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend36
1 files changed, 18 insertions, 18 deletions
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
index f493ef5a0..9360e2128 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
@@ -1,6 +1,6 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI_remove = "file://${BPN}.conf"
+SRC_URI:remove = "file://${BPN}.conf"
SRC_URI += "file://server.ttyVUART0.conf"
install_concurrent_console_config() {
@@ -27,38 +27,38 @@ install_concurrent_console_config() {
install -m 0644 ${WORKDIR}/server.ttyVUART1.conf ${D}${sysconfdir}/${BPN}/
}
-SRC_URI_append_p10bmc = " file://client.2201.conf"
-SRC_URI_append_p10bmc = " file://server.ttyVUART1.conf"
+SRC_URI:append:p10bmc = " file://client.2201.conf"
+SRC_URI:append:p10bmc = " file://server.ttyVUART1.conf"
-REGISTERED_SERVICES_${PN}_append_p10bmc = " obmc_console_guests:tcp:2201:"
+REGISTERED_SERVICES_${PN}:append:p10bmc = " obmc_console_guests:tcp:2201:"
-SYSTEMD_SERVICE_${PN}_append_p10bmc = " obmc-console-ssh@2200.service \
+SYSTEMD_SERVICE:${PN}:append:p10bmc = " obmc-console-ssh@2200.service \
obmc-console-ssh@2201.service \
"
-SYSTEMD_SERVICE_${PN}_remove_p10bmc = "obmc-console-ssh.socket"
+SYSTEMD_SERVICE:${PN}:remove:p10bmc = "obmc-console-ssh.socket"
-FILES_${PN}_remove_p10bmc = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf"
+FILES:${PN}:remove:p10bmc = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf"
-EXTRA_OECONF_append_p10bmc = " --enable-concurrent-servers"
+EXTRA_OECONF:append:p10bmc = " --enable-concurrent-servers"
-do_install_append_p10bmc() {
+do_install:append:p10bmc() {
install_concurrent_console_config
}
-SRC_URI_append_witherspoon-tacoma = " file://client.2201.conf"
-SRC_URI_append_witherspoon-tacoma = " file://server.ttyVUART1.conf"
+SRC_URI:append:witherspoon-tacoma = " file://client.2201.conf"
+SRC_URI:append:witherspoon-tacoma = " file://server.ttyVUART1.conf"
-REGISTERED_SERVICES_${PN}_append_witherspoon-tacoma = " obmc_console_guests:tcp:2201:"
+REGISTERED_SERVICES_${PN}:append:witherspoon-tacoma = " obmc_console_guests:tcp:2201:"
-SYSTEMD_SERVICE_${PN}_append_witherspoon-tacoma = " obmc-console-ssh@2200.service \
+SYSTEMD_SERVICE:${PN}:append:witherspoon-tacoma = " obmc-console-ssh@2200.service \
obmc-console-ssh@2201.service \
"
-SYSTEMD_SERVICE_${PN}_remove_witherspoon-tacoma = "obmc-console-ssh.socket"
+SYSTEMD_SERVICE:${PN}:remove:witherspoon-tacoma = "obmc-console-ssh.socket"
-FILES_${PN}_remove_witherspoon-tacoma = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf"
+FILES:${PN}:remove:witherspoon-tacoma = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf"
-EXTRA_OECONF_append_witherspoon-tacoma = " --enable-concurrent-servers"
+EXTRA_OECONF:append:witherspoon-tacoma = " --enable-concurrent-servers"
-do_install_append_witherspoon-tacoma() {
+do_install:append:witherspoon-tacoma() {
install_concurrent_console_config
}