summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-18 01:10:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-19 05:19:18 +0300
commit56e154e82136eb84b747c354f1833e8c0ac447ab (patch)
treed9dba6c2402aabeee8c777d935a191f2cf51eeee /meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb
parentfc8424b220cf52f94e442d33985cee35e8811f69 (diff)
downloadopenbmc-56e154e82136eb84b747c354f1833e8c0ac447ab.tar.xz
meta-ibm: dbus: ibm-dbus-interfaces: rename as git
Rename ibm-dbus-interfaces.bb to _git.bb per OE norms. (From meta-ibm rev: 36f78498cb4dc2e3bbba3ad32f4e00baaa6d7e8d) Change-Id: If99664a7d6409d3845719f1528a0a1aba45b06af Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb')
-rw-r--r--meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb b/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb
new file mode 100644
index 000000000..37447038d
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "IBM DBus Interfaces"
+DESCRIPTION = "Generated bindings, using sdbus++, for the IBM YAML"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-license
+inherit pythonnative
+inherit phosphor-dbus-yaml
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbus++-native"
+
+SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces"
+SRCREV = "c9ae6bf297b40391256c8f21a01d72e049036017"
+
+DEPENDS_remove_class-native = "sdbus++-native"
+DEPENDS_remove_class-nativesdk = "sdbus++-native"
+
+PACKAGECONFIG ??= "libibm_dbus"
+PACKAGECONFIG[libibm_dbus] = " \
+ --enable-libibm_dbus, \
+ --disable-libibm_dbus, \
+ systemd sdbusplus, \
+ libsystemd sdbusplus \
+ "
+
+PACKAGECONFIG_remove_class-native = "libibm_dbus"
+PACKAGECONFIG_remove_class-nativesdk = "libibm_dbus"
+
+BBCLASSEXTEND += "native nativesdk"