summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/dump
diff options
context:
space:
mode:
authorChirag Sharma <chirshar@in.ibm.com>2020-09-29 16:18:17 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-30 01:00:00 +0300
commit4b5211d52cef3c6d27532046c056e63ccd24bb0b (patch)
tree226ee95b5e28a88255cdd9d1ed1eb5a2dc47eb37 /meta-ibm/recipes-phosphor/dump
parent6e7584f932e8808fdd804650fa90ede8808a7480 (diff)
downloadopenbmc-4b5211d52cef3c6d27532046c056e63ccd24bb0b.tar.xz
meta-ibm: rainier: install dump header script
This commit will install the dump header script which will create dump header and impose the same on the dump.tar.xz file. Header format will consist of the following: -virtual file directory entry: one file directory entry for BMC DUMP, which will have file header and size of 40 bytes which consists of system serial number, dump identifier, time stamp of the dump. -section directory entry: This has SECTION as entry header, size is of 30 bytes consists of total size of the dump along with other details. -dump header: This has an eye catcher "BMC DUMP", dump identifier, system serial number, system name etc. -dump data table: This will have dump version, dump valid field and number of dump entries. (From meta-ibm rev: 49710574e0e40b98d1b671b95568314838d55985) Change-Id: I7906b6d602a8fd27655c90eb632ce55eaf8ab63a Signed-off-by: Chirag Sharma <chirshar@in.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/dump')
-rw-r--r--meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend b/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
index 91ef83e55..194d66cb0 100644
--- a/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
+++ b/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
@@ -24,5 +24,13 @@ python link_ibm_plugins() {
install_dreport_user_script(script, d)
}
-do_install[postfuncs] += "install_ibm_plugins"
-do_install[postfuncs] += "link_ibm_plugins"
+#Install dump header script from dreport/ibm.d to dreport/include.d
+install_dreport_header() {
+ install -d ${D}${dreport_include_dir}
+ install -m 0755 ${S}/tools/dreport.d/ibm.d/* ${D}${dreport_include_dir}/
+}
+
+IBM_INSTALL_POSTFUNCS = "install_ibm_plugins link_ibm_plugins"
+IBM_INSTALL_POSTFUNCS_rainier += "install_dreport_header"
+
+do_install[postfuncs] += "${IBM_INSTALL_POSTFUNCS}"