summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2020-06-22 19:14:20 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-03 00:13:50 +0300
commit2ae06d6d56758252fb8bdbd28cacac3a4d2376a8 (patch)
tree56ad7a0a842813cc08cba7db3197ff989c2c4d76 /meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
parent7c94d56b8f30ddece352b6db39f980825bac8594 (diff)
downloadopenbmc-2ae06d6d56758252fb8bdbd28cacac3a4d2376a8.tar.xz
fans:monitor:witherspoon: Enable JSON config
Use the installed `config.json` as the fan monitoring configuration to load at runtime. This replaces the need of the build time YAML `monitor.yaml` configuration. Tested: `monitor.yaml` removed from build image staging location Built/powered on image using the `config.json` file (From meta-ibm rev: 27be42e03193352d7c7ee51784448cb06d1b8e2c) Change-Id: I80c268b26dddd820e7c9c640eab2d39452ab3a29 Signed-off-by: Matthew Barth <msbarth@us.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend')
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
index 9307f17a3..cb29a7483 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
@@ -1,14 +1,11 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-SRC_URI_witherspoon += "file://monitor.yaml"
-SRC_URI_witherspoon += "file://config.json"
+SRC_URI_witherspoon = "file://config.json"
-do_install_append_witherspoon() {
- DEST=${D}${monitor_datadir}
- install -D monitor.yaml ${D}${monitor_datadir}/monitor.yaml
+do_install_witherspoon() {
install -d ${D}/${datadir}/phosphor-fan-presence/monitor/
install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/
}
-FILES_${PN}_witherspoon += "${datadir}/phosphor-fan-presence/monitor/config.json"
-FILES_${PN}_witherspoon += "${monitor_datadir}/monitor.yaml"
+FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/monitor/config.json"
+FILES_${PN}_remove_witherspoon = "${monitor_datadir}/monitor.yaml"