summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-03-24 02:54:59 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-03-25 23:23:32 +0300
commitdb94adfda170686fdca28bcbaf7d99b440ee3597 (patch)
tree2a65d8d7e8c5065598e312a8c67c7c5efa038f92 /meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
parentc22ef042f8791c093e75e4fbf8deb77e1a691677 (diff)
downloadopenbmc-db94adfda170686fdca28bcbaf7d99b440ee3597.tar.xz
1s4u: support presence config.json for new system
The 1s4u is just like the 2s4u except it has two less fans. Tested: - Booted up system with entity-manager loading rainier-1s4u config and verified fan applications found and loaded new 1s4u files and system was able to chassis power on. Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I575a63edb242c1b94e1a6f1eafd86a96e4518e37
Diffstat (limited to 'meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend')
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
index efbdea1f3..8817592d4 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
@@ -3,6 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
SRC_URI_witherspoon = "file://config.json"
SRC_URI_rainier = "file://rainier-2u/config.json \
file://rainier-4u/config.json \
+ file://rainier-1s4u/config.json \
file://everest/config.json \
"
@@ -14,8 +15,10 @@ do_install_rainier() {
# Install Rainier-2U/4U fan presence config files
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
+ install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
+ install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
# Install Everest fan presence config file
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
@@ -28,4 +31,5 @@ FILES_${PN}_remove_witherspoon = "${presence_datadir}/config.yaml"
FILES_${PN}_remove_rainier = "${presence_datadir}/config.yaml"
FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
+FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"