summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2021-08-19 18:17:45 +0300
committerMatthew Barth <msbarth@linux.ibm.com>2021-09-13 18:39:16 +0300
commitf90670136a3fe051b8b8e09215f790cac3c110ee (patch)
tree35c8190fd73dd3652a8923ca4d5d1c5d4d835282 /meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-f90670136a3fe051b8b8e09215f790cac3c110ee.tar.xz
meta-ibm:fans:presence: Use JSON config files installed from repo
The `witherspoon` and `p10bmc` machines' JSON config files should now use the JSON config files installed from the repository. Change-Id: Ie40264435ca5278a50f2aa3c688d882d72cb376b Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend')
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend35
1 files changed, 0 insertions, 35 deletions
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
deleted file mode 100644
index 64dbc758b..000000000
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
+++ /dev/null
@@ -1,35 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
-
-SRC_URI:witherspoon = "file://config.json"
-SRC_URI:p10bmc = "file://rainier-2u/config.json \
- file://rainier-4u/config.json \
- file://rainier-1s4u/config.json \
- file://everest/config.json \
- "
-
-do_install:witherspoon() {
- install -d ${D}/${datadir}/phosphor-fan-presence/presence/
- install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/
-}
-do_install:p10bmc() {
- # Install Rainier-2U/4U fan presence config files
- install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
- install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
- install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
- install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
- install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
- install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
-
- # Install Everest fan presence config file
- install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
- install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
-}
-
-FILES:${PN}:append:witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json"
-FILES:${PN}:remove:witherspoon = "${presence_datadir}/config.yaml"
-
-FILES:${PN}:remove:p10bmc = "${presence_datadir}/config.yaml"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"