summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/gpio
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2021-08-06 19:25:30 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 20:28:12 +0300
commitb96c75046da8f72359d101c813f0694409bbe0d1 (patch)
treeab68b1d00b439d9a09f5b6743e8a8bfa1e8e7087 /meta-ibm/recipes-phosphor/gpio
parent8c6707f0dcab30d2c0d818b455b030b5d7e7091c (diff)
downloadopenbmc-b96c75046da8f72359d101c813f0694409bbe0d1.tar.xz
meta-ibm: prep for new override syntax
Change-Id: I9116ed7260e369136acb39eec15075db2d4dbeba Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/gpio')
-rw-r--r--meta-ibm/recipes-phosphor/gpio/id-button.bb4
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend10
2 files changed, 7 insertions, 7 deletions
diff --git a/meta-ibm/recipes-phosphor/gpio/id-button.bb b/meta-ibm/recipes-phosphor/gpio/id-button.bb
index 386a2b93d..01df2ea5b 100644
--- a/meta-ibm/recipes-phosphor/gpio/id-button.bb
+++ b/meta-ibm/recipes-phosphor/gpio/id-button.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
DEPENDS += "virtual/obmc-gpio-monitor"
-RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
S = "${WORKDIR}"
SRC_URI += "file://toggle_identify_led.sh"
@@ -26,5 +26,5 @@ INSTFMT = "phosphor-gpio-monitor@{0}.service"
TGT = "multi-user.target"
FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
-SYSTEMD_SERVICE_${PN} += "id-button-pressed.service"
+SYSTEMD_SERVICE:${PN} += "id-button-pressed.service"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
index 995dca3ae..272a8a1f5 100644
--- a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -1,14 +1,14 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
TMPL_POWERSUPPLY = "phosphor-gpio-presence@.service"
INSTFMT_POWERSUPPLY = "phosphor-gpio-presence@{0}.service"
POWERSUPPLY_TGT = "multi-user.target"
FMT_POWERSUPPLY = "../${TMPL_POWERSUPPLY}:${POWERSUPPLY_TGT}.wants/${INSTFMT_POWERSUPPLY}"
-SYSTEMD_LINK_${PN}-presence_append_ibm-ac-server = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
-SYSTEMD_LINK_${PN}-presence_append_mihawk = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_LINK_${PN}-presence:append:ibm-ac-server = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_LINK_${PN}-presence:append:mihawk = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
POWERSUPPLY_ENV_FMT = "obmc/gpio/phosphor-power-supply-{0}.conf"
-SYSTEMD_ENVIRONMENT_FILE_${PN}-presence_append_ibm-ac-server = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
-SYSTEMD_ENVIRONMENT_FILE_${PN}-presence_append_mihawk = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}-presence:append:ibm-ac-server = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}-presence:append:mihawk = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"