summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/gpio
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-04-22 21:06:02 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-27 19:52:12 +0300
commite161514219e0dc8a957dabbb8529fb9fcac4e115 (patch)
tree5de46006517d690f5793eec41281d60611228ecd /meta-ibm/recipes-phosphor/gpio
parenta3f54c8b8cbd50bc86efdc52cfb7d348d8c19d21 (diff)
downloadopenbmc-e161514219e0dc8a957dabbb8529fb9fcac4e115.tar.xz
meta-ibm: move all meta-witherspoon metadata
The metadata common to all IBM systems is confusingly split between meta-ibm and meta-witherspoon. Move everything to meta-ibm. The meta-ibm README is re-written to more accurately reflect the scope of the layer. Allow the configuration samples (bblayers.conf.sample, local.conf.sample) to be sourced from either meta-ibm or meta-witherspoon until such a time that any workflows and tooling have had the opportunity to move to meta-ibm. (From meta-ibm rev: 6e05ef2e90b214eaf4e43ee7027bbbb1d8d09442) Change-Id: I3ec890d5300f9649c974ea6b9dca93a2e8a889ab Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/gpio')
-rw-r--r--meta-ibm/recipes-phosphor/gpio/id-button.bb30
-rw-r--r--meta-ibm/recipes-phosphor/gpio/id-button/id-button-pressed.service9
-rw-r--r--meta-ibm/recipes-phosphor/gpio/id-button/obmc/gpio/id_button5
-rw-r--r--meta-ibm/recipes-phosphor/gpio/id-button/toggle_identify_led.sh27
-rwxr-xr-xmeta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/mihawk/obmc/gpio/phosphor-power-supply-0.conf6
-rwxr-xr-xmeta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/mihawk/obmc/gpio/phosphor-power-supply-1.conf6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/phosphor-power-supply-0.conf6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-0.conf6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-1.conf6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-2.conf6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-3.conf6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/swift/obmc/gpio/phosphor-power-supply-1.conf6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon-tacoma/obmc/gpio/phosphor-power-supply-0.conf6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon-tacoma/obmc/gpio/phosphor-power-supply-1.conf6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon/obmc/gpio/phosphor-power-supply-1.conf6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend16
16 files changed, 153 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/gpio/id-button.bb b/meta-ibm/recipes-phosphor/gpio/id-button.bb
new file mode 100644
index 000000000..386a2b93d
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/id-button.bb
@@ -0,0 +1,30 @@
+SUMMARY = "ID Button pressed application"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit obmc-phosphor-systemd
+
+DEPENDS += "virtual/obmc-gpio-monitor"
+RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+
+S = "${WORKDIR}"
+SRC_URI += "file://toggle_identify_led.sh"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/toggle_identify_led.sh \
+ ${D}${bindir}/toggle_identify_led.sh
+}
+
+SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/id_button"
+
+ID_BUTTON_SERVICE = "id_button"
+
+TMPL = "phosphor-gpio-monitor@.service"
+INSTFMT = "phosphor-gpio-monitor@{0}.service"
+TGT = "multi-user.target"
+FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
+
+SYSTEMD_SERVICE_${PN} += "id-button-pressed.service"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"
diff --git a/meta-ibm/recipes-phosphor/gpio/id-button/id-button-pressed.service b/meta-ibm/recipes-phosphor/gpio/id-button/id-button-pressed.service
new file mode 100644
index 000000000..c4f939cc3
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/id-button/id-button-pressed.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=ID Button Pressed Service
+Wants=mapper-wait@-xyz-openbmc_project-led-groups.service
+After=mapper-wait@-xyz-openbmc_project-led-groups.service
+StartLimitIntervalSec=0
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/toggle_identify_led.sh
diff --git a/meta-ibm/recipes-phosphor/gpio/id-button/obmc/gpio/id_button b/meta-ibm/recipes-phosphor/gpio/id-button/obmc/gpio/id_button
new file mode 100644
index 000000000..370e609cd
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/id-button/obmc/gpio/id_button
@@ -0,0 +1,5 @@
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=41
+POLARITY=1
+TARGET=id-button-pressed.service
+EXTRA_ARGS=--continue
diff --git a/meta-ibm/recipes-phosphor/gpio/id-button/toggle_identify_led.sh b/meta-ibm/recipes-phosphor/gpio/id-button/toggle_identify_led.sh
new file mode 100644
index 000000000..496ece2b2
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/id-button/toggle_identify_led.sh
@@ -0,0 +1,27 @@
+#!/bin/sh
+# Toggle the state of identify LED Group
+
+SERVICE="xyz.openbmc_project.LED.GroupManager"
+INTERFACE="xyz.openbmc_project.Led.Group"
+PROPERTY="Asserted"
+
+# Get current state
+object=$(busctl tree $SERVICE --list | grep identify)
+led=$(cat /sys/devices/platform/leds/leds/front-id/brightness)
+if [ "$led" == "0" ]; then
+ busctl set-property $SERVICE $object $INTERFACE $PROPERTY b false
+else
+ busctl set-property $SERVICE $object $INTERFACE $PROPERTY b true
+fi
+
+state=$(busctl get-property $SERVICE $object $INTERFACE $PROPERTY \
+ | awk '{print $NF;}')
+
+if [ "$state" == "false" ]; then
+ target='true'
+else
+ target='false'
+fi
+
+# Set target state
+busctl set-property $SERVICE $object $INTERFACE $PROPERTY b $target
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/mihawk/obmc/gpio/phosphor-power-supply-0.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/mihawk/obmc/gpio/phosphor-power-supply-0.conf
new file mode 100755
index 000000000..577548792
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/mihawk/obmc/gpio/phosphor-power-supply-0.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply0
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=200
+NAME=powersupply0
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-005b
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/mihawk/obmc/gpio/phosphor-power-supply-1.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/mihawk/obmc/gpio/phosphor-power-supply-1.conf
new file mode 100755
index 000000000..4d76afb4d
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/mihawk/obmc/gpio/phosphor-power-supply-1.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply1
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=202
+NAME=powersupply1
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-0058
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/phosphor-power-supply-0.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/phosphor-power-supply-0.conf
new file mode 100644
index 000000000..e271d4d63
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/phosphor-power-supply-0.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply0
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=104
+NAME=powersupply0
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-0069
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-0.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-0.conf
new file mode 100644
index 000000000..07564e989
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-0.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply0
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=144
+NAME=powersupply0
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-0068
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-1.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-1.conf
new file mode 100644
index 000000000..304442fe9
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-1.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply1
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=145
+NAME=powersupply1
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-0069
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-2.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-2.conf
new file mode 100644
index 000000000..0f2a9c4f6
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-2.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply2
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=146
+NAME=powersupply2
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-006a
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-3.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-3.conf
new file mode 100644
index 000000000..3ea74acab
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-3.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply3
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=147
+NAME=powersupply3
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-006b
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/swift/obmc/gpio/phosphor-power-supply-1.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/swift/obmc/gpio/phosphor-power-supply-1.conf
new file mode 100644
index 000000000..57f5c7a4c
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/swift/obmc/gpio/phosphor-power-supply-1.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply1
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=143
+NAME=powersupply1
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-0068
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon-tacoma/obmc/gpio/phosphor-power-supply-0.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon-tacoma/obmc/gpio/phosphor-power-supply-0.conf
new file mode 100644
index 000000000..d4f7e1d44
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon-tacoma/obmc/gpio/phosphor-power-supply-0.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply0
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=37
+NAME=powersupply0
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-0069
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon-tacoma/obmc/gpio/phosphor-power-supply-1.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon-tacoma/obmc/gpio/phosphor-power-supply-1.conf
new file mode 100644
index 000000000..029912ea5
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon-tacoma/obmc/gpio/phosphor-power-supply-1.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply1
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=59
+NAME=powersupply1
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-0068
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon/obmc/gpio/phosphor-power-supply-1.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon/obmc/gpio/phosphor-power-supply-1.conf
new file mode 100644
index 000000000..d7681f896
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/witherspoon/obmc/gpio/phosphor-power-supply-1.conf
@@ -0,0 +1,6 @@
+INVENTORY=/system/chassis/motherboard/powersupply1
+DEVPATH=/dev/input/by-path/platform-gpio-keys-event
+KEY=127
+NAME=powersupply1
+DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-0068
+EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
new file mode 100644
index 000000000..04399f83c
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+TMPL_POWERSUPPLY = "phosphor-gpio-presence@.service"
+INSTFMT_POWERSUPPLY = "phosphor-gpio-presence@{0}.service"
+POWERSUPPLY_TGT = "multi-user.target"
+FMT_POWERSUPPLY = "../${TMPL_POWERSUPPLY}:${POWERSUPPLY_TGT}.requires/${INSTFMT_POWERSUPPLY}"
+
+SYSTEMD_LINK_${PN}-presence_append_ibm-ac-server = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_LINK_${PN}-presence_append_mihawk = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_LINK_${PN}-presence_append_rainier = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+
+POWERSUPPLY_ENV_FMT = "obmc/gpio/phosphor-power-supply-{0}.conf"
+
+SYSTEMD_ENVIRONMENT_FILE_${PN}-presence_append_ibm-ac-server = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}-presence_append_mihawk = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}-presence_append_rainier = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"