summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-04-22 21:06:02 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-27 19:52:12 +0300
commite161514219e0dc8a957dabbb8529fb9fcac4e115 (patch)
tree5de46006517d690f5793eec41281d60611228ecd /meta-ibm/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb
parenta3f54c8b8cbd50bc86efdc52cfb7d348d8c19d21 (diff)
downloadopenbmc-e161514219e0dc8a957dabbb8529fb9fcac4e115.tar.xz
meta-ibm: move all meta-witherspoon metadata
The metadata common to all IBM systems is confusingly split between meta-ibm and meta-witherspoon. Move everything to meta-ibm. The meta-ibm README is re-written to more accurately reflect the scope of the layer. Allow the configuration samples (bblayers.conf.sample, local.conf.sample) to be sourced from either meta-ibm or meta-witherspoon until such a time that any workflows and tooling have had the opportunity to move to meta-ibm. (From meta-ibm rev: 6e05ef2e90b214eaf4e43ee7027bbbb1d8d09442) Change-Id: I3ec890d5300f9649c974ea6b9dca93a2e8a889ab Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb')
-rw-r--r--meta-ibm/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb b/meta-ibm/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb
new file mode 100644
index 000000000..2281192fe
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Wistron OEM commands"
+DESCRIPTION = "Wistron OEM commands"
+HOMEPAGE = "https://github.com/openbmc/wistron-ipmi-oem"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "phosphor-ipmi-host"
+DEPENDS += "autoconf-archive-native"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/wistron-ipmi-oem"
+SRCREV = "44cee319dd113335a7885a1ff63a287dc7706682"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+HOSTIPMI_PROVIDER_LIBRARY += "libwistronoem.so"