summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/logging
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-06-12 20:10:52 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-16 23:42:05 +0300
commit20a9cf3abf57ad909549679ff1b8c2c24dbc1ecf (patch)
treeee2a9946f4f153e47e64012ad3cc6952a64485eb /meta-ibm/recipes-phosphor/logging
parent4f5772b0eab3c2f91c207f1a3864c3e67ccfb6a6 (diff)
downloadopenbmc-20a9cf3abf57ad909549679ff1b8c2c24dbc1ecf.tar.xz
ibm-logging: use non-native YAML providers
Remove the extra -native YAML provider dependencies and use the non-native YAML providers obtained via the phosphor-loggging DEPEND. Add a missing python dependency. Simplify task dependency between do_report and do_install. (From meta-ibm rev: f11928baab0df3b845f59786ec934e8fb7272b4d) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I05040555fc98808cf00db150f7dcfcfab807b9da Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/logging')
-rw-r--r--meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb18
1 files changed, 5 insertions, 13 deletions
diff --git a/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb b/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb
index 43a20c0f3..89f8e35dd 100644
--- a/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb
+++ b/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb
@@ -16,10 +16,11 @@ inherit obmc-phosphor-systemd
inherit phosphor-dbus-yaml
DEPENDS += " \
+ ${PYTHON_PN}-pyyaml-native \
+ autoconf-archive-native \
ibm-dbus-interfaces \
- phosphor-logging \
nlohmann-json \
- autoconf-archive-native \
+ phosphor-logging \
sdbusplus \
"
@@ -58,19 +59,10 @@ do_report(){
${S}/create_error_reports.py \
-p ${D}/${datadir}/ibm-logging/policy.json \
- -y ${STAGING_DIR_NATIVE}${yaml_dir} \
+ -y ${STAGING_DIR_TARGET}${yaml_dir} \
-e ${WORKDIR}/build/all_errors.json \
-x ${WORKDIR}/build/policy_crosscheck.txt
}
-addtask report
-
-#Collect all of the error YAML files into our recipe-sysroot-native dir.
-do_report[depends] = " \
- ibm-logging:do_install \
- phosphor-logging-error-logs-native:do_populate_sysroot \
- phosphor-dbus-interfaces-native:do_populate_sysroot \
- openpower-occ-control-native:do_populate_sysroot \
- openpower-debug-collector-native:do_populate_sysroot \
- "
+addtask report after do_install