summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/network
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-04-22 21:06:02 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-27 19:52:12 +0300
commite161514219e0dc8a957dabbb8529fb9fcac4e115 (patch)
tree5de46006517d690f5793eec41281d60611228ecd /meta-ibm/recipes-phosphor/network
parenta3f54c8b8cbd50bc86efdc52cfb7d348d8c19d21 (diff)
downloadopenbmc-e161514219e0dc8a957dabbb8529fb9fcac4e115.tar.xz
meta-ibm: move all meta-witherspoon metadata
The metadata common to all IBM systems is confusingly split between meta-ibm and meta-witherspoon. Move everything to meta-ibm. The meta-ibm README is re-written to more accurately reflect the scope of the layer. Allow the configuration samples (bblayers.conf.sample, local.conf.sample) to be sourced from either meta-ibm or meta-witherspoon until such a time that any workflows and tooling have had the opportunity to move to meta-ibm. (From meta-ibm rev: 6e05ef2e90b214eaf4e43ee7027bbbb1d8d09442) Change-Id: I3ec890d5300f9649c974ea6b9dca93a2e8a889ab Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/network')
-rw-r--r--meta-ibm/recipes-phosphor/network/first-boot-set-mac_%.bbappend2
-rw-r--r--meta-ibm/recipes-phosphor/network/network/ncsi-netlink.service12
-rw-r--r--meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend15
3 files changed, 29 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/network/first-boot-set-mac_%.bbappend b/meta-ibm/recipes-phosphor/network/first-boot-set-mac_%.bbappend
new file mode 100644
index 000000000..fc8f6b861
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/network/first-boot-set-mac_%.bbappend
@@ -0,0 +1,2 @@
+SYSTEMD_SERVICE_${PN}_append_ibm-ac-server = " first-boot-set-mac@eth0.service"
+SYSTEMD_SERVICE_${PN}_append_mihawk = " first-boot-set-mac@eth0.service first-boot-set-mac@eth1.service" \ No newline at end of file
diff --git a/meta-ibm/recipes-phosphor/network/network/ncsi-netlink.service b/meta-ibm/recipes-phosphor/network/network/ncsi-netlink.service
new file mode 100644
index 000000000..890551e7a
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/network/network/ncsi-netlink.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Stop the ethernet link failover
+After=network.service
+
+[Service]
+Restart=no
+ExecStart=/usr/bin/env ncsi-netlink --set -x 2 -p 0 -c 0
+SyslogIdentifier=ncsi-netlink
+Type=oneshot
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend b/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend
new file mode 100644
index 000000000..bcb2d0136
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/network:"
+SRC_URI_append_ibm-ac-server = " file://ncsi-netlink.service"
+SRC_URI_append_mihawk = " file://ncsi-netlink.service"
+
+SYSTEMD_SERVICE_${PN}_append_ibm-ac-server = " ncsi-netlink.service"
+SYSTEMD_SERVICE_${PN}_append_mihawk = " ncsi-netlink.service"
+
+do_install_append_ibm-ac-server() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/ncsi-netlink.service ${D}${systemd_system_unitdir}
+}
+do_install_append_mihawk() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/ncsi-netlink.service ${D}${systemd_system_unitdir}
+}