summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-04-22 21:06:02 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-27 19:52:12 +0300
commite161514219e0dc8a957dabbb8529fb9fcac4e115 (patch)
tree5de46006517d690f5793eec41281d60611228ecd /meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb
parenta3f54c8b8cbd50bc86efdc52cfb7d348d8c19d21 (diff)
downloadopenbmc-e161514219e0dc8a957dabbb8529fb9fcac4e115.tar.xz
meta-ibm: move all meta-witherspoon metadata
The metadata common to all IBM systems is confusingly split between meta-ibm and meta-witherspoon. Move everything to meta-ibm. The meta-ibm README is re-written to more accurately reflect the scope of the layer. Allow the configuration samples (bblayers.conf.sample, local.conf.sample) to be sourced from either meta-ibm or meta-witherspoon until such a time that any workflows and tooling have had the opportunity to move to meta-ibm. (From meta-ibm rev: 6e05ef2e90b214eaf4e43ee7027bbbb1d8d09442) Change-Id: I3ec890d5300f9649c974ea6b9dca93a2e8a889ab Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb')
-rw-r--r--meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb b/meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb
new file mode 100644
index 000000000..3c174c3e8
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Copy error yaml files to known path for elog parsing"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit native
+inherit phosphor-dbus-yaml
+
+require recipes-phosphor/power/phosphor-power.inc
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ SRC=${S}/org/open_power/Witherspoon
+ DEST=${D}${yaml_dir}/org/open_power/Witherspoon
+ install -d ${DEST}
+ install ${SRC}/Fault.errors.yaml ${DEST}
+ install ${SRC}/Fault.metadata.yaml ${DEST}
+}