summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2021-09-29 00:08:04 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-09-30 17:45:25 +0300
commitc184a0f08fbfbf94c84578a6390d5077f922413d (patch)
tree582a03e32b16497708d9d13cdbdaab19f7cc3e25 /meta-ibm/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
parent59574596499bcf503efbeb74e379d86c76fca90b (diff)
downloadopenbmc-c184a0f08fbfbf94c84578a6390d5077f922413d.tar.xz
ibm: Drop hwmon support for water cooled wspoon
There is an upcoming systemd change that doesn't handle what was being done, which was to delay starting phosphor-hwmon from udev until the chassis cooling type was on D-Bus. This commit removes this method and goes down to a single hwmon config file that only supports the air cooled system, which has 2 more fan rotors than the water cooled one does. This change also applies to the similar systems witherspoon-tacoma and swift. Resolves openbmc/phosphor-hwmon/#19. Signed-off-by: Matt Spinler <spinler@us.ibm.com> Change-Id: Ic4ed46a5bf310fb1fef8704dcafc0376c441f8c4
Diffstat (limited to 'meta-ibm/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend')
-rw-r--r--meta-ibm/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend20
1 files changed, 3 insertions, 17 deletions
diff --git a/meta-ibm/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend b/meta-ibm/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
index 7932eb3a0..e4b8e27eb 100644
--- a/meta-ibm/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
+++ b/meta-ibm/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
@@ -4,13 +4,10 @@ EXTRA_OEMESON:append:mihawk = "-Dnegative-errno-on-fail=true"
SRC_URI:append:ibm-ac-server = " \
file://70-hwmon.rules \
- file://70-max31785-hwmon.rules \
- file://start_max31785_hwmon.sh \
"
CHIPS:witherspoon = " \
- bus@1e78a000/i2c-bus@100/max31785@52_air \
- bus@1e78a000/i2c-bus@100/max31785@52_water \
+ bus@1e78a000/i2c-bus@100/max31785@52 \
bus@1e78a000/i2c-bus@100/power-supply@68 \
bus@1e78a000/i2c-bus@100/power-supply@69 \
bus@1e78a000/i2c-bus@100/bmp280@77 \
@@ -22,8 +19,7 @@ CHIPS:witherspoon = " \
bus@1e78a000/i2c-bus@380/tmp275@4a \
"
CHIPS:swift = " \
- bus@1e78a000/i2c-bus@100/max31785@52_air \
- bus@1e78a000/i2c-bus@100/max31785@52_water \
+ bus@1e78a000/i2c-bus@100/max31785@52 \
bus@1e78a000/i2c-bus@100/power-supply@68 \
bus@1e78a000/i2c-bus@100/power-supply@69 \
bus@1e78a000/i2c-bus@440/tmp275@4a \
@@ -61,8 +57,7 @@ CHIPS:mihawk = " \
"
CHIPS:witherspoon-tacoma = " \
- bus@1e78a000/i2c-bus@200/max31785@52_air \
- bus@1e78a000/i2c-bus@200/max31785@52_water \
+ bus@1e78a000/i2c-bus@200/max31785@52 \
bus@1e78a000/i2c-bus@200/power-supply@68 \
bus@1e78a000/i2c-bus@200/power-supply@69 \
bus@1e78a000/i2c-bus@200/bmp280@77 \
@@ -117,12 +112,3 @@ PACKAGECONFIG:append:ibm-ac-server = " max31785-msl"
SYSTEMD_ENVIRONMENT_FILE:max31785-msl:append:ibm-ac-server = " obmc/hwmon-max31785/max31785.conf"
SYSTEMD_LINK:max31785-msl:append:ibm-ac-server = " ../phosphor-max31785-msl@.service:multi-user.target.wants/phosphor-max31785-msl@${MACHINE}.service"
-SYSTEMD_SERVICE:${PN}:append:ibm-ac-server = " max31785-hwmon-helper@.service"
-
-do_install:append:ibm-ac-server() {
- install -d ${D}/${nonarch_base_libdir}/udev/rules.d/
- install -m 0644 ${WORKDIR}/70-max31785-hwmon.rules ${D}/${nonarch_base_libdir}/udev/rules.d/
-
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/start_max31785_hwmon.sh ${D}${bindir}
-}