summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-04-22 21:06:02 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-27 19:52:12 +0300
commite161514219e0dc8a957dabbb8529fb9fcac4e115 (patch)
tree5de46006517d690f5793eec41281d60611228ecd /meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend
parenta3f54c8b8cbd50bc86efdc52cfb7d348d8c19d21 (diff)
downloadopenbmc-e161514219e0dc8a957dabbb8529fb9fcac4e115.tar.xz
meta-ibm: move all meta-witherspoon metadata
The metadata common to all IBM systems is confusingly split between meta-ibm and meta-witherspoon. Move everything to meta-ibm. The meta-ibm README is re-written to more accurately reflect the scope of the layer. Allow the configuration samples (bblayers.conf.sample, local.conf.sample) to be sourced from either meta-ibm or meta-witherspoon until such a time that any workflows and tooling have had the opportunity to move to meta-ibm. (From meta-ibm rev: 6e05ef2e90b214eaf4e43ee7027bbbb1d8d09442) Change-Id: I3ec890d5300f9649c974ea6b9dca93a2e8a889ab Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend')
-rw-r--r--meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend b/meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend
new file mode 100644
index 000000000..6c0cbeba9
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend
@@ -0,0 +1,17 @@
+do_install_append_witherspoon() {
+ DEST=${D}${inventory_envdir}
+ printf "\nEEPROM=/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a400.i2c-bus/i2c-11/11-0051/eeprom" >> ${DEST}/inventory
+}
+
+do_install_append_swift() {
+ DEST=${D}${inventory_envdir}
+ printf "\nEEPROM=/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a340.i2c-bus/i2c-8/8-0051/eeprom" >> ${DEST}/inventory
+}
+
+do_install_append_witherspoon-tacoma() {
+ DEST=${D}${inventory_envdir}
+ printf "FRUS=BMC,ETHERNET" > ${DEST}/inventory
+ printf "\nPATHS=/system/chassis/motherboard/bmc,/system/chassis/motherboard/bmc/eth0" >> ${DEST}/inventory
+ printf "\nEEPROM=/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a600.i2c-bus/i2c-11/11-0051/eeprom" >> ${DEST}/inventory
+}
+