summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:02:49 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:02:49 +0300
commit36caa12533da01d4319c5ffe7613711a0ec7dea7 (patch)
tree591c2077bb14cfd9d23893d32cca71fa7a01bc9c /meta-ibm
parent12bef3e1bf292dec5ac15af9fb41e86f7bcfb0cb (diff)
parent3cec7f5a630c1ddcad058eb76e1f732a5fa20d59 (diff)
downloadopenbmc-36caa12533da01d4319c5ffe7613711a0ec7dea7.tar.xz
Merge tag '0.45' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/conf/conf-notes.txt2
-rw-r--r--meta-ibm/conf/distro/openbmc-witherspoon.conf1
-rw-r--r--meta-ibm/meta-fsp2/recipes-kernel/linux/linux-fsp2.inc1
-rw-r--r--meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend2
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/config.json4
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend6
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-0.conf1
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-1.conf1
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-2.conf1
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-3.conf1
-rw-r--r--meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,everest_associations.json111
-rw-r--r--meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,rainier-2u_associations.json150
-rw-r--r--meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,rainier-4u_associations.json150
-rw-r--r--meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend16
-rw-r--r--meta-ibm/recipes-phosphor/logging/mihawk-phosphor-logging-callouts-native.bb2
-rw-r--r--meta-ibm/recipes-phosphor/openssl/openssl_%.bbappend4
-rw-r--r--meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend6
-rw-r--r--meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb2
-rw-r--r--meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend5
-rw-r--r--meta-ibm/recipes-phosphor/vpd/mihawk-openpower-fru-inventory-native.bb2
-rw-r--r--meta-ibm/recipes-phosphor/vpd/mihawk-openpower-fru-vpd-layout-native.bb2
21 files changed, 454 insertions, 16 deletions
diff --git a/meta-ibm/conf/conf-notes.txt b/meta-ibm/conf/conf-notes.txt
index f8772310a..f56b88b1b 100644
--- a/meta-ibm/conf/conf-notes.txt
+++ b/meta-ibm/conf/conf-notes.txt
@@ -8,3 +8,5 @@ witherspoon:
DISTRO=openbmc-witherspoon MACHINE=witherspoon bitbake obmc-phosphor-image
witherspoon-tacoma:
DISTRO=openbmc-openpower MACHINE=witherspoon-tacoma bitbake obmc-phosphor-image
+rainier:
+DISTRO=openbmc-openpower MACHINE=rainier bitbake obmc-phosphor-image
diff --git a/meta-ibm/conf/distro/openbmc-witherspoon.conf b/meta-ibm/conf/distro/openbmc-witherspoon.conf
index 1ccdeb3f5..f2caf402b 100644
--- a/meta-ibm/conf/distro/openbmc-witherspoon.conf
+++ b/meta-ibm/conf/distro/openbmc-witherspoon.conf
@@ -1,5 +1,4 @@
require conf/distro/openbmc-openpower.conf
require conf/distro/include/phosphor-ubi.inc
-require conf/distro/include/phosphor-tiny.inc
require conf/distro/include/openpower-mrw.inc
require conf/distro/include/openpower-ubi.inc
diff --git a/meta-ibm/meta-fsp2/recipes-kernel/linux/linux-fsp2.inc b/meta-ibm/meta-fsp2/recipes-kernel/linux/linux-fsp2.inc
index 2eb7f5879..37ae6abeb 100644
--- a/meta-ibm/meta-fsp2/recipes-kernel/linux/linux-fsp2.inc
+++ b/meta-ibm/meta-fsp2/recipes-kernel/linux/linux-fsp2.inc
@@ -28,5 +28,4 @@ do_patch_append() {
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
-KERNEL_FEATURES_remove = "phosphor-gpio-keys"
INSANE_SKIP_kernel-vmlinux = "ldflags"
diff --git a/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend b/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
index b6fbb19dc..a134e350b 100644
--- a/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
+++ b/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
@@ -30,7 +30,7 @@ python link_ibm_plugins() {
#Install dump header script from dreport/ibm.d to dreport/include.d
install_dreport_header() {
install -d ${D}${dreport_include_dir}
- install -m 0755 ${S}/tools/dreport.d/ibm.d/* ${D}${dreport_include_dir}/
+ install -m 0755 ${S}/tools/dreport.d/ibm.d/gendumpheader ${D}${dreport_include_dir}/
}
IBM_INSTALL_POSTFUNCS = "install_ibm_plugins link_ibm_plugins"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/config.json b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/config.json
index 5923ccc42..f0df15788 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/config.json
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/config.json
@@ -6,6 +6,7 @@
"allowed_out_of_range_time": 30,
"deviation": 15,
"num_sensors_nonfunc_for_fan_nonfunc": 1,
+ "monitor_start_delay": 20,
"sensors": [
{
"name": "fan0_0",
@@ -23,6 +24,7 @@
"allowed_out_of_range_time": 30,
"deviation": 15,
"num_sensors_nonfunc_for_fan_nonfunc": 1,
+ "monitor_start_delay": 20,
"sensors": [
{
"name": "fan1_0",
@@ -54,6 +56,7 @@
"allowed_out_of_range_time": 30,
"deviation": 15,
"num_sensors_nonfunc_for_fan_nonfunc": 1,
+ "monitor_start_delay": 20,
"sensors": [
{
"name": "fan2_0",
@@ -71,6 +74,7 @@
"allowed_out_of_range_time": 30,
"deviation": 15,
"num_sensors_nonfunc_for_fan_nonfunc": 1,
+ "monitor_start_delay": 20,
"sensors": [
{
"name": "fan3_0",
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 2b6da5946..3d6829a2d 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -56,11 +56,13 @@ FMT_CONTROL_PWRON_witherspoon = "../${TMPL_CONTROL}:${POWERON_TGT}.requires/${IN
SYSTEMD_LINK_${PN}-control_witherspoon += "${@compose_list(d, 'FMT_CONTROL_PWRON', 'OBMC_CHASSIS_INSTANCES')}"
# Enable the use of JSON on the fan applications that support it
-EXTRA_OECONF_append_witherspoon = " --enable-json --disable-json-control"
+PACKAGECONFIG_append_witherspoon = " json"
+EXTRA_OECONF_append_witherspoon = " --disable-json-control"
RDEPENDS_${PN}-presence-tach_append_witherspoon = " phosphor-fan-presence-config"
RDEPENDS_${PN}-monitor_append_witherspoon = " phosphor-fan-monitor-config"
-EXTRA_OECONF_append_rainier = " --enable-json"
+PACKAGECONFIG_append_rainier = " json sensor-monitor"
+FAN_PACKAGES_append_rainier = " sensor-monitor"
RDEPENDS_${PN}-presence-tach_append_rainier = " phosphor-fan-presence-config"
RDEPENDS_${PN}-monitor_append_rainier = " phosphor-fan-monitor-config"
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-0.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-0.conf
index 07564e989..d2c96e643 100644
--- a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-0.conf
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-0.conf
@@ -1,6 +1,7 @@
INVENTORY=/system/chassis/motherboard/powersupply0
DEVPATH=/dev/input/by-path/platform-gpio-keys-event
KEY=144
+DRIVER_BIND_DELAY_MS=1500
NAME=powersupply0
DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-0068
EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-1.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-1.conf
index 304442fe9..655ce07f5 100644
--- a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-1.conf
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-1.conf
@@ -1,6 +1,7 @@
INVENTORY=/system/chassis/motherboard/powersupply1
DEVPATH=/dev/input/by-path/platform-gpio-keys-event
KEY=145
+DRIVER_BIND_DELAY_MS=1500
NAME=powersupply1
DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-0069
EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-2.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-2.conf
index 0f2a9c4f6..0723892d6 100644
--- a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-2.conf
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-2.conf
@@ -1,6 +1,7 @@
INVENTORY=/system/chassis/motherboard/powersupply2
DEVPATH=/dev/input/by-path/platform-gpio-keys-event
KEY=146
+DRIVER_BIND_DELAY_MS=1500
NAME=powersupply2
DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-006a
EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-3.conf b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-3.conf
index 3ea74acab..3dadeefbe 100644
--- a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-3.conf
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor/rainier/obmc/gpio/phosphor-power-supply-3.conf
@@ -1,6 +1,7 @@
INVENTORY=/system/chassis/motherboard/powersupply3
DEVPATH=/dev/input/by-path/platform-gpio-keys-event
KEY=147
+DRIVER_BIND_DELAY_MS=1500
NAME=powersupply3
DRIVERS=/sys/bus/i2c/drivers/ibm-cffps,3-006b
EXTRA_IFACES=xyz.openbmc_project.Inventory.Item.PowerSupply
diff --git a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,everest_associations.json b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,everest_associations.json
new file mode 100644
index 000000000..bf797d94c
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,everest_associations.json
@@ -0,0 +1,111 @@
+{
+ "condition":
+ {
+ "path": "system/chassis/motherboard",
+ "interface": "com.ibm.ipzvpd.VSBP",
+ "property": "IM",
+ "values": [
+ [80, 0, 48, 0]
+ ]
+ },
+ "associations":
+ [
+ {
+ "path": "system/chassis/motherboard/fan0",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan0_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan0_1"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan1",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan1_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan1_1"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan2",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan2_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan2_1"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan3",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan3_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan3_1"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "chassis",
+ "fType": "all_sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan0_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan0_1",
+ "/xyz/openbmc_project/sensors/fan_tach/fan1_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan1_1",
+ "/xyz/openbmc_project/sensors/fan_tach/fan2_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan2_1",
+ "/xyz/openbmc_project/sensors/fan_tach/fan3_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan3_1"
+ ]
+ }
+ ]
+ }
+ ]
+}
+
diff --git a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,rainier-2u_associations.json b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,rainier-2u_associations.json
new file mode 100644
index 000000000..e27de98a8
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,rainier-2u_associations.json
@@ -0,0 +1,150 @@
+{
+ "condition":
+ {
+ "path": "system/chassis/motherboard",
+ "interface": "com.ibm.ipzvpd.VSBP",
+ "property": "IM",
+ "values": [
+ [80, 0, 16, 1],
+ [80, 0, 16, 3]
+ ]
+ },
+ "associations":
+ [
+ {
+ "path": "system/chassis/motherboard/fan0",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan0_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan0_1"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan1",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan1_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan1_1"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan2",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan2_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan2_1"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan3",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan3_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan3_1"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan4",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan4_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan4_1"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan5",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan5_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan5_1"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "chassis",
+ "fType": "all_sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan0_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan0_1",
+ "/xyz/openbmc_project/sensors/fan_tach/fan1_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan1_1",
+ "/xyz/openbmc_project/sensors/fan_tach/fan2_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan2_1",
+ "/xyz/openbmc_project/sensors/fan_tach/fan3_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan3_1",
+ "/xyz/openbmc_project/sensors/fan_tach/fan4_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan4_1"
+ ]
+ }
+ ]
+ }
+ ]
+}
+
diff --git a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,rainier-4u_associations.json b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,rainier-4u_associations.json
new file mode 100644
index 000000000..3ba8fea11
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager/rainier/ibm,rainier-4u_associations.json
@@ -0,0 +1,150 @@
+{
+ "condition":
+ {
+ "path": "system/chassis/motherboard",
+ "interface": "com.ibm.ipzvpd.VSBP",
+ "property": "IM",
+ "values": [
+ [80, 0, 16, 0],
+ [80, 0, 16, 2]
+ ]
+ },
+ "associations":
+ [
+ {
+ "path": "system/chassis/motherboard/fan0",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan0_0"
+ ]
+ },
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "leds"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/led/physical/fan0"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan1",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan1_0"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan2",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan2_0"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan3",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan3_0"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan4",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan4_0"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/motherboard/fan5",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan5_0"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "chassis",
+ "fType": "all_sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/fan0_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan1_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan2_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan3_0",
+ "/xyz/openbmc_project/sensors/fan_tach/fan4_0"
+ ]
+ }
+ ]
+ }
+ ]
+}
+
diff --git a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
index bdc3912d5..af512973a 100644
--- a/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -1,11 +1,23 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
PACKAGECONFIG_append_ibm-ac-server = " associations"
SRC_URI_append_ibm-ac-server = " file://associations.json"
-
-
DEPENDS_append_ibm-ac-server = " inventory-cleanup"
+PACKAGECONFIG_append_rainier = " associations"
+SRC_URI_append_rainier = " \
+ file://ibm,rainier-2u_associations.json \
+ file://ibm,rainier-4u_associations.json \
+ file://ibm,everest_associations.json \
+ "
+
do_install_append_ibm-ac-server() {
install -d ${D}${base_datadir}
install -m 0755 ${WORKDIR}/associations.json ${D}${base_datadir}/associations.json
}
+
+do_install_append_rainier() {
+ install -d ${D}${base_datadir}
+ install -m 0755 ${WORKDIR}/ibm,rainier-2u_associations.json ${D}${base_datadir}/ibm,rainier-2u_associations.json
+ install -m 0755 ${WORKDIR}/ibm,rainier-4u_associations.json ${D}${base_datadir}/ibm,rainier-4u_associations.json
+ install -m 0755 ${WORKDIR}/ibm,everest_associations.json ${D}${base_datadir}/ibm,everest_associations.json
+}
diff --git a/meta-ibm/recipes-phosphor/logging/mihawk-phosphor-logging-callouts-native.bb b/meta-ibm/recipes-phosphor/logging/mihawk-phosphor-logging-callouts-native.bb
index a52e93762..6d4edb337 100644
--- a/meta-ibm/recipes-phosphor/logging/mihawk-phosphor-logging-callouts-native.bb
+++ b/meta-ibm/recipes-phosphor/logging/mihawk-phosphor-logging-callouts-native.bb
@@ -3,8 +3,8 @@ PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-inherit native
inherit phosphor-logging
+inherit native
SRC_URI += "file://callouts.yaml"
diff --git a/meta-ibm/recipes-phosphor/openssl/openssl_%.bbappend b/meta-ibm/recipes-phosphor/openssl/openssl_%.bbappend
index 6ffe5db6c..ebe35e4b2 100644
--- a/meta-ibm/recipes-phosphor/openssl/openssl_%.bbappend
+++ b/meta-ibm/recipes-phosphor/openssl/openssl_%.bbappend
@@ -1,4 +1,4 @@
# Rainier needs ibmtpm2tss which needs ibmswtpm2 which needs openssl
# camellia support
-EXTRA_OECONF_remove_witherspoon-tacoma = " no-camellia"
-EXTRA_OECONF_remove_rainier = " no-camellia"
+DEPRECATED_CRYPTO_FLAGS_remove_witherspoon-tacoma = " no-camellia"
+DEPRECATED_CRYPTO_FLAGS_remove_rainier = " no-camellia"
diff --git a/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index 29a567e27..ce13dc115 100644
--- a/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -26,17 +26,17 @@ RDEPENDS_${PN}-inventory_append_ibm-ac-server = " openpower-fru-vpd openpower-oc
RDEPENDS_${PN}-inventory_append_rainier = " openpower-fru-vpd openpower-occ-control virtual/obmc-gpio-presence"
RDEPENDS_${PN}-inventory_append_mihawk = " openpower-fru-vpd openpower-occ-control virtual/obmc-gpio-presence id-button phosphor-cooling-type"
RDEPENDS_${PN}-fan-control_append_ibm-ac-server = " fan-watchdog"
-RDEPENDS_${PN}-fan-control_append_rainier = " fan-watchdog"
+RDEPENDS_${PN}-fan-control_append_rainier = " fan-watchdog sensor-monitor"
RDEPENDS_${PN}-extras_append_ibm-ac-server = " ${POWER_SERVICE_PACKAGES_AC_SERVER} witherspoon-power-supply-sync phosphor-webui"
RDEPENDS_${PN}-extras_append_rainier = " ${POWER_SERVICE_PACKAGES_RAINIER} webui-vue dbus-sensors phosphor-virtual-sensor"
RDEPENDS_${PN}-extras_append_mihawk = " phosphor-webui phosphor-image-signing wistron-ipmi-oem ${POWER_SERVICE_PACKAGES_AC_SERVER}"
-RDEPENDS_${PN}-extras_append_witherspoon-tacoma = " pldm srvcfg-manager webui-vue biosconfig-manager"
+RDEPENDS_${PN}-extras_append_witherspoon-tacoma = " pldm srvcfg-manager webui-vue biosconfig-manager phosphor-post-code-manager phosphor-host-postd"
RDEPENDS_${PN}-extras_remove_rainier = "obmc-ikvm liberation-fonts uart-render-controller"
RDEPENDS_${PN}-extras_remove_swift = "obmc-ikvm"
RDEPENDS_${PN}-extras_remove_witherspoon-tacoma = "obmc-ikvm liberation-fonts uart-render-controller phosphor-webui"
RDEPENDS_${PN}-logging_append = " ${EXTRA_IBM_LOGGING_PKGS}"
-RDEPENDS_${PN}-extras_append_rainier = " pldm openpower-hw-diags srvcfg-manager biosconfig-manager"
+RDEPENDS_${PN}-extras_append_rainier = " pldm openpower-hw-diags srvcfg-manager biosconfig-manager phosphor-post-code-manager phosphor-host-postd"
RDEPENDS_${PN}-leds_remove_rainier = "phosphor-led-manager-faultmonitor"
RDEPENDS_${PN}-leds_remove_witherspoon-tacoma = "phosphor-led-manager-faultmonitor"
diff --git a/meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb b/meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb
index 3c174c3e8..5ea6cb522 100644
--- a/meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb
+++ b/meta-ibm/recipes-phosphor/power/witherspoon-pfault-analysis-error-native_git.bb
@@ -2,8 +2,8 @@ SUMMARY = "Copy error yaml files to known path for elog parsing"
PR = "r1"
PV = "1.0+git${SRCPV}"
-inherit native
inherit phosphor-dbus-yaml
+inherit native
require recipes-phosphor/power/phosphor-power.inc
diff --git a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 075cddab2..47201122b 100644
--- a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -4,3 +4,8 @@ EXTRA_OEMESON_witherspoon += "-Dwarm-reboot=disabled"
# schedule power on and off operations for the host at some
# time in the future. IBM systems will utilize this feature
RRECOMMENDS_${PN}-host += "${PN}-scheduled-host-transition"
+
+# IBM systems track the state of the hypervisor so bring
+# in the needed package when the host state package is
+# included
+RRECOMMENDS_${PN}-host += "${PN}-hypervisor"
diff --git a/meta-ibm/recipes-phosphor/vpd/mihawk-openpower-fru-inventory-native.bb b/meta-ibm/recipes-phosphor/vpd/mihawk-openpower-fru-inventory-native.bb
index 2edb98d3c..a0f8b81d8 100644
--- a/meta-ibm/recipes-phosphor/vpd/mihawk-openpower-fru-inventory-native.bb
+++ b/meta-ibm/recipes-phosphor/vpd/mihawk-openpower-fru-inventory-native.bb
@@ -3,8 +3,8 @@ PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-inherit native
inherit openpower-fru-vpd
+inherit native
SRC_URI += "file://inventory"
diff --git a/meta-ibm/recipes-phosphor/vpd/mihawk-openpower-fru-vpd-layout-native.bb b/meta-ibm/recipes-phosphor/vpd/mihawk-openpower-fru-vpd-layout-native.bb
index c2332d56e..84cce2cb0 100644
--- a/meta-ibm/recipes-phosphor/vpd/mihawk-openpower-fru-vpd-layout-native.bb
+++ b/meta-ibm/recipes-phosphor/vpd/mihawk-openpower-fru-vpd-layout-native.bb
@@ -3,8 +3,8 @@ PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-inherit native
inherit openpower-fru-vpd
+inherit native
SRC_URI += "file://layout.yaml"