summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2019-06-12 18:18:39 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-27 23:22:42 +0300
commit9c525870b9bc81cb91455cd7b051fda83f686209 (patch)
tree04c09bf33e94813b35deb31577951e37d6c0ebbc /meta-ibm
parent7e27b041d27dbe1abca753d74f82d9fc08f28021 (diff)
downloadopenbmc-9c525870b9bc81cb91455cd7b051fda83f686209.tar.xz
Make dbus monitor policies machine specific
Policy configurations will be loaded by machine within the system meta layer (in this case meta-witherspoon). This allows different machines to have different policies and/or different policy configurations. The .bbappend can be used to alter which policies are used on a machine. The thought here being that most machines within the same system meta layer would use the same policies. However these policies would likely have different configurations, this is where each machine would have its own policy configuration which would be loaded per the policy recipe. Tested: Built witherspoon phosphor-dbus-monitor resulting in no image change Built swift phosphor-dbus-monitor where no polices exist now (From meta-ibm rev: 6275fda44b3fd1a039f6aef55e920b542b8135ef) Change-Id: I9c86e9eb15756236e1e802f18345fb8c7ab5400a Signed-off-by: Matthew Barth <msbarth@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend8
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy.bb2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy/witherspoon/config.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy/config.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy.bb2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/witherspoon/air-cooled.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/air-cooled.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/witherspoon/fan-errors.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/fan-errors.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/witherspoon/water-cooled.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/water-cooled.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy.bb2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy/witherspoon/thermal-policy.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy/thermal-policy.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy.bb2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy/witherspoon/power-supply-policy.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy/power-supply-policy.yaml)0
11 files changed, 8 insertions, 8 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend
index b06da500a..1bef6c361 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend
@@ -1,4 +1,4 @@
-PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " fan-policy"
-PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " thermal-policy"
-PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " power-supply-policy"
-PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " events-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append_witherspoon = " fan-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append_witherspoon = " thermal-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append_witherspoon = " power-supply-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append_witherspoon = " events-policy"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy.bb
index cca184aa4..f456e4287 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy.bb
@@ -1,4 +1,4 @@
-SUMMARY = "Event policy for Witherspoon"
+SUMMARY = "Event policy configuration for meta-witherspoon machines"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy/config.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy/witherspoon/config.yaml
index 5c62d45a3..5c62d45a3 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy/config.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/events/events-policy/witherspoon/config.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy.bb
index 50c8c91e5..12194640d 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy.bb
@@ -1,4 +1,4 @@
-SUMMARY = "Fan policy for Witherspoon"
+SUMMARY = "Fan policy configurations for meta-witherspoon machines"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/air-cooled.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/witherspoon/air-cooled.yaml
index d60aa9179..d60aa9179 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/air-cooled.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/witherspoon/air-cooled.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/fan-errors.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/witherspoon/fan-errors.yaml
index 0c14627d2..0c14627d2 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/fan-errors.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/witherspoon/fan-errors.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/water-cooled.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/witherspoon/water-cooled.yaml
index a279cfefa..a279cfefa 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/water-cooled.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/fan-policy/witherspoon/water-cooled.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy.bb
index ef395b1c4..9fb7d252b 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy.bb
@@ -1,4 +1,4 @@
-SUMMARY = "Thermal policy for Witherspoon"
+SUMMARY = "Thermal policy configuration for meta-witherspoon machines"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy/thermal-policy.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy/witherspoon/thermal-policy.yaml
index 1dd2306e9..1dd2306e9 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy/thermal-policy.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/thermal-policy/witherspoon/thermal-policy.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy.bb
index 774626691..27d60fb34 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy.bb
@@ -1,4 +1,4 @@
-SUMMARY = "Power supply policy for Witherspoon"
+SUMMARY = "Power supply policy configuration for meta-witherspoon machines"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy/power-supply-policy.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy/witherspoon/power-supply-policy.yaml
index 20141c9c3..20141c9c3 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy/power-supply-policy.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/power-supply-policy/witherspoon/power-supply-policy.yaml