summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-18 02:05:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-24 00:26:25 +0300
commitf2b3f9e032827f47abd2189d31555df2fe4628dd (patch)
tree4c36c24b9f8330aff8cfc1e686b7f2a057c49aad /meta-ibm
parent32cb84972657c1d57e13b1ee7a2c988b5566b704 (diff)
downloadopenbmc-f2b3f9e032827f47abd2189d31555df2fe4628dd.tar.xz
meta-ibm: use machine overrides instead of distro
Using a distro feature here might be a case of too much abstraction. Instead, just enable them because that is what is desired for those systems. This is slightly easier to comprehend. Revisit, if at a later time, several phosphor-software-manager users enable signature verification and file syncing when using UBI (making the abstraction useful). If/when that occurs, those configure options and packages should be enabled via the distro feature in the base recipe and not in a bbappend. (From meta-ibm rev: 50eebe208babfe35ccd5a3ed8d560669381e82a5) Change-Id: Ic4ac7f89eeb4575e6dabb68bb61aa55835316864 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend8
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend3
2 files changed, 7 insertions, 4 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
index b58fc3b06..13c434d16 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
@@ -2,8 +2,10 @@ BMC_RW_MTD = "bmc"
BMC_RO_MTD = "alt-bmc+bmc"
BMC_KERNEL_MTD = "bmc"
-# Enable signature verification by DISTRO_FEATURE obmc-ubi-fs
-PACKAGECONFIG_append_df-obmc-ubi-fs = " verify_signature"
+# Enable signature verification
+PACKAGECONFIG_append_witherspoon = " verify_signature"
+PACKAGECONFIG_append_swift = " verify_signature"
# Enable sync of persistent files to the alternate BMC chip
-PACKAGECONFIG_append_df-obmc-ubi-fs = " sync_bmc_files"
+PACKAGECONFIG_append_witherspoon = " sync_bmc_files"
+PACKAGECONFIG_append_swift = " sync_bmc_files"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index 6e0db1e62..92b48f92a 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -2,4 +2,5 @@ RDEPENDS_${PN}-inventory += "openpower-fru-vpd openpower-occ-control phosphor-co
RDEPENDS_${PN}-fan-control += "witherspoon-fan-watchdog"
RDEPENDS_${PN}-extras += "witherspoon-pfault-analysis witherspoon-power-supply-sync phosphor-webui"
-${PN}-software-extras_df-obmc-ubi-fs += "phosphor-software-manager-sync"
+${PN}-software-extras_append_witherspoon = " phosphor-software-manager-sync"
+${PN}-software-extras_append_swift = " phosphor-software-manager-sync"