summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-01-08 18:43:11 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-01-12 16:52:56 +0300
commit0c784cec452036b789fc8b9b6b14a403e578c7bb (patch)
tree3b97d8a4d23447ad66b1fc43939effd22764f42b /meta-ibm
parentd31ef576e206582ac9a40f080782ee3699dd3b68 (diff)
downloadopenbmc-0c784cec452036b789fc8b9b6b14a403e578c7bb.tar.xz
gpio-presence: wants relationship with multi-user
The rule of thumb within OpenBMC is to utilize a wants relationship with targets, especially the multi-user.target. This follows the general design of always allowing the system to continue whenever possible. For example I'm doing some bringup in simulation where these services are not required, but their failure is impacting my ability to reach a successful multi-user.target state which impacts other targets that depend on it. Tested: - Verified multi-user.target completes successfully now on my bringup system (From meta-ibm rev: f2f6d38efdfa1a88a5f41b9871e0d3aa76f193d1) Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I687fbbb7006a3d9b9abe1d308802914d64224410 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
index 04399f83c..e5af8850c 100644
--- a/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
+++ b/meta-ibm/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
TMPL_POWERSUPPLY = "phosphor-gpio-presence@.service"
INSTFMT_POWERSUPPLY = "phosphor-gpio-presence@{0}.service"
POWERSUPPLY_TGT = "multi-user.target"
-FMT_POWERSUPPLY = "../${TMPL_POWERSUPPLY}:${POWERSUPPLY_TGT}.requires/${INSTFMT_POWERSUPPLY}"
+FMT_POWERSUPPLY = "../${TMPL_POWERSUPPLY}:${POWERSUPPLY_TGT}.wants/${INSTFMT_POWERSUPPLY}"
SYSTEMD_LINK_${PN}-presence_append_ibm-ac-server = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
SYSTEMD_LINK_${PN}-presence_append_mihawk = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"