summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2020-04-02 07:59:34 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-14 22:26:07 +0300
commit35c33cc59e459409e6172bc2ba71adcb7e0ce6ff (patch)
tree8a0feec190c1d40c4c692a4994c83b7b34e5811f /meta-ibm
parent1688b154fead9646a2e023363d8ebf84fcaf9743 (diff)
downloadopenbmc-35c33cc59e459409e6172bc2ba71adcb7e0ce6ff.tar.xz
meta-witherspoon: tacoma: Enable concurrent console servers
The design uses the same configuration as Rainier. (From meta-ibm rev: 499fc3dae676b969abe64ec58aaa3021910c7bfa) Change-Id: Id8520b86804d2495e37a1b092491ceeddc2b11a0 Signed-off-by: Andrew Jeffery <andrew@aj.id.au> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf1
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART0.conf (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/obmc-console.conf)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console_%.bbappend18
4 files changed, 22 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf
new file mode 100644
index 000000000..7264e8278
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf
@@ -0,0 +1 @@
+socket-id = guests
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/obmc-console.conf b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART0.conf
index 010d82468..010d82468 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/obmc-console.conf
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART0.conf
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf
new file mode 100644
index 000000000..e98587f15
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf
@@ -0,0 +1,3 @@
+lpc-address = 0x2f8
+sirq = 3
+socket-id = guests
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console_%.bbappend
index 75ec2e0ba..c10b7ce04 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console_%.bbappend
@@ -44,3 +44,21 @@ EXTRA_OECONF_append_rainier = " --enable-concurrent-servers"
do_install_append_rainier() {
install_concurrent_console_config
}
+
+SRC_URI_append_witherspoon-tacoma = " file://client.2201.conf"
+SRC_URI_append_witherspoon-tacoma = " file://server.ttyVUART1.conf"
+
+REGISTERED_SERVICES_${PN}_append_witherspoon-tacoma = " obmc_console_guests:tcp:2201:"
+
+SYSTEMD_SERVICE_${PN}_append_witherspoon-tacoma = " obmc-console-ssh@2200.service \
+ obmc-console-ssh@2201.service \
+ "
+SYSTEMD_SERVICE_${PN}_remove_witherspoon-tacoma = "obmc-console-ssh.socket"
+
+FILES_${PN}_remove_witherspoon-tacoma = "/lib/systemd/system/obmc-console-ssh@.service.d/use-socket.conf"
+
+EXTRA_OECONF_append_witherspoon-tacoma = " --enable-concurrent-servers"
+
+do_install_append_witherspoon-tacoma() {
+ install_concurrent_console_config
+}