summaryrefslogtreecommitdiff
path: root/meta-inspur/meta-fp5280g2/recipes-phosphor/inventory/phosphor-inventory-manager-chassis.bb
diff options
context:
space:
mode:
authorGeorge Liu <liuxiwei@inspur.com>2020-07-24 11:33:05 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-10-06 01:10:25 +0300
commit56da762e1dc443e8e9eac3cabf31ec205d1f18e8 (patch)
tree4fae697a2ad40d5a68edd37f60a45d5b323db6e8 /meta-inspur/meta-fp5280g2/recipes-phosphor/inventory/phosphor-inventory-manager-chassis.bb
parente8860cd0e1d3d85802d12cf30c54ec15fa99d28c (diff)
downloadopenbmc-56da762e1dc443e8e9eac3cabf31ec205d1f18e8.tar.xz
fp5280g2: inventory: Add Chassis interface to the chassis
Create the xyz.openbmc_project.Inventory.Item.Chassis interface on the /system/chassis inventory item at startup. (From meta-inspur rev: 7cd52a29282b3a6f4d291d16cec1bcaeb16ab2d0) Signed-off-by: George Liu <liuxiwei@inspur.com> Change-Id: I514c7b77583992357696b5eb09df52b4770efa23 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-inspur/meta-fp5280g2/recipes-phosphor/inventory/phosphor-inventory-manager-chassis.bb')
-rw-r--r--meta-inspur/meta-fp5280g2/recipes-phosphor/inventory/phosphor-inventory-manager-chassis.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-inspur/meta-fp5280g2/recipes-phosphor/inventory/phosphor-inventory-manager-chassis.bb b/meta-inspur/meta-fp5280g2/recipes-phosphor/inventory/phosphor-inventory-manager-chassis.bb
new file mode 100644
index 000000000..11ff66261
--- /dev/null
+++ b/meta-inspur/meta-fp5280g2/recipes-phosphor/inventory/phosphor-inventory-manager-chassis.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Add Chassis interface for inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+PROVIDES += "virtual/phosphor-inventory-manager-chassis"
+S = "${WORKDIR}"
+
+SRC_URI = "file://chassis.yaml"
+
+do_install() {
+ install -D chassis.yaml ${D}${base_datadir}/events.d/chassis.yaml
+}
+
+FILES_${PN} += "${base_datadir}/events.d/chassis.yaml"