summaryrefslogtreecommitdiff
path: root/meta-inspur/meta-fp5280g2/recipes-phosphor/power/phosphor-fp5280g2-psu-update.bb
diff options
context:
space:
mode:
authorChicago Duan <duanzhijia01@inspur.com>2020-05-08 11:35:52 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-29 17:33:43 +0300
commite9e9da9fdfa74074f9e7923f83631b19dd4921bd (patch)
treebe92060e6686fcac28e7f7c11fdccdc2caee2675 /meta-inspur/meta-fp5280g2/recipes-phosphor/power/phosphor-fp5280g2-psu-update.bb
parent5b59eee5b8ef3c294bcd3c45253ca550136a62a5 (diff)
downloadopenbmc-e9e9da9fdfa74074f9e7923f83631b19dd4921bd.tar.xz
inspur: fp5280g2: Add fp5280g2 psu fw update function
Add phosphor-psu-software-manager and use inspur specific binary tool to update fp5280g2's psu firmware. (From meta-inspur rev: 38802b27a5b96f2d406f17805e77971fc76e46ec) Signed-off-by: Chicago Duan <duanzhijia01@inspur.com> Change-Id: I366453eda485e6f96cbb6ef8672ea4011abf463e Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-inspur/meta-fp5280g2/recipes-phosphor/power/phosphor-fp5280g2-psu-update.bb')
-rw-r--r--meta-inspur/meta-fp5280g2/recipes-phosphor/power/phosphor-fp5280g2-psu-update.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-inspur/meta-fp5280g2/recipes-phosphor/power/phosphor-fp5280g2-psu-update.bb b/meta-inspur/meta-fp5280g2/recipes-phosphor/power/phosphor-fp5280g2-psu-update.bb
new file mode 100644
index 000000000..3cc63868a
--- /dev/null
+++ b/meta-inspur/meta-fp5280g2/recipes-phosphor/power/phosphor-fp5280g2-psu-update.bb
@@ -0,0 +1,20 @@
+HOMEPAGE = "https://github.com/inspur-bmc/fp5280g2-psu-update-tool"
+
+SRC_URI = "git://github.com/inspur-bmc/fp5280g2-psu-update-tool"
+
+SRCREV = "d9cc0d32197163197c41dc1c5e4613edd7ebacf1"
+
+SUMMARY = "Phosphor FP5280G2 PSU Update Tool"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+S = "${WORKDIR}/git/"
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/fp5280g2-psu-update ${D}${bindir}/fp5280g2-psu-update
+}
+
+INSANE_SKIP_${PN} = "ldflags"
+