summaryrefslogtreecommitdiff
path: root/meta-inspur/meta-on5263m5
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-06-19 01:34:17 +0300
committerEd Tanous <ed.tanous@intel.com>2019-06-19 01:34:17 +0300
commitaea9e7cbf9bd7677228747a8e7bab4d22bc80103 (patch)
tree94f59c0b6566fbd9c459918177ceb49e53128aa7 /meta-inspur/meta-on5263m5
parent10bc2ef852277cf8e9858f75cea9f55b482bf85b (diff)
parentf3b2f5e9e3e0fe093d5ab1e3dcdede0aa3000450 (diff)
downloadopenbmc-aea9e7cbf9bd7677228747a8e7bab4d22bc80103.tar.xz
Merge branch 'master' of ssh://github.com/openbmc/openbmc into intel
Diffstat (limited to 'meta-inspur/meta-on5263m5')
-rw-r--r--meta-inspur/meta-on5263m5/conf/layer.conf6
-rw-r--r--meta-inspur/meta-on5263m5/conf/machine/on5263m5.conf8
-rw-r--r--meta-inspur/meta-on5263m5/recipes-inspur/inspur-uuid/inspur-uuid_git.bb27
-rw-r--r--meta-inspur/meta-on5263m5/recipes-inspur/packagegroups/packagegroup-inspur-apps.bb46
-rw-r--r--meta-inspur/meta-on5263m5/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json47
-rw-r--r--meta-inspur/meta-on5263m5/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend1
-rw-r--r--meta-inspur/meta-on5263m5/recipes-phosphor/workbook/on5263m5-config.bb38
-rw-r--r--meta-inspur/meta-on5263m5/recipes-phosphor/workbook/on5263m5-config/On5263m5.py48
8 files changed, 81 insertions, 140 deletions
diff --git a/meta-inspur/meta-on5263m5/conf/layer.conf b/meta-inspur/meta-on5263m5/conf/layer.conf
index 93db95c5c..b49d300bf 100644
--- a/meta-inspur/meta-on5263m5/conf/layer.conf
+++ b/meta-inspur/meta-on5263m5/conf/layer.conf
@@ -6,7 +6,5 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "on5263m5-layer"
-BBFILE_PATTERN_on5263m5-layer = ""
-BBFILE_PRIORITY_on5263m5-layer = "5"
-LAYERSERIES_COMPAT_on5263m5-layer = "sumo"
-
+BBFILE_PATTERN_on5263m5-layer = "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_on5263m5-layer = "thud warrior"
diff --git a/meta-inspur/meta-on5263m5/conf/machine/on5263m5.conf b/meta-inspur/meta-on5263m5/conf/machine/on5263m5.conf
index ba8ce1067..1c217913e 100644
--- a/meta-inspur/meta-on5263m5/conf/machine/on5263m5.conf
+++ b/meta-inspur/meta-on5263m5/conf/machine/on5263m5.conf
@@ -3,10 +3,14 @@ KERNEL_DEVICETREE = "${KMACHINE}-bmc-inspur-${MACHINE}.dtb"
require conf/machine/include/ast2500.inc
require conf/machine/include/obmc-bsp-common.inc
-require conf/machine/include/inspur.inc
+
+PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-inspur-apps"
+PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-inspur-apps"
+PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-inspur-apps"
+PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-inspur-apps"
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-kcs"
UBOOT_MACHINE = "ast_g5_phy_config"
FLASH_SIZE = "32768"
-VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"
diff --git a/meta-inspur/meta-on5263m5/recipes-inspur/inspur-uuid/inspur-uuid_git.bb b/meta-inspur/meta-on5263m5/recipes-inspur/inspur-uuid/inspur-uuid_git.bb
new file mode 100644
index 000000000..2174da950
--- /dev/null
+++ b/meta-inspur/meta-on5263m5/recipes-inspur/inspur-uuid/inspur-uuid_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Inspur Identify LED Controller daemon"
+DESCRIPTION = "Daemon to trigger actions on a inspur identify LED"
+
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+inherit systemd
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "sdeventplus"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "phosphor-logging"
+DEPENDS += "gpioplus"
+
+
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.inspur.identify_led.controller.service"
+
+SRC_URI = "git://github.com/inspur-bmc/inspur-uuid.git"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "703633f2e81ba4d59eef74910c019e91d2bac63c"
+
+S = "${WORKDIR}/git"
diff --git a/meta-inspur/meta-on5263m5/recipes-inspur/packagegroups/packagegroup-inspur-apps.bb b/meta-inspur/meta-on5263m5/recipes-inspur/packagegroups/packagegroup-inspur-apps.bb
new file mode 100644
index 000000000..517b9eb77
--- /dev/null
+++ b/meta-inspur/meta-on5263m5/recipes-inspur/packagegroups/packagegroup-inspur-apps.bb
@@ -0,0 +1,46 @@
+SUMMARY = "OpenBMC for Inspur - Applications"
+PR = "r1"
+
+inherit packagegroup
+
+PROVIDES = "${PACKAGES}"
+PACKAGES = " \
+ ${PN}-chassis \
+ ${PN}-fans \
+ ${PN}-flash \
+ ${PN}-system \
+ "
+
+PROVIDES += "virtual/obmc-chassis-mgmt"
+PROVIDES += "virtual/obmc-fan-mgmt"
+PROVIDES += "virtual/obmc-flash-mgmt"
+PROVIDES += "virtual/obmc-system-mgmt"
+
+RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt"
+RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt"
+
+SUMMARY_${PN}-chassis = "Inspur Chassis"
+RDEPENDS_${PN}-chassis = " \
+ obmc-control-chassis \
+ obmc-op-control-power \
+ obmc-host-failure-reboots \
+ "
+
+SUMMARY_${PN}-fans = "Inspur Fans"
+RDEPENDS_${PN}-fans = ""
+
+SUMMARY_${PN}-flash = "Inspur Flash"
+RDEPENDS_${PN}-flash = " \
+ obmc-flash-bmc \
+ obmc-mgr-download \
+ obmc-control-bmc \
+ "
+
+SUMMARY_${PN}-system = "Inspur System"
+RDEPENDS_${PN}-system = " \
+ bmcweb \
+ entity-manager \
+ phosphor-webui \
+ "
diff --git a/meta-inspur/meta-on5263m5/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-inspur/meta-on5263m5/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
deleted file mode 100644
index b02709ec2..000000000
--- a/meta-inspur/meta-on5263m5/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
+++ /dev/null
@@ -1,47 +0,0 @@
-{
- "gpio_configs": {
-
- "power_config": {
- "power_good_in": "PGOOD",
- "power_up_outs": [
- {"name": "POWER_UP_PIN", "polarity": true}
- ],
- "reset_outs": [
- {"name": "RESET_OUT", "polarity": false}
- ]
- }
- },
-
- "gpio_definitions": [
- {
- "name": "PGOOD",
- "pin": "AB3",
- "direction": "in"
- },
- {
- "name": "POWER_BUTTON",
- "pin": "E2",
- "direction": "both"
- },
- {
- "name": "POWER_UP_PIN",
- "pin": "E3",
- "direction": "out"
- },
- {
- "name": "RESET_BUTTON",
- "pin": "E0",
- "direction": "both"
- },
- {
- "name": "RESET_OUT",
- "pin": "E1",
- "direction": "out"
- },
- {
- "name": "ID_BUTTON",
- "pin": "S6",
- "direction": "both"
- }
- ]
-}
diff --git a/meta-inspur/meta-on5263m5/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-inspur/meta-on5263m5/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
deleted file mode 100644
index 72d991c7e..000000000
--- a/meta-inspur/meta-on5263m5/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-inspur/meta-on5263m5/recipes-phosphor/workbook/on5263m5-config.bb b/meta-inspur/meta-on5263m5/recipes-phosphor/workbook/on5263m5-config.bb
deleted file mode 100644
index 1b6e926b9..000000000
--- a/meta-inspur/meta-on5263m5/recipes-phosphor/workbook/on5263m5-config.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-SUMMARY = "Inspur On5263 board wiring"
-DESCRIPTION = "Board wiring information for the On5263 system."
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${INSPURBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit allarch
-inherit setuptools
-inherit pythonnative
-
-PROVIDES += "virtual/obmc-inventory-data"
-RPROVIDES_${PN} += "virtual-obmc-inventory-data"
-
-DEPENDS += "python"
-
-S = "${WORKDIR}"
-SRC_URI += "file://On5263m5.py"
-
-# the following is unnecessary.
-python() {
- machine = d.getVar('MACHINE', True).capitalize() + '.py'
- d.setVar('_config_in_skeleton', machine)
-}
-
-do_make_setup() {
- cp ${S}/${_config_in_skeleton} \
- ${S}/obmc_system_config.py
- cat <<EOF > ${S}/setup.py
-from distutils.core import setup
-
-setup(name='${BPN}',
- version='${PR}',
- py_modules=['obmc_system_config'],
- )
-EOF
-}
-
-addtask make_setup after do_patch before do_configure
diff --git a/meta-inspur/meta-on5263m5/recipes-phosphor/workbook/on5263m5-config/On5263m5.py b/meta-inspur/meta-on5263m5/recipes-phosphor/workbook/on5263m5-config/On5263m5.py
deleted file mode 100644
index ca7cb2098..000000000
--- a/meta-inspur/meta-on5263m5/recipes-phosphor/workbook/on5263m5-config/On5263m5.py
+++ /dev/null
@@ -1,48 +0,0 @@
-## System states
-## state can change to next state in 2 ways:
-## - a process emits a GotoSystemState signal with state name to goto
-## - objects specified in EXIT_STATE_DEPEND have started
-SYSTEM_STATES = [
- 'BASE_APPS',
- 'BMC_STARTING',
- 'BMC_READY',
- 'HOST_POWERING_ON',
- 'HOST_POWERED_ON',
- 'HOST_BOOTING',
- 'HOST_BOOTED',
- 'HOST_POWERED_OFF',
-]
-
-EXIT_STATE_DEPEND = {
- 'BASE_APPS' : {
- '/xyz/openbmc_poroject/sensors': 0,
- },
- 'BMC_STARTING' : {
- '/xyz/openbmc_project/control/chassis0': 0,
- },
-}
-
-FRU_INSTANCES = {}
-
-# I believe these numbers need to match the yaml file used to create the c++ ipmi map.
-# the devices have types, but I don't believe that factors in here, I think these are
-# just unique IDs.
-ID_LOOKUP = {
- 'FRU' : {},
- # The number at the end needs to match the FRU ID.
- # https://github.com/openbmc/skeleton/blob/master/pysystemmgr/system_manager.py#L143
- # The parameter for it is of type 'y' (unsigned 8-bit integer) presumably decimal?
- 'FRU_STR' : {},
- 'SENSOR' : {},
- 'GPIO_PRESENT' : {}
-}
-
-GPIO_CONFIG = {}
-HWMON_CONFIG = {}
-GPIO_CONFIGS = {}
-
-# Miscellaneous non-poll sensor with system specific properties.
-# The sensor id is the same as those defined in ID_LOOKUP['SENSOR'].
-MISC_SENSORS = {}
-
-# vim: tabstop=8 expandtab shiftwidth=4 softtabstop=4