summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc/meta-common/recipes-intel/packagegroups
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2021-01-07 00:04:58 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-01-25 16:42:47 +0300
commit6510566f018b664b901835547891e08024616811 (patch)
treeda318cb1c7a59a4f172acb5052dbb2bd02bc0f8a /meta-intel-openbmc/meta-common/recipes-intel/packagegroups
parent5ff169f12d35c5e55ccc88d0e064d8cd39f87031 (diff)
downloadopenbmc-6510566f018b664b901835547891e08024616811.tar.xz
Move meta-intel to meta-intel-openbmc
meta-intel conflicts with the upstream yocto meta layer of the same name. This commit renames meta-intel to meta-intel-openbmc and updates all the relevant bblayers files with the new name. This is to pave the way for allowing the yocto meta-intel in the tree, which would allow the use of generic-x86 machine type, which would allow building and running tests natively. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: Ia19a7a4a10245c1c2f85f6da216997cb6a836daa
Diffstat (limited to 'meta-intel-openbmc/meta-common/recipes-intel/packagegroups')
-rw-r--r--meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb b/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
new file mode 100644
index 000000000..8c0dfbf1c
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
@@ -0,0 +1,47 @@
+SUMMARY = "OpenBMC for Intel - Applications"
+PR = "r1"
+
+inherit packagegroup
+
+PROVIDES = "${PACKAGES}"
+PACKAGES = " \
+ ${PN}-chassis \
+ ${PN}-fans \
+ ${PN}-flash \
+ ${PN}-system \
+ "
+
+PROVIDES += "virtual/obmc-chassis-mgmt"
+PROVIDES += "virtual/obmc-fan-mgmt"
+PROVIDES += "virtual/obmc-flash-mgmt"
+PROVIDES += "virtual/obmc-system-mgmt"
+
+RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt"
+RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt"
+
+SUMMARY_${PN}-chassis = "Intel Chassis"
+RDEPENDS_${PN}-chassis = " \
+ x86-power-control \
+ obmc-host-failure-reboots \
+ "
+
+SUMMARY_${PN}-fans = "Intel Fans"
+RDEPENDS_${PN}-fans = " \
+ phosphor-pid-control \
+ "
+
+SUMMARY_${PN}-flash = "Intel Flash"
+RDEPENDS_${PN}-flash = " \
+ obmc-control-bmc \
+ "
+
+SUMMARY_${PN}-system = "Intel System"
+RDEPENDS_${PN}-system = " \
+ bmcweb \
+ entity-manager \
+ intel-ipmi-oem \
+ dbus-sensors \
+ phosphor-webui \
+ "