summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc/meta-common/recipes-intel
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2021-01-07 00:04:58 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-01-25 16:42:47 +0300
commit6510566f018b664b901835547891e08024616811 (patch)
treeda318cb1c7a59a4f172acb5052dbb2bd02bc0f8a /meta-intel-openbmc/meta-common/recipes-intel
parent5ff169f12d35c5e55ccc88d0e064d8cd39f87031 (diff)
downloadopenbmc-6510566f018b664b901835547891e08024616811.tar.xz
Move meta-intel to meta-intel-openbmc
meta-intel conflicts with the upstream yocto meta layer of the same name. This commit renames meta-intel to meta-intel-openbmc and updates all the relevant bblayers files with the new name. This is to pave the way for allowing the yocto meta-intel in the tree, which would allow the use of generic-x86 machine type, which would allow building and running tests natively. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: Ia19a7a4a10245c1c2f85f6da216997cb6a836daa
Diffstat (limited to 'meta-intel-openbmc/meta-common/recipes-intel')
-rwxr-xr-xmeta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb32
-rw-r--r--meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb47
-rw-r--r--meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb23
3 files changed, 102 insertions, 0 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb b/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
new file mode 100755
index 000000000..20bd1bd36
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Intel OEM IPMI commands"
+DESCRIPTION = "Intel OEM IPMI commands"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a4edad4aed50f39a66d098d74b265b"
+
+SRC_URI = "git://github.com/openbmc/intel-ipmi-oem"
+SRCREV = "6d6dc7ad721268a66adecca423716ce9fcf3838b"
+
+S = "${WORKDIR}/git"
+PV = "0.1+git${SRCPV}"
+
+DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd intel-dbus-interfaces libgpiod"
+
+inherit cmake obmc-phosphor-ipmiprovider-symlink
+
+EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
+
+LIBRARY_NAMES = "libzinteloemcmds.so"
+
+HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
+NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
+
+do_install_append(){
+ install -d ${D}${includedir}/intel-ipmi-oem
+ install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/intel-ipmi-oem
+}
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb b/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
new file mode 100644
index 000000000..8c0dfbf1c
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
@@ -0,0 +1,47 @@
+SUMMARY = "OpenBMC for Intel - Applications"
+PR = "r1"
+
+inherit packagegroup
+
+PROVIDES = "${PACKAGES}"
+PACKAGES = " \
+ ${PN}-chassis \
+ ${PN}-fans \
+ ${PN}-flash \
+ ${PN}-system \
+ "
+
+PROVIDES += "virtual/obmc-chassis-mgmt"
+PROVIDES += "virtual/obmc-fan-mgmt"
+PROVIDES += "virtual/obmc-flash-mgmt"
+PROVIDES += "virtual/obmc-system-mgmt"
+
+RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt"
+RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt"
+
+SUMMARY_${PN}-chassis = "Intel Chassis"
+RDEPENDS_${PN}-chassis = " \
+ x86-power-control \
+ obmc-host-failure-reboots \
+ "
+
+SUMMARY_${PN}-fans = "Intel Fans"
+RDEPENDS_${PN}-fans = " \
+ phosphor-pid-control \
+ "
+
+SUMMARY_${PN}-flash = "Intel Flash"
+RDEPENDS_${PN}-flash = " \
+ obmc-control-bmc \
+ "
+
+SUMMARY_${PN}-system = "Intel System"
+RDEPENDS_${PN}-system = " \
+ bmcweb \
+ entity-manager \
+ intel-ipmi-oem \
+ dbus-sensors \
+ phosphor-webui \
+ "
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb b/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
new file mode 100644
index 000000000..0399ad6c9
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "PFR Manager Service"
+DESCRIPTION = "Daemon to handle all PFR functionalities"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
+inherit cmake systemd
+
+SRC_URI = "git://github.com/openbmc/pfr-manager"
+
+PV = "0.1+git${SRCPV}"
+SRCREV = "0884191b6478bdd787852ab9d290caaeb7816454"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.PFR.Manager.service"
+
+DEPENDS += " \
+ sdbusplus \
+ phosphor-logging \
+ boost \
+ i2c-tools \
+ libgpiod \
+ "