summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc/meta-common/recipes-phosphor/webui
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2021-01-07 00:04:58 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-01-25 16:42:47 +0300
commit6510566f018b664b901835547891e08024616811 (patch)
treeda318cb1c7a59a4f172acb5052dbb2bd02bc0f8a /meta-intel-openbmc/meta-common/recipes-phosphor/webui
parent5ff169f12d35c5e55ccc88d0e064d8cd39f87031 (diff)
downloadopenbmc-6510566f018b664b901835547891e08024616811.tar.xz
Move meta-intel to meta-intel-openbmc
meta-intel conflicts with the upstream yocto meta layer of the same name. This commit renames meta-intel to meta-intel-openbmc and updates all the relevant bblayers files with the new name. This is to pave the way for allowing the yocto meta-intel in the tree, which would allow the use of generic-x86 machine type, which would allow building and running tests natively. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: Ia19a7a4a10245c1c2f85f6da216997cb6a836daa
Diffstat (limited to 'meta-intel-openbmc/meta-common/recipes-phosphor/webui')
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui/config.json8
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend8
2 files changed, 16 insertions, 0 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui/config.json b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui/config.json
new file mode 100644
index 000000000..1543a6249
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui/config.json
@@ -0,0 +1,8 @@
+{
+ "customKeyEnable": true,
+ "keyType" : "VT100+",
+ "customConsoleDisplaySize": {
+ "width": 100,
+ "height": 32
+ }
+}
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
new file mode 100644
index 000000000..590e9e629
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
+
+SRC_URI_append_intel = " file://config.json"
+
+do_compile_prepend_intel() {
+ cp -r ${WORKDIR}/config.json ${S}/
+}
+