summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc/meta-common/recipes-phosphor
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2021-01-07 00:04:58 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-01-25 16:42:47 +0300
commit6510566f018b664b901835547891e08024616811 (patch)
treeda318cb1c7a59a4f172acb5052dbb2bd02bc0f8a /meta-intel-openbmc/meta-common/recipes-phosphor
parent5ff169f12d35c5e55ccc88d0e064d8cd39f87031 (diff)
downloadopenbmc-6510566f018b664b901835547891e08024616811.tar.xz
Move meta-intel to meta-intel-openbmc
meta-intel conflicts with the upstream yocto meta layer of the same name. This commit renames meta-intel to meta-intel-openbmc and updates all the relevant bblayers files with the new name. This is to pave the way for allowing the yocto meta-intel in the tree, which would allow the use of generic-x86 machine type, which would allow building and running tests natively. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: Ia19a7a4a10245c1c2f85f6da216997cb6a836daa
Diffstat (limited to 'meta-intel-openbmc/meta-common/recipes-phosphor')
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb11
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb31
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend1
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control/phosphor-pid-control.service12
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend5
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend5
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend5
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb/ipmb-channels.json16
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend8
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb19
-rwxr-xr-xmeta-intel-openbmc/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml36
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui/config.json8
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend8
14 files changed, 167 insertions, 0 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
new file mode 100644
index 000000000..0d1d016fe
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
@@ -0,0 +1,11 @@
+SUMMARY="Add /com/intel namespace to phosphor-mapper"
+DESCRIPTION="Add the /com/intel path namespace and \
+com.intel interface prefix to the mapper watch list."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit phosphor-mapper
+inherit native
+
+PHOSPHOR_MAPPER_SERVICE_append = " com.intel"
+PHOSPHOR_MAPPER_INTERFACE_append = " com.intel"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
new file mode 100644
index 000000000..cdb88bbfe
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Intel DBus Interfaces"
+DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit python3native
+inherit phosphor-dbus-yaml
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
+
+SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
+SRCREV = "b5f2dd444c5d3808d005452417e4ae2ea28624ff"
+
+PACKAGECONFIG ??= "libintel_dbus"
+PACKAGECONFIG[libintel_dbus] = " \
+ --enable-libintel_dbus, \
+ --disable-libintel_dbus, \
+ systemd sdbusplus, \
+ libsystemd \
+ "
+
+PACKAGECONFIG_remove_class-native = "libintel_dbus"
+PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
new file mode 100644
index 000000000..ef991a58b
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
@@ -0,0 +1 @@
+PHOSPHOR_MAPPER_CONFIGS_append_intel = " intel-dbus-interfaces-mapper-config-native"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control/phosphor-pid-control.service b/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control/phosphor-pid-control.service
new file mode 100644
index 000000000..99494717f
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control/phosphor-pid-control.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Phosphor-Pid-Control Margin-based Fan Control Daemon
+
+[Service]
+Restart=always
+ExecStart={bindir}/swampd
+RestartSec=5
+StartLimitInterval=0
+Type=simple
+
+[Install]
+WantedBy=basic.target
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
new file mode 100644
index 000000000..4521fe8f8
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
+
+inherit obmc-phosphor-systemd
+SYSTEMD_SERVICE_${PN}_intel = "phosphor-pid-control.service"
+EXTRA_OECONF_intel = "--enable-configure-dbus=yes"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
new file mode 100644
index 000000000..4e24bab9e
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
@@ -0,0 +1,5 @@
+EXTRA_OEMESON += "-Dredfish-cpu-log=enabled \
+ -Dredfish-raw-peci=enabled \
+ -Dredfish-bmc-journal=enabled \
+ -Drest=disabled"
+
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
new file mode 100644
index 000000000..876567f9a
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -0,0 +1,5 @@
+do_install_append_intel(){
+ install -d ${D}${includedir}/phosphor-ipmi-host
+ install -m 0644 -D ${S}/sensorhandler.hpp ${D}${includedir}/phosphor-ipmi-host
+ install -m 0644 -D ${S}/selutility.hpp ${D}${includedir}/phosphor-ipmi-host
+}
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb/ipmb-channels.json b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb/ipmb-channels.json
new file mode 100644
index 000000000..cf5a28303
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb/ipmb-channels.json
@@ -0,0 +1,16 @@
+{
+ "channels": [
+ {
+ "type": "me",
+ "slave-path": "/dev/ipmb-5",
+ "bmc-addr": 32,
+ "remote-addr": 44
+ },
+ {
+ "type": "ipmb",
+ "slave-path": "/dev/ipmb-13",
+ "bmc-addr": 32,
+ "remote-addr": 56
+ }
+ ]
+}
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
new file mode 100644
index 000000000..e8cbbe928
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append = " file://ipmb-channels.json"
+
+do_install_append(){
+ install -m 0644 -D ${WORKDIR}/ipmb-channels.json \
+ ${D}/usr/share/ipmbbridge
+}
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb b/meta-intel-openbmc/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
new file mode 100644
index 000000000..20df1185b
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor LED Group Management for Intel"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-utils
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml b/meta-intel-openbmc/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml
new file mode 100755
index 000000000..813ffbfd4
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml
@@ -0,0 +1,36 @@
+bmc_booted:
+
+power_on:
+
+status_ok:
+ status_green:
+ Action: 'On'
+ status_amber:
+ Action: 'Off'
+
+status_degraded:
+ status_green:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+ status_amber:
+ Action: 'Off'
+
+status_non_critical:
+ status_green:
+ Action: 'Off'
+ status_amber:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+status_critical:
+ status_green:
+ Action: 'Off'
+ status_amber:
+ Action: 'On'
+
+enclosure_identify:
+ identify:
+ Action: 'On'
+
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
new file mode 100644
index 000000000..3e769e174
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
@@ -0,0 +1,2 @@
+# Enable threshold monitoring
+EXTRA_OECMAKE_intel += "-DSEL_LOGGER_MONITOR_THRESHOLD_EVENTS=ON"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui/config.json b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui/config.json
new file mode 100644
index 000000000..1543a6249
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui/config.json
@@ -0,0 +1,8 @@
+{
+ "customKeyEnable": true,
+ "keyType" : "VT100+",
+ "customConsoleDisplaySize": {
+ "width": 100,
+ "height": 32
+ }
+}
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
new file mode 100644
index 000000000..590e9e629
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
+
+SRC_URI_append_intel = " file://config.json"
+
+do_compile_prepend_intel() {
+ cp -r ${WORKDIR}/config.json ${S}/
+}
+