summaryrefslogtreecommitdiff
path: root/meta-intel
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-04-08 21:57:55 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-10 18:05:48 +0300
commit8207f6eac121a9936c3d8a97ade3dd20a312dfd1 (patch)
tree6cc6fcda107261f6457d1259d9ea64e46cc618ef /meta-intel
parente3952c7d6439a15deef5206b2c9b083889f24d52 (diff)
downloadopenbmc-8207f6eac121a9936c3d8a97ade3dd20a312dfd1.tar.xz
Add a host-error-monitor recipe
Tested: Verified that the recipe builds (From meta-intel rev: c60d4b4488a6cfd8015537213309d6a20438edf9) Change-Id: I15afd8a5626126fbe0d7bfd967ff6f2a19e8be22 Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-intel')
-rw-r--r--meta-intel/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-intel/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb b/meta-intel/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
new file mode 100644
index 000000000..4a2353f8b
--- /dev/null
+++ b/meta-intel/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
@@ -0,0 +1,22 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
+inherit cmake systemd
+
+SRC_URI = "git://github.com/openbmc/host-error-monitor"
+
+DEPENDS = "boost sdbusplus libgpiod libpeci"
+
+PV = "0.1+git${SRCPV}"
+SRCREV = "53099c49b89c22cfe09c7217679ae1fb20e019eb"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.HostErrorMonitor.service"
+SECURITY_CFLAGS_pn-host-error-monitor = "${SECURITY_NOPIE_CFLAGS}"
+
+# linux-libc-headers guides this way to include custom uapi headers
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
+CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
+do_configure[depends] += "virtual/kernel:do_shared_workdir"