summaryrefslogtreecommitdiff
path: root/meta-intel
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-04-07 01:54:23 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-10 18:05:47 +0300
commite3952c7d6439a15deef5206b2c9b083889f24d52 (patch)
treeba9a8b6ffda88477fa2016c13f1cbb641e45de40 /meta-intel
parente4175bb9c38b112600abe7f61cbc56e4fa6d827f (diff)
downloadopenbmc-e3952c7d6439a15deef5206b2c9b083889f24d52.tar.xz
Add a libpeci recipe
Tested: Verified that the recipe builds and PECI commands work. (From meta-intel rev: 0ae2c89cff8e59c4121bcf33ea3a053d0890f6df) Change-Id: I2335583d439c6f3eb9be6a9c1c58bb62cd30ec0c Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-intel')
-rw-r--r--meta-intel/meta-common/recipes-core/libpeci/libpeci_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-intel/meta-common/recipes-core/libpeci/libpeci_git.bb b/meta-intel/meta-common/recipes-core/libpeci/libpeci_git.bb
new file mode 100644
index 000000000..ed1c7b508
--- /dev/null
+++ b/meta-intel/meta-common/recipes-core/libpeci/libpeci_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "PECI Library"
+DESCRIPTION = "PECI Library"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
+inherit cmake
+
+SRC_URI = "git://github.com/openbmc/libpeci"
+
+PV = "0.1+git${SRCPV}"
+SRCREV = "7ef5a55777bb4d0c403a4eca98c487fa4e9c7bd1"
+
+S = "${WORKDIR}/git"
+
+# linux-libc-headers guides this way to include custom uapi headers
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
+CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
+do_configure[depends] += "virtual/kernel:do_shared_workdir"