summaryrefslogtreecommitdiff
path: root/meta-intel
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-05-04 22:10:14 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-05-04 22:10:14 +0300
commit794d26fa53ad7e8cb54a3a5773436b1d8e813f35 (patch)
tree92940f7842138b00efea3b42140093a3bf39b81b /meta-intel
parent235618c7396902842906bc3a8c90a3320aeeaeba (diff)
parenta6da583e088a2e9462d5330555a704402eff74a9 (diff)
downloadopenbmc-794d26fa53ad7e8cb54a3a5773436b1d8e813f35.tar.xz
Merge tag 'wht-0.53' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-intel')
-rw-r--r--meta-intel/MAINTAINERS67
-rw-r--r--meta-intel/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb22
-rw-r--r--meta-intel/meta-common/recipes-core/libpeci/libpeci_git.bb20
-rwxr-xr-xmeta-intel/meta-common/recipes-intel/chassis/x86-power-control_git.bb2
-rwxr-xr-xmeta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb2
-rw-r--r--meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb11
-rw-r--r--meta-intel/meta-s2600wf/recipes-phosphor/workbook/s2600wf-config_git.bb6
7 files changed, 115 insertions, 15 deletions
diff --git a/meta-intel/MAINTAINERS b/meta-intel/MAINTAINERS
new file mode 100644
index 000000000..0a18b9aff
--- /dev/null
+++ b/meta-intel/MAINTAINERS
@@ -0,0 +1,67 @@
+List of maintainers for meta-intel
+===============================
+
+How to use this list:
+ Find the most specific section entry (described below) that matches where
+ your change lives and add the reviewers (R) and maintainers (M) as
+ reviewers. You can use the same method to track down who knows a particular
+ code base best.
+
+ Your change/query may span multiple entries; that is okay.
+
+ If you do not find an entry that describes your request at all, someone
+ forgot to update this list; please at least file an issue or send an email
+ to a maintainer, but preferably you should just update this document.
+
+Description of section entries:
+
+ Section entries are structured according to the following scheme:
+
+ X: NAME <EMAIL_USERNAME@DOMAIN> <IRC_USERNAME!>
+ X: ...
+ .
+ .
+ .
+
+ Where REPO_NAME is the name of the repository within the OpenBMC GitHub
+ organization; FILE_PATH is a file path within the repository, possibly with
+ wildcards; X is a tag of one of the following types:
+
+ M: Denotes maintainer; has fields NAME <EMAIL_USERNAME@DOMAIN> <IRC_USERNAME!>;
+ if omitted from an entry, assume one of the maintainers from the
+ MAINTAINERS entry.
+ R: Denotes reviewer; has fields NAME <EMAIL_USERNAME@DOMAIN> <IRC_USERNAME!>;
+ these people are to be added as reviewers for a change matching the repo
+ path.
+ F: Denotes forked from an external repository; has fields URL.
+
+ Line comments are to be denoted "# SOME COMMENT" (typical shell style
+ comment); it is important to follow the correct syntax and semantics as we
+ may want to use automated tools with this file in the future.
+
+ A change cannot be added to an OpenBMC repository without a MAINTAINER's
+ approval; thus, a MAINTAINER should always be listed as a reviewer.
+
+Change approval rules:
+
+ - Patches must be available for review for a minimum of 48 hours before it
+ can be submitted.
+ - Patches must be be approved (+1) by at least 2 maintainers.
+ - Patches must not have an unresolved -1 vote by any maintainer.
+ - Patches should have all maintainers added for visibility.
+ - Patches should include unit tests where possible.
+ - Feel free to ping on IRC about patches that look good but have not
+ received +2
+
+Design approval rules:
+
+ - Design discussions should be carried out via email with, at minimum,
+ all maintainers on the thread. It's encouraged to include the
+ OpenBMC mailing list in the thread as well.
+
+START OF MAINTAINERS LIST
+-------------------------
+
+M: Vernon Mauery <vernon.mauery@linux.intel.com> <vmauery!>
+M: James Feist <james.feist@linux.intel.com> <jfei!>
+M: Jason Bills <jason.m.bills@linux.intel.com> <jmbills!>
diff --git a/meta-intel/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb b/meta-intel/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
new file mode 100644
index 000000000..4a2353f8b
--- /dev/null
+++ b/meta-intel/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
@@ -0,0 +1,22 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
+inherit cmake systemd
+
+SRC_URI = "git://github.com/openbmc/host-error-monitor"
+
+DEPENDS = "boost sdbusplus libgpiod libpeci"
+
+PV = "0.1+git${SRCPV}"
+SRCREV = "53099c49b89c22cfe09c7217679ae1fb20e019eb"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.HostErrorMonitor.service"
+SECURITY_CFLAGS_pn-host-error-monitor = "${SECURITY_NOPIE_CFLAGS}"
+
+# linux-libc-headers guides this way to include custom uapi headers
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
+CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
diff --git a/meta-intel/meta-common/recipes-core/libpeci/libpeci_git.bb b/meta-intel/meta-common/recipes-core/libpeci/libpeci_git.bb
new file mode 100644
index 000000000..ed1c7b508
--- /dev/null
+++ b/meta-intel/meta-common/recipes-core/libpeci/libpeci_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "PECI Library"
+DESCRIPTION = "PECI Library"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
+inherit cmake
+
+SRC_URI = "git://github.com/openbmc/libpeci"
+
+PV = "0.1+git${SRCPV}"
+SRCREV = "7ef5a55777bb4d0c403a4eca98c487fa4e9c7bd1"
+
+S = "${WORKDIR}/git"
+
+# linux-libc-headers guides this way to include custom uapi headers
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
+CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
diff --git a/meta-intel/meta-common/recipes-intel/chassis/x86-power-control_git.bb b/meta-intel/meta-common/recipes-intel/chassis/x86-power-control_git.bb
index 2922b6a36..7dd149e81 100755
--- a/meta-intel/meta-common/recipes-intel/chassis/x86-power-control_git.bb
+++ b/meta-intel/meta-common/recipes-intel/chassis/x86-power-control_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "Chassis Power Control service for Intel based platforms"
DESCRIPTION = "Chassis Power Control service for Intel based platforms"
SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=ssh"
-SRCREV = "e7520ba18a5b5ba6c8eb7a9d543704f9699295a1"
+SRCREV = "fc1ecc59100d21c953501703bc5db9e02e25b333"
PV = "1.0+git${SRCPV}"
diff --git a/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb b/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
index d212933ca..53024e0c7 100755
--- a/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
+++ b/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a4edad4aed50f39a66d098d74b265b"
SRC_URI = "git://github.com/openbmc/intel-ipmi-oem"
-SRCREV = "8709fbb3a396bdef42b2466011bb71fa2bcadfc0"
+SRCREV = "2b664d5a185247f0448c763ba7d0e42cfc245024"
S = "${WORKDIR}/git"
PV = "0.1+git${SRCPV}"
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
index 76fb67dc3..cdb88bbfe 100644
--- a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
@@ -8,27 +8,24 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
-inherit pythonnative
+inherit python3native
inherit phosphor-dbus-yaml
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbus++-native"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
SRCREV = "b5f2dd444c5d3808d005452417e4ae2ea28624ff"
-DEPENDS_remove_class-native = "sdbus++-native"
-DEPENDS_remove_class-nativesdk = "sdbus++-native"
-
PACKAGECONFIG ??= "libintel_dbus"
PACKAGECONFIG[libintel_dbus] = " \
--enable-libintel_dbus, \
--disable-libintel_dbus, \
systemd sdbusplus, \
- libsystemd sdbusplus \
+ libsystemd \
"
PACKAGECONFIG_remove_class-native = "libintel_dbus"
PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
-BBCLASSEXTEND += "native nativesdk" \ No newline at end of file
+BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-intel/meta-s2600wf/recipes-phosphor/workbook/s2600wf-config_git.bb b/meta-intel/meta-s2600wf/recipes-phosphor/workbook/s2600wf-config_git.bb
deleted file mode 100644
index cc12010b1..000000000
--- a/meta-intel/meta-s2600wf/recipes-phosphor/workbook/s2600wf-config_git.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-SUMMARY = "s2600wf board wiring"
-DESCRIPTION = "Board wiring information for the s2600wf system."
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
-inherit config-in-skeleton