summaryrefslogtreecommitdiff
path: root/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock.bb
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-06-20 19:46:38 +0300
committerGitHub <noreply@github.com>2019-06-20 19:46:38 +0300
commit43a183cc0926da36e3a218efa02ab4838ace316f (patch)
tree9ea192b408585fc2a19b54d196c3d56eaddc4acb /meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock.bb
parent5575b1d27fc222f973d96dc06af0f21ba7656f28 (diff)
parent2c7e8f4ce61f2e0407c37e98e22bbb13e562b414 (diff)
downloadopenbmc-43a183cc0926da36e3a218efa02ab4838ace316f.tar.xz
Merge pull request #12 from Intel-BMC/update
Update
Diffstat (limited to 'meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock.bb')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock.bb b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock.bb
new file mode 100644
index 000000000..85b80708d
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock.bb
@@ -0,0 +1,19 @@
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+SRCREV = "10.09.05"
+FILENAME = "Poleg_bootblock.bin"
+
+SRC_URI = "git://github.com/Nuvoton-Israel/npcm7xx-bootblock;protocol=git"
+SRC_URI[md5sum] = "cf8daa5f4636ed1ff952618e435af028"
+
+S = "${WORKDIR}/git"
+
+inherit deploy
+
+do_deploy () {
+ install -d ${DEPLOYDIR}
+ install -m 644 ${FILENAME} ${DEPLOYDIR}/
+}
+
+addtask deploy before do_build after do_compile