summaryrefslogtreecommitdiff
path: root/meta-openbmc-bsp
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-24 08:03:18 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-06-11 17:16:24 +0300
commit8099077e3e93d9bdf35ae889dca3e639d765bafe (patch)
tree5bf61c45e02c068c5274ccb36c15129d3b0acb68 /meta-openbmc-bsp
parent01ddfab322ae50bedaa250630661ebed0c1a9101 (diff)
downloadopenbmc-8099077e3e93d9bdf35ae889dca3e639d765bafe.tar.xz
aspeed: Rename u-boot recipes
Append an -aspeed suffix to Aspeed u-boot and u-boot-fw-utils recipes to match convention of other upstream BSP layers like meta-fsl-arm. Tested: Built palmetto/spoon images and booted in QEMU Change-Id: I88ce2062876674ea9c104a97cc0bf2c83f2b1fcd Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openbmc-bsp')
-rw-r--r--meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb (renamed from meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot_2016.07.bb)3
-rw-r--r--meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-common-aspeed_2016.07.inc (renamed from meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-common_2016.07.inc)0
-rw-r--r--meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb (renamed from meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb)4
-rw-r--r--meta-openbmc-bsp/meta-aspeed/conf/machine/include/aspeed.inc9
4 files changed, 8 insertions, 8 deletions
diff --git a/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot_2016.07.bb b/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
index 05b1c8976..b3a41a28a 100644
--- a/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot_2016.07.bb
+++ b/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
@@ -1,4 +1,5 @@
-require u-boot-common_${PV}.inc
+require u-boot-common-aspeed_${PV}.inc
require recipes-bsp/u-boot/u-boot.inc
+PROVIDES += "u-boot"
DEPENDS += "dtc-native"
diff --git a/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-common_2016.07.inc b/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-common-aspeed_2016.07.inc
index 054933057..054933057 100644
--- a/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-common_2016.07.inc
+++ b/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-common-aspeed_2016.07.inc
diff --git a/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb b/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
index 2b2b62c9e..713133ceb 100644
--- a/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb
+++ b/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
@@ -1,4 +1,4 @@
-require u-boot-common_${PV}.inc
+require u-boot-common-aspeed_${PV}.inc
SRC_URI += "file://default-gcc.patch"
SRC_URI += "file://fw_env.config"
@@ -7,6 +7,8 @@ SRC_URI += "file://alt_fw_env.config"
SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
DEPENDS = "mtd-utils"
+PROVIDES += "u-boot-fw-utils"
+
INSANE_SKIP_${PN} = "already-stripped"
EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
diff --git a/meta-openbmc-bsp/meta-aspeed/conf/machine/include/aspeed.inc b/meta-openbmc-bsp/meta-aspeed/conf/machine/include/aspeed.inc
index 4990e1ae3..ff6c83e42 100644
--- a/meta-openbmc-bsp/meta-aspeed/conf/machine/include/aspeed.inc
+++ b/meta-openbmc-bsp/meta-aspeed/conf/machine/include/aspeed.inc
@@ -1,9 +1,6 @@
PREFERRED_PROVIDER_virtual/kernel ?= "linux-obmc"
-
-ASPEED_UBOOT_VERSION ?= "v2016.07+git%"
-
-PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot"
-PREFERRED_VERSION_u-boot ?= "${ASPEED_UBOOT_VERSION}"
-PREFERRED_VERSION_u-boot-fw-utils ?= "${ASPEED_UBOOT_VERSION}"
+PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-aspeed"
+PREFERRED_PROVIDER_u-boot ?= "u-boot-aspeed"
+PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-fw-utils-aspeed"
MACHINEOVERRIDES .= ":aspeed"