summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-09 08:40:41 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-13 05:51:39 +0300
commit09806a566ce7af38691ec9a9b9c26ebe3463f746 (patch)
tree1f5211c9109e11e51538f7c956da208e5784bff8 /meta-openbmc-machines/meta-openpower/common/recipes-core/systemd
parent8623bbe4d4a187018cc3c265aaca5fa05b78d13b (diff)
downloadopenbmc-09806a566ce7af38691ec9a9b9c26ebe3463f746.tar.xz
Convert openpower-ubi-fs to a distro feature
As with MRW the use of the UBI image scheme is distro policy. Convert the existing machine feature to a distro feature. Enable the new distro feature on the systems that use it(Witherspoon). Add a distro override and fix-up MF checks to use this override instead for improved readability. Change-Id: I57f3bc244523eff5bc043caff8365e334d98cb30 Tested: Built a witherspoon image and validate manifest Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-core/systemd')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend b/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend
index 751940467..e576d8e6c 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend
@@ -1,11 +1,11 @@
-SRC_URI += "${@mf_enabled(d, 'openpower-ubi-fs', 'file://software.conf')}"
+SRC_URI += "${@df_enabled(d, 'openpower-ubi-fs', 'file://software.conf')}"
install_tmpfile() {
# /tmp/images is the software image upload directory.
# It should not be deleted since it is watched by the Image Manager for
# new images.
- if ${@bb.utils.contains('MACHINE_FEATURES', 'openpower-ubi-fs', 'true', 'false', d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-ubi-fs', 'true', 'false', d)}; then
install -m 0644 ${WORKDIR}/software.conf ${D}${exec_prefix}/lib/tmpfiles.d/
fi
}