summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-09 08:04:00 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-13 05:51:39 +0300
commit8623bbe4d4a187018cc3c265aaca5fa05b78d13b (patch)
tree92566fed6a5d963b24658f634c1cce40841c8d01 /meta-openbmc-machines/meta-openpower/common/recipes-core/systemd
parent250a984fc21fa6de8ae7723d59409815758b7825 (diff)
downloadopenbmc-8623bbe4d4a187018cc3c265aaca5fa05b78d13b.tar.xz
Convert obmc-ubi-fs to a distro feature
As with MRW the use of the UBI image scheme is distro policy. Convert the existing machine feature to a distro feature. Enable the new distro feature on the systems that use it(Witherspoon). Add a distro override and fix-up MF checks to use this override instead for improved readability. Tested: Built a Witherspoon image and validated image Change-Id: I8ab03115bbfc2ecc77cff5c9eb8628903ae88051 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-core/systemd')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend22
1 files changed, 16 insertions, 6 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend b/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend
index 134bab5f1..751940467 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend
@@ -1,13 +1,23 @@
SRC_URI += "${@mf_enabled(d, 'openpower-ubi-fs', 'file://software.conf')}"
-do_install_append() {
-
+install_tmpfile() {
# /tmp/images is the software image upload directory.
# It should not be deleted since it is watched by the Image Manager for
- # new images. Don't install software.conf if obmc-ubi-fs is set since
- # the bbappend in the meta-phosphor layer already installs if
- # obmc-ubi-fs is set.
- if ${@bb.utils.contains('MACHINE_FEATURES', 'openpower-ubi-fs', 'true', 'false', d)} && ! ${@bb.utils.contains('MACHINE_FEATURES', 'obmc-ubi-fs', 'true', 'false', d)}; then
+ # new images.
+
+ if ${@bb.utils.contains('MACHINE_FEATURES', 'openpower-ubi-fs', 'true', 'false', d)}; then
install -m 0644 ${WORKDIR}/software.conf ${D}${exec_prefix}/lib/tmpfiles.d/
fi
}
+
+install_tmpfile_df-obmc-ubi-fs() {
+ # Don't install software.conf if obmc-ubi-fs is set since
+ # the bbappend in the meta-phosphor layer already installs
+ # if obmc-ubi-fs is set.
+
+ :
+}
+
+do_install_append() {
+ install_tmpfile
+}