summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-09-18 23:33:41 +0300
committerMatt Spinler <spinler@us.ibm.com>2017-09-29 19:21:28 +0300
commit348439b774563037dc6f22d46807f46bdcb3769c (patch)
tree6d9df6aa45b8cf162d4c4cf4f4695abe4dda4207 /meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host
parent19826927e156f778d0418565e62942a65986e8c8 (diff)
downloadopenbmc-348439b774563037dc6f22d46807f46bdcb3769c.tar.xz
op-proc-control: install error yaml files
Copy the yaml to the place where phosphor-logging looks for them during the build. Change-Id: I3413937a7920c7540794e3f39f3642e0876a9f8f Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control-error-native.bb17
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb7
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.inc6
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/phosphor-logging-error-logs-native.bbappend2
4 files changed, 27 insertions, 5 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control-error-native.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control-error-native.bb
new file mode 100644
index 000000000..c9a24cd83
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control-error-native.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Copy error yaml files to known path for elog parsing"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-dbus-yaml
+
+require op-proc-control.inc
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ SRC=${S}/org/open_power/Proc
+ DEST=${yaml_dir}/org/open_power/Proc
+ install -d ${DEST}
+ install ${SRC}/*.yaml ${DEST}
+}
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb
index 251db5dc1..561aaba52 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb
@@ -2,15 +2,12 @@ SUMMARY = "OpenPower procedure control"
DESCRIPTION = "Provides procedures that run against the host chipset"
PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
S = "${WORKDIR}/git"
inherit autotools pkgconfig
+require ${PN}.inc
+
DEPENDS += "autoconf-archive-native phosphor-logging"
RDEPENDS_${PN} += "phosphor-logging"
-SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "d8dd9b25ac65043ad0cb7734919bf96084b47831"
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.inc b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.inc
new file mode 100644
index 000000000..1a0167b71
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/op-proc-control.inc
@@ -0,0 +1,6 @@
+HOMEPAGE = "https://github.com/openbmc/openpower-proc-control"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI += "git://github.com/openbmc/openpower-proc-control"
+SRCREV = "d8dd9b25ac65043ad0cb7734919bf96084b47831"
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/phosphor-logging-error-logs-native.bbappend b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/phosphor-logging-error-logs-native.bbappend
new file mode 100644
index 000000000..34454f168
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/phosphor-logging-error-logs-native.bbappend
@@ -0,0 +1,2 @@
+DEPENDS += "op-proc-control-error-native"
+