summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2018-03-09 19:54:09 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-14 22:16:44 +0300
commit25c9a63084a97790d62d2bbb9db3cd64b91db5d4 (patch)
tree4fa9066ef39a89cb538f4a853fca1dd2e3bbcd5a /meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb
parentd683d87130f7a3aad1e3fc8382a98b94fb81b16b (diff)
downloadopenbmc-25c9a63084a97790d62d2bbb9db3cd64b91db5d4.tar.xz
Use OpenPower variable for PS derating factor
The openpower-occ-control code needs to know the power supply derating factor, but will default to a value if one isn't supplied externally in do_configure. Since other will also need to use that same value, use a common variable for it defined in openpower.inc, and now pass it into the configure step. This derating factor is an OpenPower concept used by the Power processor's OCC thermal control subsystem. Tested: Check that the derating factor variable in config.h in the openenpower-occ-control repo follows the variable in openpower.inc. Change-Id: I259b6086ebe70b2ac6eccdd244e43a7d36a28a77 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb
index f9527f123..a113045b7 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb
@@ -42,7 +42,10 @@ RDEPENDS_${PN} += " \
phosphor-dbus-interfaces \
"
-EXTRA_OECONF = "YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN}"
+EXTRA_OECONF = " \
+ YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN} \
+ PS_DERATING_FACTOR=${POWER_SUPPLY_DERATING_FACTOR} \
+ "
EXTRA_OECONF_append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}"
OCC_ENABLE = "enable"