summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-02-05 19:10:44 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-02-17 02:10:40 +0300
commitba5ce786b6fa625218fd732d6a6f22a9d1cf9d97 (patch)
tree3aff11577e41eac2d79ee2c333c46db834f598a5 /meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb
parentcffe9a81f6ddbe8112019d0199b459d850a35fee (diff)
downloadopenbmc-ba5ce786b6fa625218fd732d6a6f22a9d1cf9d97.tar.xz
Add virtual/openpower-fru-inventory
This virtual provides an environment file that serves as inventory configuration for openpower-vpd-parser. Add a native recipe that builds the configuration from MRW. Set this recipe as the default for OpenPOWER systems. Change-Id: I88c1d4123d73a5cdf37cba8efda40107f7b9ef25 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb
new file mode 100644
index 000000000..8f9bd050b
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Inventory config for openpower-vpd-parser"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit openpower-fru-vpd
+
+SRC_URI += "file://inventory"
+
+PROVIDES += "virtual/openpower-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # This recipe is supposed to create a systemd environment file
+ # with values for FRU types and paths. This example recipe
+ # uses a pre-defined file ($PN/inventory).
+
+ DEST=${D}${inventory_datadir_native}
+ install -d ${DEST}
+ install inventory ${DEST}
+}