summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.service
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-06-06 17:40:45 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-06-14 10:39:59 +0300
commit6304341c661d1f3b307015d4c097083daefa69a3 (patch)
treeac38370e2762cbbe5fc2360ebb4b8d0ff2fc83c9 /meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.service
parent20a9336fb649da817086eb00c194965bbb105287 (diff)
downloadopenbmc-6304341c661d1f3b307015d4c097083daefa69a3.tar.xz
Install witherspoon-reset-fan-watchdog service
This is a witherspoon only service that will reset the fan watchdog circuit on a poweron, which would bring the fans out of watchdog control if they previously were. The watchdog is reset by toggling a GPIO that feeds a latch that drives the watchdog signal to the fan controller. The GPIO parameters are obtained from an environment file. The witherspoon-fan-watchdog.bb recipe will have other watchdog related services added to it in the future. Resolves openbmc/openbmc#1687 Change-Id: I103ccf6cb69f8a98fc352fa2fa05e45ecbf2cd23 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.service')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.service11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.service b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.service
new file mode 100644
index 000000000..8ac3dd115
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Witherspoon Fan Watchdog Reset
+Wants=phosphor-fan-control-init@0.service
+Before=phosphor-fan-control-init@0.service
+Conflicts=obmc-chassis-poweroff@0.target
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+EnvironmentFile={envfiledir}/obmc/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.conf
+ExecStart={sbindir}/phosphor-gpio-util -p ${{GPIO_PATH}} -g ${{GPIO}} -a ${{ACTION}} -d ${{DELAY}}