summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2018-03-21 16:23:42 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-23 20:56:44 +0300
commit7472ec4b59fcce69964dc1017a989848b04650d2 (patch)
treecdffd5b978e084e0596500a44739c1b65d045640 /meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor
parent1686c5e661b47196f2b56cbebae47d24ed69e84d (diff)
downloadopenbmc-7472ec4b59fcce69964dc1017a989848b04650d2.tar.xz
Fix wspoon power fault error yaml install
Missing the ${D} on the install command - this still managed to work on the older versions of yocto but not with the latest one. Also removed the PROVIDES=<recipe-name> line since it's redundant. Change-Id: I83127f0c457ec31bd99311371ec76abaf6fbc76a Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb
index 1b8276b75..64c551f7d 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb
@@ -5,14 +5,13 @@ inherit native
inherit obmc-phosphor-license
inherit phosphor-dbus-yaml
-PROVIDES += "witherspoon-pfault-analysis-error-native"
require witherspoon-pfault-analysis.inc
S = "${WORKDIR}/git"
do_install_append() {
SRC=${S}/org/open_power/Witherspoon
- DEST=${yaml_dir}/org/open_power/Witherspoon
+ DEST=${D}${yaml_dir}/org/open_power/Witherspoon
install -d ${DEST}
install ${SRC}/Fault.errors.yaml ${DEST}
install ${SRC}/Fault.metadata.yaml ${DEST}