summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-ast2500/recipes-phosphor
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:45:20 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-10 01:15:05 +0300
commit82dbc15a05125a812c140a3c8cff81c366482229 (patch)
tree9c8f1ad262a2e281f20340cf8646aca6f8596044 /meta-openbmc-mods/meta-ast2500/recipes-phosphor
parent8d6ae7f2a817751fad151168fa10ce28ee0869d8 (diff)
downloadopenbmc-82dbc15a05125a812c140a3c8cff81c366482229.tar.xz
Update to internal 0.26
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-ast2500/recipes-phosphor')
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CPC-Baseboard.json6
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json99
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Chassis.json6
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WP-Baseboard.json6
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/blocklist.json3
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager_%.bbappend4
6 files changed, 110 insertions, 14 deletions
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CPC-Baseboard.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CPC-Baseboard.json
index 94e7e7daa..0346c3f90 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CPC-Baseboard.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CPC-Baseboard.json
@@ -1914,6 +1914,12 @@
"Bus": 4,
"Name": "PFR",
"Type": "PFR"
+ },
+ {
+ "Name": "PCH SMBUS Slave",
+ "PchSmbusSlaveI2cBus": 3,
+ "PchSmbusSlaveI2cAddress": "0x44",
+ "Type": "PchSmbusSlave"
}
],
"Name": "CPC Baseboard",
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json
index 83e6deabe..909c47621 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json
@@ -499,96 +499,112 @@
{
"BindConnector": "System Fan connector 1",
"Index": 0,
+ "MaxReading": 8000,
"Name": "Fan 1a",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 1",
"Index": 1,
+ "MaxReading": 8000,
"Name": "Fan 1b",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 2",
"Index": 2,
+ "MaxReading": 8000,
"Name": "Fan 2a",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 2",
"Index": 3,
+ "MaxReading": 8000,
"Name": "Fan 2b",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 3",
"Index": 4,
+ "MaxReading": 8000,
"Name": "Fan 3a",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 3",
"Index": 5,
+ "MaxReading": 8000,
"Name": "Fan 3b",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 4",
"Index": 6,
+ "MaxReading": 8000,
"Name": "Fan 4a",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 4",
"Index": 7,
+ "MaxReading": 8000,
"Name": "Fan 4b",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 5",
"Index": 8,
+ "MaxReading": 8000,
"Name": "Fan 5a",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 5",
"Index": 9,
+ "MaxReading": 8000,
"Name": "Fan 5b",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 6",
"Index": 10,
+ "MaxReading": 8000,
"Name": "Fan 6a",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 6",
"Index": 11,
+ "MaxReading": 8000,
"Name": "Fan 6b",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 7",
"Index": 12,
+ "MaxReading": 8000,
"Name": "Fan 7a",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 7",
"Index": 13,
+ "MaxReading": 8000,
"Name": "Fan 7b",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 8",
"Index": 14,
+ "MaxReading": 8000,
"Name": "Fan 8a",
"Type": "AspeedFan"
},
{
"BindConnector": "System Fan connector 8",
"Index": 15,
+ "MaxReading": 8000,
"Name": "Fan 8b",
"Type": "AspeedFan"
},
@@ -620,6 +636,7 @@
"Type": "CFMSensor"
},
{
+ "LED": "fan1_fault",
"Name": "System Fan connector 1",
"Pwm": 0,
"Tachs": [
@@ -629,6 +646,7 @@
"Type": "IntelFanConnector"
},
{
+ "LED": "fan2_fault",
"Name": "System Fan connector 2",
"Pwm": 1,
"Tachs": [
@@ -638,6 +656,7 @@
"Type": "IntelFanConnector"
},
{
+ "LED": "fan3_fault",
"Name": "System Fan connector 3",
"Pwm": 2,
"Tachs": [
@@ -647,6 +666,7 @@
"Type": "IntelFanConnector"
},
{
+ "LED": "fan4_fault",
"Name": "System Fan connector 4",
"Pwm": 3,
"Tachs": [
@@ -656,6 +676,7 @@
"Type": "IntelFanConnector"
},
{
+ "LED": "fan5_fault",
"Name": "System Fan connector 5",
"Pwm": 4,
"Tachs": [
@@ -665,6 +686,7 @@
"Type": "IntelFanConnector"
},
{
+ "LED": "fan6_fault",
"Name": "System Fan connector 6",
"Pwm": 5,
"Tachs": [
@@ -674,6 +696,7 @@
"Type": "IntelFanConnector"
},
{
+ "LED": "fan7_fault",
"Name": "System Fan connector 7",
"Pwm": 6,
"Tachs": [
@@ -683,6 +706,7 @@
"Type": "IntelFanConnector"
},
{
+ "LED": "fan8_fault",
"Name": "System Fan connector 8",
"Pwm": 7,
"Tachs": [
@@ -1048,27 +1072,61 @@
"Address": 190,
"Class": "MESensor",
"Name": "Host Cpu Utilization",
- "SensorType": "utilization",
"ScaleValue": 0.392,
+ "SensorType": "utilization",
"Type": "IpmbSensor"
},
{
"Address": 191,
"Class": "MESensor",
"Name": "Host Pci Bandwidth Utilization",
- "SensorType": "utilization",
"ScaleValue": 0.392,
+ "SensorType": "utilization",
"Type": "IpmbSensor"
},
{
"Address": 192,
"Class": "MESensor",
"Name": "Host Memory Bandwidth Utilization",
- "SensorType": "utilization",
"ScaleValue": 0.392,
+ "SensorType": "utilization",
"Type": "IpmbSensor"
},
{
+ "Name": "Node Manager Sensor",
+ "Type": "NMSensor"
+ },
+ {
+ "ARPOwnerSupport": false,
+ "BMCReceiverAddress": 18,
+ "BindingType": "MctpSMBus",
+ "Bus": "/dev/i2c-2",
+ "DefaultEID": 8,
+ "EIDPool": [
+ 9,
+ 10,
+ 11,
+ 12,
+ 13,
+ 14,
+ 15,
+ 16,
+ 17,
+ 18,
+ 19,
+ 20
+ ],
+ "Index": 0,
+ "Name": "MCTP SMBus PCIe slot",
+ "PhysicalMediumID": "Smbus3OrI2c400khzCompatible",
+ "ReqRetryCount": 2,
+ "ReqToRespTimeMs": 100,
+ "Role": "BusOwner",
+ "TopMostBusOwner":false,
+ "OwnEidPool":true,
+ "Type": "MctpConfiguration"
+ },
+ {
"EthIndex": 0,
"Name": "Dedicated Management NIC",
"Type": "NIC"
@@ -1137,6 +1195,12 @@
"Type": "PCA9546Mux"
},
{
+ "Address": "0x38",
+ "Bus": 4,
+ "Name": "PFR",
+ "Type": "PFR"
+ },
+ {
"Interface": [
"i2c",
"peci"
@@ -1668,6 +1732,11 @@
"Type": "PSUPresence"
},
{
+ "Name": "Power Unit Redundancy",
+ "RedundantCount": 1,
+ "Type": "PURedundancy"
+ },
+ {
"Class": "temp",
"FFGainCoefficient": 0.0,
"FFOffCoefficient": 0.0,
@@ -1951,7 +2020,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 80.0,
+ "SetPoint": 60.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1977,7 +2046,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 80.0,
+ "SetPoint": 60.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -2002,7 +2071,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 80.0,
+ "SetPoint": 60.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -2028,7 +2097,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 80.0,
+ "SetPoint": 60.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -2335,7 +2404,7 @@
"Type": "TMP75"
},
{
- "Address": "0x48",
+ "Address": "0x4C",
"Bus": 6,
"Name": "PCH M.2 Temp",
"Thresholds": [
@@ -2409,6 +2478,8 @@
"Polarity": "Low"
}
],
+ "PiromI2cBus": 13,
+ "PiromI2cAddress": "0x50",
"Type": "XeonCPU"
},
{
@@ -2422,13 +2493,15 @@
"Polarity": "Low"
}
],
+ "PiromI2cBus": 13,
+ "PiromI2cAddress": "0x51",
"Type": "XeonCPU"
},
{
- "Address": "0x38",
- "Bus": 4,
- "Name": "PFR",
- "Type": "PFR"
+ "Name": "PCH SMBUS Slave",
+ "PchSmbusSlaveI2cBus": 3,
+ "PchSmbusSlaveI2cAddress": "0x44",
+ "Type": "PchSmbusSlave"
}
],
"Name": "WC Baseboard",
@@ -2451,4 +2524,4 @@
"ProductId": 145
},
"xyz.openbmc_project.Inventory.Item.System": {}
-} \ No newline at end of file
+}
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Chassis.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Chassis.json
index 12c2e6084..ad10d87a4 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Chassis.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Chassis.json
@@ -3,6 +3,7 @@
{
"BindConnector": "System Fan connector 1",
"Index": 0,
+ "MaxReading": 21000,
"Name": "Fan 1",
"Thresholds": [
{
@@ -23,6 +24,7 @@
{
"BindConnector": "System Fan connector 2",
"Index": 2,
+ "MaxReading": 21000,
"Name": "Fan 2",
"Thresholds": [
{
@@ -43,6 +45,7 @@
{
"BindConnector": "System Fan connector 3",
"Index": 4,
+ "MaxReading": 21000,
"Name": "Fan 3",
"Thresholds": [
{
@@ -63,6 +66,7 @@
{
"BindConnector": "System Fan connector 6",
"Index": 10,
+ "MaxReading": 21000,
"Name": "Fan 4",
"Thresholds": [
{
@@ -83,6 +87,7 @@
{
"BindConnector": "System Fan connector 7",
"Index": 12,
+ "MaxReading": 21000,
"Name": "Fan 5",
"Thresholds": [
{
@@ -103,6 +108,7 @@
{
"BindConnector": "System Fan connector 8",
"Index": 14,
+ "MaxReading": 21000,
"Name": "Fan 6",
"Thresholds": [
{
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WP-Baseboard.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WP-Baseboard.json
index 573f1aec6..23869e812 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WP-Baseboard.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WP-Baseboard.json
@@ -2414,6 +2414,12 @@
}
],
"Type": "XeonCPU"
+ },
+ {
+ "Name": "PCH SMBUS Slave",
+ "PchSmbusSlaveI2cBus": 3,
+ "PchSmbusSlaveI2cAddress": "0x44",
+ "Type": "PchSmbusSlave"
}
],
"Name": "WP Baseboard",
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/blocklist.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/blocklist.json
new file mode 100644
index 000000000..477c87062
--- /dev/null
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/blocklist.json
@@ -0,0 +1,3 @@
+{
+ "buses": [9]
+}
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager_%.bbappend
index 6528bd513..80aba4906 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager_%.bbappend
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -9,11 +9,13 @@ SRC_URI_append = " file://0001-Blacklist-DIMM-Bus.patch \
file://J85894-HSBP.json \
file://CPC-Baseboard.json \
file://MIDPLANE-2U2X12SWITCH.json \
- file://WC-Chassis.json"
+ file://WC-Chassis.json \
+ file://blocklist.json"
RDEPENDS_${PN} += " default-fru"
do_install_append() {
install -d ${D}/usr/share/entity-manager/configurations
install -m 0444 ${WORKDIR}/*.json ${D}/usr/share/entity-manager/configurations
+ rm ${D}/usr/share/entity-manager/configurations/blocklist.json
}