summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-ast2500/recipes-phosphor
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-07-31 20:43:37 +0300
committerEd Tanous <ed.tanous@intel.com>2019-08-01 18:19:38 +0300
commitd0f63ef62c76c932a2003eaa42c0b250065ae06f (patch)
tree4c0e3cb32dc80f80460bdbf82ff6d401d4ff194f /meta-openbmc-mods/meta-ast2500/recipes-phosphor
parentb4f66bacb1b8e661d794fa7a189e2f66f5092e2e (diff)
downloadopenbmc-d0f63ef62c76c932a2003eaa42c0b250065ae06f.tar.xz
Update to internal 7-31-19
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-ast2500/recipes-phosphor')
-rwxr-xr-x[-rw-r--r--]meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CYP-baseboard.json114
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/TNP-baseboard.json66
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json74
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WP-Baseboard.json69
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed.bb20
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed/fan-default-speed.service10
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed/set_fan_speeds.py23
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru.bb14
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600CYP.fru.binbin513 -> 0 bytes
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600TNP.fru.binbin512 -> 0 bytes
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WC.fru.binbin511 -> 0 bytes
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WFT.fru.binbin512 -> 0 bytes
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WP.fru.binbin512 -> 0 bytes
-rwxr-xr-xmeta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/checkFru.sh8
-rwxr-xr-xmeta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/create_fru.py154
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/workbook/wolfpass-config.bb2
16 files changed, 384 insertions, 170 deletions
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CYP-baseboard.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CYP-baseboard.json
index 2bbaa0238..42e313568 100644..100755
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CYP-baseboard.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CYP-baseboard.json
@@ -224,6 +224,12 @@
"Type": "ADC"
},
{
+ "BridgeGpio": [
+ {
+ "Name": "P3VBAT_BRIDGE_EN",
+ "Polarity": "High"
+ }
+ ],
"Index": 7,
"Name": "P3VBAT",
"ScaleFactor": 0.3333,
@@ -661,20 +667,6 @@
},
{
"Direction": "Input",
- "Index": 48,
- "Name": "Cpu Err2",
- "Polarity": "Low",
- "Type": "Gpio"
- },
- {
- "Direction": "Input",
- "Index": 49,
- "Name": "Cpu Caterr",
- "Polarity": "Low",
- "Type": "Gpio"
- },
- {
- "Direction": "Input",
"Index": 50,
"Name": "PCH Thermaltrip",
"Polarity": "Low",
@@ -1150,6 +1142,90 @@
"Type": "Gpio"
},
{
+ "Address": "0x71",
+ "Bus": 2,
+ "ChannelNames": [
+ "M2_Slot1",
+ "M2_Slot2",
+ "",
+ ""
+ ],
+ "Name": "M.2 Mux",
+ "Type": "PCA9543Mux"
+ },
+ {
+ "Address": "0x70",
+ "Bus": 4,
+ "ChannelNames": [
+ "U2_Slot1",
+ "U2_Slot2",
+ "U2_Slot3",
+ "U2_Slot4"
+ ],
+ "Name": "HSBP 1 Mux",
+ "Type": "PCA9546Mux"
+ },
+ {
+ "Address": "0x74",
+ "Bus": 4,
+ "ChannelNames": [
+ "U2_Slot5",
+ "U2_Slot6",
+ "U2_Slot7",
+ "U2_Slot8"
+ ],
+ "Name": "HSBP 1 Mux2",
+ "Type": "PCA9546Mux"
+ },
+ {
+ "Address": "0x77",
+ "Bus": 4,
+ "ChannelNames": [
+ "U2_Slot1",
+ "U2_Slot2",
+ "U2_Slot3",
+ "U2_Slot4"
+ ],
+ "Name": "HSBP 2 Mux",
+ "Type": "PCA9546Mux"
+ },
+ {
+ "Address": "0x73",
+ "Bus": 4,
+ "ChannelNames": [
+ "U2_Slot5",
+ "U2_Slot6",
+ "U2_Slot7",
+ "U2_Slot8"
+ ],
+ "Name": "HSBP 2 Mux2",
+ "Type": "PCA9546Mux"
+ },
+ {
+ "Address": "0x76",
+ "Bus": 4,
+ "ChannelNames": [
+ "U2_Slot1",
+ "U2_Slot2",
+ "U2_Slot3",
+ "U2_Slot4"
+ ],
+ "Name": "HSBP 3 Mux",
+ "Type": "PCA9546Mux"
+ },
+ {
+ "Address": "0x72",
+ "Bus": 4,
+ "ChannelNames": [
+ "U2_Slot5",
+ "U2_Slot6",
+ "U2_Slot7",
+ "U2_Slot8"
+ ],
+ "Name": "HSBP 3 Mux2",
+ "Type": "PCA9546Mux"
+ },
+ {
"Address": "0x4D",
"Bus": 6,
"Name": "CPU0 VR Temp",
@@ -1343,13 +1419,17 @@
}
],
"Name": "CYP Baseboard",
- "Probe": "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': '.*CYP'})",
- "Type": "Board",
+ "Probe": [
+ "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': 'M50CYP2SB2U'})",
+ "OR",
+ "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': '.*CYP'})"
+ ],
"ProductId": 152,
+ "Type": "Board",
"xyz.openbmc_project.Inventory.Decorator.Asset": {
"Manufacturer": "$PRODUCT_MANUFACTURER",
"Model": "$PRODUCT_PRODUCT_NAME",
"PartNumber": "$PRODUCT_PART_NUMBER",
"SerialNumber": "$PRODUCT_SERIAL_NUMBER"
}
-}
+} \ No newline at end of file
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/TNP-baseboard.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/TNP-baseboard.json
index 39e101e77..235e7965a 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/TNP-baseboard.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/TNP-baseboard.json
@@ -193,6 +193,12 @@
"Type": "ADC"
},
{
+ "BridgeGpio": [
+ {
+ "Name": "P3VBAT_BRIDGE_EN",
+ "Polarity": "High"
+ }
+ ],
"Index": 7,
"Name": "P3VBAT",
"ScaleFactor": 0.3333,
@@ -558,33 +564,12 @@
},
{
"Direction": "Input",
- "Index": 49,
- "Name": "Cpu Caterr",
- "Polarity": "Low",
- "Type": "Gpio"
- },
- {
- "Direction": "Input",
- "Index": 48,
- "Name": "Cpu Err2",
- "Polarity": "Low",
- "Type": "Gpio"
- },
- {
- "Direction": "Input",
"Index": 63,
"Name": "PU 240VA Status",
"Polarity": "Low",
"Type": "Gpio"
},
{
- "Direction": "Out",
- "Index": 208,
- "Name": "P3v3bat BridgeEn",
- "Polarity": "High",
- "Type": "Gpio"
- },
- {
"Direction": "Input",
"Index": 214,
"Name": "Nmi Button",
@@ -1687,6 +1672,39 @@
"Type": "IpmbSensor"
},
{
+ "Address": "0x20",
+ "Bus": 10,
+ "Class": "NodePower",
+ "Name": "Node Power",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 255
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 250
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "MP5920"
+ },
+ {
"GpioPins": [
27,
26
@@ -1818,7 +1836,11 @@
}
],
"Name": "TNP Baseboard",
- "Probe": "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': '.*TNP'})",
+ "Probe": [
+ "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': 'D50TNP1SB'})",
+ "OR",
+ "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': '.*TNP'})"
+ ],
"ProductId": 153,
"Type": "Board",
"xyz.openbmc_project.Inventory.Decorator.Asset": {
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json
index ce98132d6..9431c30a6 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json
@@ -162,7 +162,12 @@
"Type": "ADC"
},
{
- "BridgeGpio": 208,
+ "BridgeGpio": [
+ {
+ "Name": "P3VBAT_BRIDGE_EN",
+ "Polarity": "High"
+ }
+ ],
"Index": 7,
"Name": "P3VBAT",
"ScaleFactor": 0.3333,
@@ -656,13 +661,6 @@
"Type": "FanRedundancy"
},
{
- "Direction": "Out",
- "Index": 208,
- "Name": "Bridge P3VBAT",
- "Polarity": "Low",
- "Type": "Gpio"
- },
- {
"Direction": "Input",
"Index": 40,
"Name": "NMI Input",
@@ -671,20 +669,6 @@
},
{
"Direction": "Input",
- "Index": 48,
- "Name": "CPU ERR2",
- "Polarity": "High",
- "Type": "Gpio"
- },
- {
- "Direction": "Input",
- "Index": 49,
- "Name": "CPU CATERR",
- "Polarity": "High",
- "Type": "Gpio"
- },
- {
- "Direction": "Input",
"Index": 214,
"Name": "SMI Input",
"Polarity": "High",
@@ -1197,7 +1181,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 65.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1439,7 +1423,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1464,7 +1448,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1490,7 +1474,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1515,7 +1499,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1541,7 +1525,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1567,7 +1551,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1592,7 +1576,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1669,7 +1653,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 75.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1686,16 +1670,18 @@
"ILimitMax": 100,
"ILimitMin": 30,
"Inputs": [
- "VR 1 Temp"
+ "CPU1 VR Mem ABCD Temp",
+ "CPU1 VR Mem ABCD Temp",
+ "CPU1 VR P1V8"
],
- "Name": "VR 1 Temp",
+ "Name": "CPU 1 VR Temp",
"NegativeHysteresis": 5.0,
"OutLimitMax": 100,
"OutLimitMin": 30,
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 85.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1711,16 +1697,18 @@
"ILimitMax": 100,
"ILimitMin": 30,
"Inputs": [
- "VR 2 Temp"
+ "CPU2 VR Mem ABCD Temp",
+ "CPU2 VR Mem ABCD Temp",
+ "CPU2 VR P1V8"
],
- "Name": "VR 2 Temp",
+ "Name": "CPU 2 VR Temp",
"NegativeHysteresis": 5.0,
"OutLimitMax": 100,
"OutLimitMin": 30,
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 85.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -2036,7 +2024,11 @@
}
],
"Name": "WC Baseboard",
- "Probe": "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': '.*WC'})",
+ "Probe": [
+ "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': 'WilsonCity'})",
+ "OR",
+ "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': '.*WC'})"
+ ],
"ProductId": 145,
"Type": "Board",
"xyz.openbmc_project.Inventory.Decorator.Asset": {
@@ -2044,5 +2036,9 @@
"Model": "$PRODUCT_PRODUCT_NAME",
"PartNumber": "$PRODUCT_PART_NUMBER",
"SerialNumber": "$PRODUCT_SERIAL_NUMBER"
- }
+ },
+ "xyz.openbmc_project.Inventory.Decorator.AssetTag": {
+ "AssetTag": "$PRODUCT_ASSET_TAG"
+ },
+ "xyz.openbmc_project.Inventory.Item.System": {}
} \ No newline at end of file
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WP-Baseboard.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WP-Baseboard.json
index 923924a0b..7da6fe261 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WP-Baseboard.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WP-Baseboard.json
@@ -162,7 +162,12 @@
"Type": "ADC"
},
{
- "BridgeGpio": 208,
+ "BridgeGpio": [
+ {
+ "Name": "P3VBAT_BRIDGE_EN",
+ "Polarity": "High"
+ }
+ ],
"Index": 7,
"Name": "P3VBAT",
"ScaleFactor": 0.3333,
@@ -656,20 +661,6 @@
"Type": "FanRedundancy"
},
{
- "Direction": "Out",
- "Index": 208,
- "Name": "Bridge P3VBAT",
- "Polarity": "Low",
- "Type": "Gpio"
- },
- {
- "Direction": "Input",
- "Index": 49,
- "Name": "CPU CATERR",
- "Polarity": "High",
- "Type": "Gpio"
- },
- {
"Direction": "Input",
"Index": 214,
"Name": "SMI Input",
@@ -1183,7 +1174,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 65.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1425,7 +1416,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1450,7 +1441,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1476,7 +1467,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1501,7 +1492,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1527,7 +1518,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1553,7 +1544,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1578,7 +1569,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 80.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1655,7 +1646,7 @@
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 75.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1672,16 +1663,18 @@
"ILimitMax": 100,
"ILimitMin": 30,
"Inputs": [
- "VR 1 Temp"
+ "CPU1 VR Mem ABCD Temp",
+ "CPU1 VR Mem ABCD Temp",
+ "CPU1 VR P1V8"
],
- "Name": "VR 1 Temp",
+ "Name": "CPU 1 VR Temp",
"NegativeHysteresis": 5.0,
"OutLimitMax": 100,
"OutLimitMin": 30,
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 85.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -1697,16 +1690,18 @@
"ILimitMax": 100,
"ILimitMin": 30,
"Inputs": [
- "VR 2 Temp"
+ "CPU2 VR Mem ABCD Temp",
+ "CPU2 VR Mem ABCD Temp",
+ "CPU2 VR P1V8"
],
- "Name": "VR 2 Temp",
+ "Name": "CPU 2 VR Temp",
"NegativeHysteresis": 5.0,
"OutLimitMax": 100,
"OutLimitMin": 30,
"Outputs": [],
"PCoefficient": -0.15,
"PositiveHysteresis": 0.0,
- "SetPoint": 60.0,
+ "SetPoint": 85.0,
"SlewNeg": -1,
"SlewPos": 0.0,
"Type": "Pid",
@@ -2022,7 +2017,11 @@
}
],
"Name": "WP Baseboard",
- "Probe": "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': '.*WP'})",
+ "Probe": [
+ "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': 'WilsonPoint'})",
+ "OR",
+ "xyz.openbmc_project.FruDevice({'PRODUCT_PRODUCT_NAME': '.*WP'})"
+ ],
"ProductId": 154,
"Type": "Board",
"xyz.openbmc_project.Inventory.Decorator.Asset": {
@@ -2030,5 +2029,9 @@
"Model": "$PRODUCT_PRODUCT_NAME",
"PartNumber": "$PRODUCT_PART_NUMBER",
"SerialNumber": "$PRODUCT_SERIAL_NUMBER"
- }
-}
+ },
+ "xyz.openbmc_project.Inventory.Decorator.AssetTag": {
+ "AssetTag": "$PRODUCT_ASSET_TAG"
+ },
+ "xyz.openbmc_project.Inventory.Item.System": {}
+} \ No newline at end of file
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed.bb b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed.bb
deleted file mode 100644
index 9c10c5b3d..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "Set Wolfpass fan default speeds"
-DESCRIPTION = "Sets all fans to a single speed"
-
-inherit allarch
-inherit obmc-phosphor-systemd
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-RDEPENDS_${PN} += "python"
-
-S = "${WORKDIR}"
-SRC_URI += "file://set_fan_speeds.py"
-
-SYSTEMD_SERVICE_${PN} += "fan-default-speed.service"
-
-do_install() {
- install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/set_fan_speeds.py ${D}/${bindir}/set_fan_speeds.py
-}
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed/fan-default-speed.service b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed/fan-default-speed.service
deleted file mode 100644
index 267fdee43..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed/fan-default-speed.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Set fans to a default speed
-ConditionFileNotEmpty={bindir}/set_fan_speeds.py
-
-[Service]
-ExecStart={bindir}/set_fan_speeds.py 150
-Type=oneshot
-
-[Install]
-WantedBy=default.target
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed/set_fan_speeds.py b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed/set_fan_speeds.py
deleted file mode 100644
index 70ba64799..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fans/fan-default-speed/set_fan_speeds.py
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/usr/bin/python
-import os
-import glob
-import time
-import sys
-
-HWMON_DIR = "/sys/class/hwmon/hwmon0"
-
-count = 0
-inputs = None
-while not inputs:
- count += 1
- if count > 20:
- print("pwm missing!")
- sys.exit(0)
-
- inputs = glob.glob(os.path.join(HWMON_DIR, "pwm*"))
- time.sleep(5)
-
-inputs = glob.glob(os.path.join(HWMON_DIR, "pwm*"))
-for pwm in inputs:
- with open(pwm, 'w') as f:
- f.write(sys.argv[1])
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru.bb b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru.bb
index 1ae1680e0..b8b8f7524 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru.bb
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru.bb
@@ -8,13 +8,25 @@ SYSTEMD_SERVICE_${PN} = "SetBaseboardFru.service"
S = "${WORKDIR}"
SRC_URI = "file://checkFru.sh \
file://SetBaseboardFru.service \
- file://*.fru.bin"
+ file://create_fru.py"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
RDEPENDS_${PN} = "bash"
+python do_compile() {
+ import sys
+ workdir = d.getVar('WORKDIR', True)
+ sys.path.insert(0, workdir)
+ from create_fru import create_fru
+ create_fru('S2600WFT')
+ create_fru('WilsonCity')
+ create_fru('WilsonPoint')
+ create_fru('M50CYP2SB2U')
+ create_fru('D50TNP1SB')
+}
+
do_install() {
install -d ${D}${bindir}
install -m 0755 ${S}/checkFru.sh ${D}/${bindir}/checkFru.sh
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600CYP.fru.bin b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600CYP.fru.bin
deleted file mode 100644
index ba5b96392..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600CYP.fru.bin
+++ /dev/null
Binary files differ
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600TNP.fru.bin b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600TNP.fru.bin
deleted file mode 100644
index afd58e6b9..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600TNP.fru.bin
+++ /dev/null
Binary files differ
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WC.fru.bin b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WC.fru.bin
deleted file mode 100644
index 76c4b8d4b..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WC.fru.bin
+++ /dev/null
Binary files differ
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WFT.fru.bin b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WFT.fru.bin
deleted file mode 100644
index 1b9f97ff4..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WFT.fru.bin
+++ /dev/null
Binary files differ
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WP.fru.bin b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WP.fru.bin
deleted file mode 100644
index fb219c0ce..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/S2600WP.fru.bin
+++ /dev/null
Binary files differ
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/checkFru.sh b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/checkFru.sh
index 1eb79b299..4b7910198 100755
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/checkFru.sh
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/checkFru.sh
@@ -22,16 +22,16 @@ done
# wp
if (($result == 62)); then
- cat S2600WP.fru.bin > $fruFile
+ cat WilsonPoint.fru.bin > $fruFile
# wc
elif (($result == 45)); then
- cat S2600WC.fru.bin > $fruFile
+ cat WilsonCity.fru.bin > $fruFile
# cyp
elif (($result == 60)); then
- cat S2600CYP.fru.bin > $fruFile
+ cat M50CYP2SB2U.fru.bin > $fruFile
# tnp
elif (($result == 12)); then
- cat S2600TNP.fru.bin > $fruFile
+ cat D50TNP1SB.fru.bin > $fruFile
# default to wft
else
cat S2600WFT.fru.bin > $fruFile
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/create_fru.py b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/create_fru.py
new file mode 100755
index 000000000..7f11cbf2d
--- /dev/null
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/fru/default-fru/create_fru.py
@@ -0,0 +1,154 @@
+#!/usr/bin/python3
+
+"""
+This script generates a default baseboard fru file.
+"""
+
+
+def create_fru(name):
+ if len(name) > 16:
+ raise Exception('Product Name Too Large: {}'.format(name))
+
+ fill_char = ord('.')
+ eof = 0xC1
+
+ filename = '{}.fru.bin'.format(name)
+ name = name.encode('ascii')
+
+ name_len = (0x3 << 6) | len(name)
+
+ # internal area
+ internal = [0x01] + ([0] * 6) + [0x01]
+
+ # chassis area
+ chassis = [0x01, # Chassis Info Area Format Version Bit Fields
+ 0xFF, # Chassis Info Area Length (in multiples of 8 bytes)
+ 0x17] # Chassis Type (Main Server Chassis)
+
+ fill_len = 18
+
+ # Chassis Part Number
+ chassis += [0x3 << 6 | fill_len] + ([fill_char] * fill_len)
+
+ # Chassis Serial Number
+ chassis += [0x3 << 6 | fill_len] + ([fill_char] * fill_len)
+
+ fill_len = 31
+ chassis += [0x3 << 6 | fill_len] + ([fill_char] * fill_len) # Info AM1
+ chassis += [0x3 << 6 | fill_len] + ([fill_char] * fill_len) # Info AM2
+
+ chassis.append(eof)
+
+ chassis.append(0) # need room for checksum
+
+ while len(chassis) % 8: # pad
+ chassis.append(0)
+
+ chassis[1] = int(len(chassis) / 8) # populate length
+ chassis[-1] = (256 - sum(chassis)) & 0xFF # populate checksum
+
+ # board area
+ board = [0x1, # Board Info Area Format Version Bit Fields
+ 0xFF, # Board Info Area Length (in multiples of 8 bytes)
+ 0x0, # Language Code
+ 0x0, # Mfg. Date/Time
+ 0x0, # Mfg. Date/Time
+ 0x0, # Mfg. Date/Time
+ 0xD1] # Product Manufacturer Name Len
+
+ corp = b'Intel Corporation'
+ board += bytearray(corp) # Manufacturer Name
+
+ board.append(name_len)
+ board += bytearray(name) # Board Product Name
+
+ fill_len = 12
+ board += [0x3 << 6 | fill_len] + ([fill_char] * fill_len) # board SN
+
+ fill_len = 10
+ board += [0x3 << 6 | fill_len] + ([fill_char] * fill_len) # board PN
+
+ version = b'FRU Ver 0.01'
+
+ board += [0x3 << 6 | len(version)] # FRU File version ID string
+ board += bytearray(version)
+
+ board.append(eof)
+
+ board.append(0) # need room for checksum
+
+ while len(board) % 8:
+ board.append(0)
+
+ board[1] = int(len(board) / 8) # populate length
+ board[-1] = (256 - sum(board)) & 0xFF # populate checksum
+
+ # product area
+ product = [1, # Product Info Area Format Version Bit Fields
+ 0xFF, # Product Info Area Length (in multiples of 8 bytes)
+ 0x0, # Language Code
+ 0xD1] # Product Manufacturer Name Len
+
+ product += bytearray(corp) # Manufacturer Name
+
+ product.append(name_len) # Product Name Len
+ product += bytearray(name) # Product Name
+
+ fill_len = 10
+
+ # Product Part Number
+ product += [0x3 << 6 | fill_len] + ([fill_char] * fill_len)
+
+ # Product Version
+ fill_len = 20
+ product += [0x3 << 6 | fill_len] + ([fill_char] * fill_len)
+
+ # Product Serial Number
+ fill_len = 12
+ product += [0x3 << 6 | fill_len] + ([fill_char] * fill_len)
+
+ # Asset Tag
+ fill_len = 20
+ product += [0x3 << 6 | fill_len] + ([fill_char] * fill_len)
+
+ product.append(0xC0) # FRU File ID (Not used)
+ product.append(eof)
+
+ product.append(0) # need room for checksum
+
+ while len(product) % 8:
+ product.append(0)
+
+ product[1] = int(len(product) / 8)
+ product[-1] = (256 - sum(product)) & 0xFF
+
+ header = [0x1]
+ length = 1 # internal
+ header.append(length)
+ length += int(len(internal) / 8)
+ header.append(length)
+ length += int(len(chassis) / 8)
+ header.append(length)
+ length += int(len(board) / 8)
+ header.append(length)
+ header.append(0)
+ header.append(0)
+ header.append((256 - sum(header)) & 0xFF)
+
+ result = header + internal + chassis + board + product
+
+ while len(result) < 0x1FF:
+ result.append(0)
+
+ result = bytearray(result)
+
+ # print(result)
+
+ with open(filename, 'wb') as out:
+ out.write(result)
+
+
+if __name__ == '__main__':
+ product_name = input('Enter Product Name: ')
+ create_fru(product_name)
+
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/workbook/wolfpass-config.bb b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/workbook/wolfpass-config.bb
index ead62f47e..c91053536 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/workbook/wolfpass-config.bb
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/workbook/wolfpass-config.bb
@@ -7,4 +7,4 @@ inherit config-in-skeleton
LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
SRCREV = "946064239016e38cd1cc346047b1d26960c06cdb"
-SKELETON_URI = "git://git-amr-1.devtools.intel.com:29418/openbmc-skeleton.git;protocol=ssh;branch=intel"
+SKELETON_URI = "git://git@github.com/Intel-BMC/skeleton.git;protocol=ssh;branch=intel"