summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-11-04 00:40:53 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-11-04 01:28:00 +0300
commit61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b (patch)
tree5aadf91080299b1583caed86a31da368dfcda2da /meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot
parent901ced0812b458fdc599fe40b0a4233d422d6df9 (diff)
downloadopenbmc-61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b.tar.xz
Update to internal 0.77
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot')
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0035-Remove-u-boot-delay-before-autoboot-in-release-image.patch34
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend6
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0035-Remove-u-boot-delay-before-autoboot-in-release-image.patch b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0035-Remove-u-boot-delay-before-autoboot-in-release-image.patch
new file mode 100644
index 000000000..17ef21308
--- /dev/null
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0035-Remove-u-boot-delay-before-autoboot-in-release-image.patch
@@ -0,0 +1,34 @@
+From 7aeedcb63c6d83e7ad61b55a7098c2e6381a917c Mon Sep 17 00:00:00 2001
+From: AKSHAY RAVEENDRAN K <akshay.raveendran.k@intel.com>
+Date: Sun, 12 Sep 2021 19:16:59 +0000
+Subject: [PATCH] Remove u-boot delay before autoboot in release image
+
+Removed the delay in u-boot which allowed the user to stop
+automatically booting to kernel in release image by changing
+the delay value to negative.
+
+Tested:
+After the fix, unable to stop the release image at u-boot
+and prevent autoboot.
+
+Signed-off-by: AKSHAY RAVEENDRAN K <akshay.raveendran.k@intel.com>
+---
+ include/configs/aspeed-common.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/include/configs/aspeed-common.h b/include/configs/aspeed-common.h
+index 2be63a5c66..9707a49f90 100644
+--- a/include/configs/aspeed-common.h
++++ b/include/configs/aspeed-common.h
+@@ -85,6 +85,8 @@
+
+ #define CONFIG_ENV_SECT_SIZE (4 << 10)
+
++#define CONFIG_BOOTDELAY -2
++
+ /*
+ * Ethernet related
+ */
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
index 2f24a602f..5b4885c2e 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
@@ -97,7 +97,13 @@ SRC_URI:append:intel-ast2600 = " \
PFR_SRC_URI = " \
file://0043-AST2600-PFR-u-boot-env-changes-as-per-PFR-BMC-image.patch \
"
+
+AUTOBOOT_SRC_URI = " \
+ file://0035-Remove-u-boot-delay-before-autoboot-in-release-image.patch \
+ "
+
SRC_URI:append:intel-ast2600 += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', PFR_SRC_URI, '', d)}"
+SRC_URI:append:intel-ast2600 += "${@bb.utils.contains('EXTRA_IMAGE_FEATURES', 'debug-tweaks', '', AUTOBOOT_SRC_URI, d)}"
do_install:append () {
install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config