summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-ast2600
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 22:04:51 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 23:07:19 +0300
commitffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (patch)
tree8019999b0ca042482e5193d6cabc06220c71d776 /meta-openbmc-mods/meta-ast2600
parentd73e39703a0260c8911cb439b579e1c2bada4b20 (diff)
downloadopenbmc-ffe6d597d9e3d4407cf8062b5d6505a80ce08f41.tar.xz
Update to internal 0.75
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-ast2600')
-rw-r--r--meta-openbmc-mods/meta-ast2600/conf/layer.conf6
-rw-r--r--meta-openbmc-mods/meta-ast2600/conf/machine/include/intel-ast2600.inc2
-rw-r--r--meta-openbmc-mods/meta-ast2600/conf/machine/include/obmc-bsp-si-common.inc4
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch76
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0017-Manufacturing-mode-physical-presence-detection.patch41
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0022-Reboot-into-UBOOT-on-Watchdog-Failures.patch8
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0025-ast2600-PFR-platform-EXTRST-reset-mask-selection.patch2
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0032-Disable-eSPI-initialization-in-u-boot-for-normal-boo.patch20
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend44
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-graphics/obmc-ikvm/obmc-ikvm_%.bbappend2
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed_%.bbappend2
11 files changed, 109 insertions, 98 deletions
diff --git a/meta-openbmc-mods/meta-ast2600/conf/layer.conf b/meta-openbmc-mods/meta-ast2600/conf/layer.conf
index e60de28cc..72c40f6e1 100644
--- a/meta-openbmc-mods/meta-ast2600/conf/layer.conf
+++ b/meta-openbmc-mods/meta-ast2600/conf/layer.conf
@@ -9,12 +9,12 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "ast2600"
BBFILE_PATTERN_ast2600 = "^${LAYERDIR}/"
BBFILE_PRIORITY_ast2600 = "10"
-LAYERSERIES_COMPAT_ast2600 = "gatesgarth hardknott"
+LAYERSERIES_COMPAT_ast2600 = "gatesgarth hardknott honister"
INHERIT += "extrausers"
#INHERIT += " cve-check"
-EXTRA_USERS_PARAMS_append_pn-intel-platforms = " \
+EXTRA_USERS_PARAMS:append:pn-intel-platforms = " \
${@bb.utils.contains('EXTRA_IMAGE_FEATURES', 'debug-tweaks', "usermod -p '\$1\$UGMqyqdG\$FZiylVFmRRfl9Z0Ue8G7e/' root;", '', d)}"
-hostname_pn-base-files = "intel-obmc"
+hostname:pn-base-files = "intel-obmc"
diff --git a/meta-openbmc-mods/meta-ast2600/conf/machine/include/intel-ast2600.inc b/meta-openbmc-mods/meta-ast2600/conf/machine/include/intel-ast2600.inc
index a1700c873..a7146299c 100644
--- a/meta-openbmc-mods/meta-ast2600/conf/machine/include/intel-ast2600.inc
+++ b/meta-openbmc-mods/meta-ast2600/conf/machine/include/intel-ast2600.inc
@@ -1,4 +1,4 @@
-COMPATIBLE_MACHINE_intel-ast2600 = "intel-ast2600"
+COMPATIBLE_MACHINE:intel-ast2600 = "intel-ast2600"
KMACHINE = "aspeed"
KERNEL_DEVICETREE = " \
${KMACHINE}-bmc-${COMPATIBLE_MACHINE}.dtb \
diff --git a/meta-openbmc-mods/meta-ast2600/conf/machine/include/obmc-bsp-si-common.inc b/meta-openbmc-mods/meta-ast2600/conf/machine/include/obmc-bsp-si-common.inc
index 06e4a2ed3..59ec0c2a9 100644
--- a/meta-openbmc-mods/meta-ast2600/conf/machine/include/obmc-bsp-si-common.inc
+++ b/meta-openbmc-mods/meta-ast2600/conf/machine/include/obmc-bsp-si-common.inc
@@ -8,7 +8,7 @@ EXTRA_IMAGEDEPENDS += "u-boot"
IMAGE_FSTYPES += "squashfs-xz"
IMAGE_FSTYPES += "mtd-auto"
INITRAMFS_FSTYPES = "squashfs-xz"
-EXTRA_IMAGECMD_squashfs-xz_append = "-processors ${BB_NUMBER_THREADS} -b 262144 -Xdict-size 100% -Xbcj arm"
+EXTRA_IMAGECMD:squashfs-xz:append = "-processors ${BB_NUMBER_THREADS} -b 262144 -Xdict-size 100% -Xbcj arm"
KERNEL_CLASSES ?= "kernel-fitimage"
KERNEL_IMAGETYPES ?= "fitImage"
@@ -19,7 +19,7 @@ UBOOT_SUFFIX ?= "bin"
MACHINEOVERRIDES =. "openbmc:"
OBMC_PHOSPHOR_IMAGE_OVERLAY= "1"
-OBMC_IMAGE_EXTRA_INSTALL_append = "u-boot-fw-utils-aspeed-sdk"
+OBMC_IMAGE_EXTRA_INSTALL:append = "u-boot-fw-utils-aspeed-sdk"
IMAGE_CLASSES += "image_types image_types_phosphor_auto qemuboot"
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch
index d1ccc278a..a2981f822 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch
@@ -1,4 +1,4 @@
-From 45d1a40a3fc5fa97c92e59fc36fd98eb047a9bd1 Mon Sep 17 00:00:00 2001
+From 9c65cf5fa3cdbbdf1ac7f8269502ec6564703319 Mon Sep 17 00:00:00 2001
From: Vernon Mauery <vernon.mauery@intel.com>
Date: Thu, 24 Oct 2019 14:06:33 -0700
Subject: [PATCH] Add ast2600-intel as a new board
@@ -6,6 +6,7 @@ Subject: [PATCH] Add ast2600-intel as a new board
Signed-off-by: Vernon Mauery <vernon.mauery@intel.com>
Signed-off-by: Kuiying Wang <kuiying.wang@intel.com>
Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+Signed-off-by: AKSHAY RAVEENDRAN K <akshay.raveendran.k@intel.com>
---
arch/arm/dts/ast2600-intel.dts | 202 ++++---------
arch/arm/lib/interrupts.c | 5 +
@@ -15,11 +16,11 @@ Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
board/aspeed/ast2600_intel/ast-irq.c | 399 +++++++++++++++++++++++++
board/aspeed/ast2600_intel/ast-irq.h | 8 +
board/aspeed/ast2600_intel/ast-timer.c | 59 ++++
- board/aspeed/ast2600_intel/intel.c | 346 ++++++++++-----------
+ board/aspeed/ast2600_intel/intel.c | 347 ++++++++++-----------
cmd/Kconfig | 2 +-
common/autoboot.c | 10 +
configs/ast2600_openbmc_defconfig | 2 +-
- 12 files changed, 998 insertions(+), 334 deletions(-)
+ 12 files changed, 999 insertions(+), 334 deletions(-)
create mode 100644 board/aspeed/ast2600_intel/ast-espi.c
create mode 100644 board/aspeed/ast2600_intel/ast-irq.c
create mode 100644 board/aspeed/ast2600_intel/ast-irq.h
@@ -1163,10 +1164,10 @@ index 000000000000..cf8c69aba5d3
+ writel(tctrl, AST_TIMER_BASE + TIMER_CONTROL);
+}
diff --git a/board/aspeed/ast2600_intel/intel.c b/board/aspeed/ast2600_intel/intel.c
-index be6dc49a3bc7..092ff8b5c095 100644
+index be6dc49a3bc7..fc0e41a47712 100644
--- a/board/aspeed/ast2600_intel/intel.c
+++ b/board/aspeed/ast2600_intel/intel.c
-@@ -1,222 +1,192 @@
+@@ -1,222 +1,193 @@
-// SPDX-License-Identifier: GPL-2.0+
-/*
- * Copyright (C) ASPEED Technology Inc.
@@ -1323,6 +1324,7 @@ index be6dc49a3bc7..092ff8b5c095 100644
+
+/* HICRB Bits */
+#define HICRB_EN80HSGIO (1 << 13) /* Enable 80hSGIO */
++#define HICRB_ENSNP0D (1 << 14) /* Enable ACCEPT response for snoop #0 */
+
+static void port80h_snoop_init(void)
+{
@@ -1358,7 +1360,7 @@ index be6dc49a3bc7..092ff8b5c095 100644
- val = readl(LPC_HICRB);
- val |= LPC_HICRB_80HSGPIO_EN;
- writel(val, LPC_HICRB);
-+ value = readl(AST_LPC_BASE + HICRB) | HICRB_EN80HSGIO;
++ value = readl(AST_LPC_BASE + HICRB) | HICRB_EN80HSGIO | HICRB_ENSNP0D;
+ writel(value, AST_LPC_BASE + HICRB);
}
@@ -1373,29 +1375,35 @@ index be6dc49a3bc7..092ff8b5c095 100644
+#define SCU_414 0x414 /* Multi-function Pin Control #5 */
#define SCU_414_SGPM_MASK GENMASK(27, 24)
-+ uint32_t value;
- /* set the sgpio clock to pclk/(2*(5+1)) or ~2 MHz */
+- /* set the sgpio clock to pclk/(2*(5+1)) or ~2 MHz */
- u32 val;
-
- val = ((256 << SGPIO_M1_CONF_CLKDIV_SHIFT) & SGPIO_M1_CONF_CLKDIV_MASK) |
- ((10 << SGPIO_M1_PINS_SHIFT) & SGPIO_M1_PINS_MASK) |
- SPGIO_M1_EN;
- writel(val, SGPIO_M1_CONF);
--
++ uint32_t value;
++ /* set the sgpio clock to 2MHz */
++ value = SGPIO_CLK_DIV(24) | SGPIO_BYTES(10) | SGPIO_ENABLE;
++ writel(value, AST_GPIO_BASE + GPIO554);
++ writel(readl(SCU_BASE | SCU_414) | SCU_414_SGPM_MASK,
++ SCU_BASE | SCU_414);
++}
+
- val = readl(SCU_PINMUX5);
- val |= (SCU_PINMUX5_SGPMI |
- SCU_PINMUX5_SGPMO |
- SCU_PINMUX5_SGPMLD |
- SCU_PINMUX5_SGPMCK);
- writel(val, SCU_PINMUX5);
-+ value = SGPIO_CLK_DIV(256) | SGPIO_BYTES(10) | SGPIO_ENABLE;
-+ writel(value, AST_GPIO_BASE + GPIO554);
-+ writel(readl(SCU_BASE | SCU_414) | SCU_414_SGPM_MASK,
-+ SCU_BASE | SCU_414);
++static void timer_handler(void *regs)
++{
++ printf("+");
}
-static void gpio_init(void)
-+static void timer_handler(void *regs)
++extern int arch_interrupt_init_early(void);
++int board_early_init_f(void)
{
- /* Default setting of Y23 pad in AST2600 A1 is HBLED so disable it. */
- writel(readl(SCU_PINMUX27) & ~SCU_PINMUX27_HBLED_EN,
@@ -1438,12 +1446,24 @@ index be6dc49a3bc7..092ff8b5c095 100644
- /* GPIO G6 is also an open-drain output so set it as an input. */
- writel(readl(GPIO_EFGH_DIR) & ~GPIO_EFGH_DIR_G6,
- GPIO_EFGH_DIR);
-+ printf("+");
++ /* This is called before relocation; beware! */
++ /* initialize running timer? timer_init is next in the list but
++ * I am not sure if it actually does anything... */
++ arch_interrupt_init_early();
++
++ gpio_passthru_init();
++
++ port80h_snoop_init();
++
++ sgpio_init();
++
++ /* TODO: is it too late to enforce HW security registers? */
++ return 0;
}
-static void espi_init(void)
-+extern int arch_interrupt_init_early(void);
-+int board_early_init_f(void)
++extern void timer_enable(int n, uint32_t freq, interrupt_handler_t *handler);
++int board_early_init_r(void)
{
- u32 reg;
-
@@ -1488,31 +1508,13 @@ index be6dc49a3bc7..092ff8b5c095 100644
- reg = readl(ESPI_CTRL);
- reg |= 0x10;
- writel(reg, ESPI_CTRL);
-+ /* This is called before relocation; beware! */
-+ /* initialize running timer? timer_init is next in the list but
-+ * I am not sure if it actually does anything... */
-+ arch_interrupt_init_early();
-+
-+ gpio_passthru_init();
-+
-+ port80h_snoop_init();
-+
-+ sgpio_init();
++ debug("board_early_init_r\n");
++ /* timer_enable(0, 1, timer_handler); */
+
-+ /* TODO: is it too late to enforce HW security registers? */
+ return 0;
}
-int board_early_init_f(void)
-+extern void timer_enable(int n, uint32_t freq, interrupt_handler_t *handler);
-+int board_early_init_r(void)
-+{
-+ debug("board_early_init_r\n");
-+ /* timer_enable(0, 1, timer_handler); */
-+
-+ return 0;
-+}
-+
+extern void espi_init(void);
+int board_late_init(void)
{
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0017-Manufacturing-mode-physical-presence-detection.patch b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0017-Manufacturing-mode-physical-presence-detection.patch
index c0d409592..7df227c82 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0017-Manufacturing-mode-physical-presence-detection.patch
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0017-Manufacturing-mode-physical-presence-detection.patch
@@ -1,4 +1,4 @@
-From 5d3f9d42ba9b1f634a65ae52f6263b1c4a95b947 Mon Sep 17 00:00:00 2001
+From 3b08379cb6e841c934ded3db3c70a3d0906cea65 Mon Sep 17 00:00:00 2001
From: AppaRao Puli <apparao.puli@linux.intel.com>
Date: Thu, 20 Jun 2019 18:11:43 +0530
Subject: [PATCH] Manufacturing mode physical presence detection
@@ -22,12 +22,12 @@ Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.co
Signed-off-by: AppaRao Puli <apparao.puli@linux.intel.com>
Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
---
- board/aspeed/ast2600_intel/intel.c | 74 ++++++++++++++++++++++++++++--
+ board/aspeed/ast2600_intel/intel.c | 87 ++++++++++++++++++++++++++++--
common/autoboot.c | 12 ++++-
- 2 files changed, 82 insertions(+), 4 deletions(-)
+ 2 files changed, 95 insertions(+), 4 deletions(-)
diff --git a/board/aspeed/ast2600_intel/intel.c b/board/aspeed/ast2600_intel/intel.c
-index fb9075f93945..a644010dd339 100644
+index f45b9d06a3f5..7664ac0ddfc6 100644
--- a/board/aspeed/ast2600_intel/intel.c
+++ b/board/aspeed/ast2600_intel/intel.c
@@ -8,6 +8,8 @@
@@ -66,19 +66,18 @@ index fb9075f93945..a644010dd339 100644
#define SCU_BASE 0x1E6E2000
#define SCU_338 0x338 //Generate UART 24 MHz Reference from UXCLK
#define SCU_33C 0x33c //Generate UART 24 MHz Reference from HUXCLK
-@@ -119,6 +141,11 @@ static void gpio_passthru_init(void)
+@@ -119,6 +141,10 @@ static void gpio_passthru_init(void)
SCU_BASE | SCU_418);
}
+void board_pre_abort_autoboot(void)
+{
-+ gpio_passthru_init();
+}
+
#define AST_LPC_BASE 0x1e789000
#define LPC_SNOOP_ADDR 0x80
#define HICR5 0x080 /* Host Interface Control Register 5 */
-@@ -300,8 +327,6 @@ int board_early_init_f(void)
+@@ -301,8 +327,6 @@ int board_early_init_f(void)
set_gpio_default_state();
@@ -87,7 +86,7 @@ index fb9075f93945..a644010dd339 100644
port80h_snoop_init();
sgpio_init();
-@@ -388,6 +413,43 @@ static void update_bootargs_cmd(const char *key, const char *value)
+@@ -389,6 +413,56 @@ static void update_bootargs_cmd(const char *key, const char *value)
free(buf);
}
@@ -100,13 +99,14 @@ index fb9075f93945..a644010dd339 100644
+ */
+ const uint32_t delay_in_ms = 100;
+ const uint32_t read_count = ((15 * 1000) / delay_in_ms);
-+ const uint32_t delay_for_indication = 10 * 1000;
++ const uint32_t delay_for_indication = 2 * 1000;
++ uint32_t count;
+#ifdef CONFIG_LED_BLINK
+ struct udevice *dev;
+ int ret;
+#endif
+
-+ for (uint32_t count = 0; count < read_count; ++count) {
++ for (count = 0; count < read_count; ++count) {
+ if (read_frontpanel_power_button() != 1)
+ return false;
+
@@ -122,8 +122,20 @@ index fb9075f93945..a644010dd339 100644
+ }
+#endif
+
-+ /* Delay the boot to do physical indication for mfg mode */
-+ mdelay(delay_for_indication);
++ /*
++ * Delay up to 15 seconds until the power button is released to prevent
++ * unintentional power button overriding to PCH through GPIO
++ * pass-through.
++ */
++ for (count = 0; count < read_count; ++count) {
++ if (read_frontpanel_power_button() != 1)
++ break;
++
++ mdelay(delay_in_ms);
++ }
++ /* Keep the indication at least for 2 seconds */
++ if (delay_in_ms * count < delay_for_indication)
++ mdelay(delay_for_indication - (delay_in_ms * count));
+
+ return true;
+}
@@ -131,7 +143,7 @@ index fb9075f93945..a644010dd339 100644
extern void espi_init(void);
extern void kcs_init(void);
extern void timer_enable(int n, u32 interval_us, interrupt_handler_t *handler,
-@@ -413,8 +475,14 @@ int board_late_init(void)
+@@ -414,8 +488,15 @@ int board_late_init(void)
snprintf(value, sizeof(value), "0x%x", gd->reset_reason);
update_bootargs_cmd("resetreason", value);
@@ -140,8 +152,9 @@ index fb9075f93945..a644010dd339 100644
+ if (gd->reset_reason & SYS_PWR_RESET_FLAG && is_mfg_mode_phy_req())
+ update_bootargs_cmd("special", "mfg");
+
++ gpio_passthru_init();
++
+ if (read_ffuj()) {
-+ gpio_passthru_init();
kcs_init();
+ }
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0022-Reboot-into-UBOOT-on-Watchdog-Failures.patch b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0022-Reboot-into-UBOOT-on-Watchdog-Failures.patch
index d1cb523e5..9b87b5c57 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0022-Reboot-into-UBOOT-on-Watchdog-Failures.patch
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0022-Reboot-into-UBOOT-on-Watchdog-Failures.patch
@@ -1,4 +1,4 @@
-From 56a1cafcf68c624ca9ea9de6c38080603e80ea0d Mon Sep 17 00:00:00 2001
+From 1c879ae1f822f59d74cec9dd7ed10790279ad65b Mon Sep 17 00:00:00 2001
From: James Feist <james.feist@linux.intel.com>
Date: Wed, 31 Jul 2019 16:01:49 -0700
Subject: [PATCH] Reboot into UBOOT on Watchdog Failures
@@ -17,7 +17,7 @@ Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
1 file changed, 61 insertions(+)
diff --git a/board/aspeed/ast2600_intel/intel.c b/board/aspeed/ast2600_intel/intel.c
-index a644010dd339..2db162bc9d4c 100644
+index 7664ac0ddfc6..24ae48fc62e7 100644
--- a/board/aspeed/ast2600_intel/intel.c
+++ b/board/aspeed/ast2600_intel/intel.c
@@ -9,6 +9,55 @@
@@ -87,7 +87,7 @@ index a644010dd339..2db162bc9d4c 100644
/* check ffuj to abort the autoboot */
value = read_ffuj();
printf("FFUJ: %d\n", value);
-@@ -460,6 +513,7 @@ int board_late_init(void)
+@@ -473,6 +526,7 @@ int board_late_init(void)
#define REV_ID_AST2600A0 0x05000303 /* AST2600 A0 */
#define ONE_MSEC_IN_USEC 1000
char value[11];
@@ -95,7 +95,7 @@ index a644010dd339..2db162bc9d4c 100644
if (readl(SCU_BASE | SCU_014) == REV_ID_AST2600A0)
timer_enable(0, ONE_MSEC_IN_USEC, timer_callback, (void *)0);
-@@ -475,6 +529,13 @@ int board_late_init(void)
+@@ -488,6 +542,13 @@ int board_late_init(void)
snprintf(value, sizeof(value), "0x%x", gd->reset_reason);
update_bootargs_cmd("resetreason", value);
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0025-ast2600-PFR-platform-EXTRST-reset-mask-selection.patch b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0025-ast2600-PFR-platform-EXTRST-reset-mask-selection.patch
index 959fd0bf4..e72679836 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0025-ast2600-PFR-platform-EXTRST-reset-mask-selection.patch
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0025-ast2600-PFR-platform-EXTRST-reset-mask-selection.patch
@@ -34,7 +34,7 @@ index c65adff0d69a..3db7d993d3ca 100644
2:
+ /* SCU060:EXTRST1# reset mask selection */
+ ldr r0, =AST_SCU_EXTRST_SEL1
-+ ldr r1, =0x6FF1FF1
++ ldr r1, =0x6CF1FF1
+ str r1, [r0]
+
+ /* SCU070:EXTRST2# reset mask selection */
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0032-Disable-eSPI-initialization-in-u-boot-for-normal-boo.patch b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0032-Disable-eSPI-initialization-in-u-boot-for-normal-boo.patch
index aa1f0cc65..018ab07cf 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0032-Disable-eSPI-initialization-in-u-boot-for-normal-boo.patch
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0032-Disable-eSPI-initialization-in-u-boot-for-normal-boo.patch
@@ -1,4 +1,4 @@
-From e152d718da6bfdf71d309b7ec885d2050fc19d01 Mon Sep 17 00:00:00 2001
+From 08f2b4f0464ef8abcf32511f8549233359d16eed Mon Sep 17 00:00:00 2001
From: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
Date: Wed, 2 Jun 2021 13:03:47 -0700
Subject: [PATCH] Disable eSPI initialization in u-boot for normal booting
@@ -21,27 +21,25 @@ eSPI will be initialized in u-boot only in these specific cases:
Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
---
- board/aspeed/ast2600_intel/intel.c | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
+ board/aspeed/ast2600_intel/intel.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/board/aspeed/ast2600_intel/intel.c b/board/aspeed/ast2600_intel/intel.c
-index aff0c8593759..fc2f3c8feea7 100644
+index 54f53d77c476..f3f1d8114616 100644
--- a/board/aspeed/ast2600_intel/intel.c
+++ b/board/aspeed/ast2600_intel/intel.c
-@@ -201,7 +201,11 @@ static void gpio_passthru_init(void)
+@@ -201,6 +201,10 @@ static void gpio_passthru_init(void)
void board_pre_abort_autoboot(void)
{
-- gpio_passthru_init();
+ if (!read_ffuj()) {
+ espi_init();
-+ gpio_passthru_init();
+ kcs_init();
+ }
}
#define AST_LPC_BASE 0x1e789000
-@@ -662,7 +666,6 @@ int board_late_init(void)
+@@ -625,7 +629,6 @@ int board_late_init(void)
#endif
pwm_init();
@@ -49,14 +47,14 @@ index aff0c8593759..fc2f3c8feea7 100644
/* Add reset reason to bootargs */
snprintf(value, sizeof(value), "0x%x", gd->reset_reason);
-@@ -684,6 +687,7 @@ int board_late_init(void)
- update_bootargs_cmd("special", "mfg");
+@@ -645,6 +648,7 @@ int board_late_init(void)
+ gpio_passthru_init();
if (read_ffuj()) {
+ espi_init();
- gpio_passthru_init();
kcs_init();
}
+
--
2.17.1
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
index 08eb6336e..2f24a602f 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
@@ -1,12 +1,10 @@
COMPATIBLE_MACHINE = "intel-ast2600"
-FILESEXTRAPATHS_append_intel-ast2600:= "${THISDIR}/files:"
-
-SRCREV = "e1417368fdc3ba45ffde51a4b13290114a643be4"
+FILESEXTRAPATHS:append:intel-ast2600:= "${THISDIR}/files:"
# the meta-phosphor layer adds this patch, which conflicts
# with the intel layout for environment
-SRC_URI_append_intel-ast2600 = " \
+SRC_URI:append:intel-ast2600 = " \
file://intel.cfg \
file://0001-Add-ast2600-intel-as-a-new-board.patch \
file://0002-AST2600-Enable-host-searial-port-clock-configuration.patch \
@@ -44,8 +42,8 @@ SRC_URI_append_intel-ast2600 = " \
"
# CVE-2020-10648 vulnerability fix
-FILESEXTRAPATHS_append_intel-ast2600:= "${THISDIR}/files/CVE-2020-10648:"
-SRC_URI_append_intel-ast2600 = " \
+FILESEXTRAPATHS:append:intel-ast2600:= "${THISDIR}/files/CVE-2020-10648:"
+SRC_URI:append:intel-ast2600 = " \
file://0001-image-Correct-comment-for-fit_conf_get_node.patch \
file://0008-image-Load-the-correct-configuration-in-fit_check_si.patch \
file://0009-fit_check_sign-Allow-selecting-the-configuration-to-.patch \
@@ -53,56 +51,56 @@ SRC_URI_append_intel-ast2600 = " \
"
# CVE-2019-11059 vulnerability fix
-FILESEXTRAPATHS_append_intel-ast2600:= "${THISDIR}/files/CVE-2019-11059:"
-SRC_URI_append_intel-ast2600 = " \
+FILESEXTRAPATHS:append:intel-ast2600:= "${THISDIR}/files/CVE-2019-11059:"
+SRC_URI:append:intel-ast2600 = " \
file://0001-Fix-ext4-block-group-descriptor-sizing.patch \
"
# CVE-2019-11690 vulnerability fix
-FILESEXTRAPATHS_append_intel-ast2600:= "${THISDIR}/files/CVE-2019-11690:"
-SRC_URI_append_intel-ast2600 = " \
+FILESEXTRAPATHS:append:intel-ast2600:= "${THISDIR}/files/CVE-2019-11690:"
+SRC_URI:append:intel-ast2600 = " \
file://0001-lib-uuid-Fix-unseeded-PRNG-on-RANDOM_UUID-y.patch \
"
# CVE-2019-13105 vulnerability fix
-FILESEXTRAPATHS_append_intel-ast2600:= "${THISDIR}/files/CVE-2019-13105:"
-SRC_URI_append_intel-ast2600 = " \
+FILESEXTRAPATHS:append:intel-ast2600:= "${THISDIR}/files/CVE-2019-13105:"
+SRC_URI:append:intel-ast2600 = " \
file://0001-fs-ext4-cache-extent-data.patch \
file://0002-CVE-2019-13105-ext4-fix-double-free-in-ext4_cache_re.patch \
"
# CVE-2019-13104 vulnerability fix
-FILESEXTRAPATHS_append_intel-ast2600:= "${THISDIR}/files/CVE-2019-13104:"
-SRC_URI_append_intel-ast2600 = " \
+FILESEXTRAPATHS:append:intel-ast2600:= "${THISDIR}/files/CVE-2019-13104:"
+SRC_URI:append:intel-ast2600 = " \
file://0001-CVE-2019-13104-ext4-check-for-underflow-in-ext4fs_re.patch \
"
# CVE-2019-13106 vulnerability fix
-FILESEXTRAPATHS_append_intel-ast2600:= "${THISDIR}/files/CVE-2019-13106:"
-SRC_URI_append_intel-ast2600 = " \
+FILESEXTRAPATHS:append:intel-ast2600:= "${THISDIR}/files/CVE-2019-13106:"
+SRC_URI:append:intel-ast2600 = " \
file://0001-CVE-2019-13106-ext4-fix-out-of-bounds-memset.patch \
"
# CVE-2021-27097 vulnerability fix
-FILESEXTRAPATHS_append_intel-ast2600:= "${THISDIR}/files/CVE-2021-27097:"
-SRC_URI_append_intel-ast2600 = " \
+FILESEXTRAPATHS:append:intel-ast2600:= "${THISDIR}/files/CVE-2021-27097:"
+SRC_URI:append:intel-ast2600 = " \
file://0001-image-Adjust-the-workings-of-fit_check_format.patch \
file://0002-image-Add-an-option-to-do-a-full-check-of-the-FIT.patch \
"
# CVE-2021-27138 vulnerability fix
-FILESEXTRAPATHS_append_intel-ast2600:= "${THISDIR}/files/CVE-2021-27138:"
-SRC_URI_append_intel-ast2600 = " \
+FILESEXTRAPATHS:append:intel-ast2600:= "${THISDIR}/files/CVE-2021-27138:"
+SRC_URI:append:intel-ast2600 = " \
file://0001-image-Check-for-unit-addresses-in-FITs.patch \
"
PFR_SRC_URI = " \
file://0043-AST2600-PFR-u-boot-env-changes-as-per-PFR-BMC-image.patch \
"
-SRC_URI_append_intel-ast2600 += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', PFR_SRC_URI, '', d)}"
+SRC_URI:append:intel-ast2600 += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', PFR_SRC_URI, '', d)}"
-do_install_append () {
+do_install:append () {
install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
install -m 0644 ${WORKDIR}/fw_env.config ${S}/tools/env/fw_env.config
}
-RDEPENDS_${PN} = "udev-aspeed-mtd-partitions"
+RDEPENDS:${PN} = "udev-aspeed-mtd-partitions"
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-graphics/obmc-ikvm/obmc-ikvm_%.bbappend b/meta-openbmc-mods/meta-ast2600/recipes-graphics/obmc-ikvm/obmc-ikvm_%.bbappend
index 23c9060d2..85e3ffc26 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-graphics/obmc-ikvm/obmc-ikvm_%.bbappend
+++ b/meta-openbmc-mods/meta-ast2600/recipes-graphics/obmc-ikvm/obmc-ikvm_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
SRC_URI += " \
file://0001-Enable-per-frame-CRC-calculation-option-to-save-netw.patch \
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed_%.bbappend
index 07cafe94e..e5687d4d1 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -1,5 +1,5 @@
COMPATIBLE_MACHINE = "intel-ast2600"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += " \
file://intel-ast2600.cfg \