summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core/host-error-monitor
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-10-23 00:01:54 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-10-23 00:48:48 +0300
commit456380bb272d3a301c887eee513a3937cc1f48e1 (patch)
tree124399167d539582befbe35ad28377eaea6cc8bc /meta-openbmc-mods/meta-common/recipes-core/host-error-monitor
parent9722c6ee87766a45a337c094d1293de81cdcb106 (diff)
downloadopenbmc-456380bb272d3a301c887eee513a3937cc1f48e1.tar.xz
Update to internal 10-22-19
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core/host-error-monitor')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb b/meta-openbmc-mods/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
index 483a9bf12..8556f3310 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
+++ b/meta-openbmc-mods/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
@@ -2,13 +2,20 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit cmake systemd
-SRC_URI = "git://git@github.com/Intel-BMC/at-scale-debug;protocol=ssh"
+SRC_URI = "git://git@github.com/Intel-BMC/provingground.git;protocol=ssh"
-DEPENDS = "boost sdbusplus libgpiod"
+DEPENDS = "boost sdbusplus libgpiod libpeci"
PV = "0.1+git${SRCPV}"
-SRCREV = "6ed87657134c7379da1febcccd5d87617c702347"
+SRCREV = "30110fe5b18999bddc5721dc5611f542f6feeabd"
S = "${WORKDIR}/git/host_error_monitor"
SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.HostErrorMonitor.service"
+
+# linux-libc-headers guides this way to include custom uapi headers
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
+CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
+do_configure[depends] += "virtual/kernel:do_shared_workdir"