summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core/systemd
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-05-29 20:29:58 +0300
committerEd Tanous <ed.tanous@intel.com>2019-06-06 04:30:22 +0300
commit87a65e63bac789bca0607e0b4ab09d62517b95e7 (patch)
tree3254b912d6468012543e127a19ba2f1cd13b108f /meta-openbmc-mods/meta-common/recipes-core/systemd
parent5364646cb66fa75cdcbf148e039e0383cda94f2a (diff)
downloadopenbmc-87a65e63bac789bca0607e0b4ab09d62517b95e7.tar.xz
Update to internal
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core/systemd')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/systemd/obmc-targets.bbappend1
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/systemd/systemd-conf/journald.conf12
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/systemd/systemd-conf_%.bbappend1
3 files changed, 7 insertions, 7 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/systemd/obmc-targets.bbappend b/meta-openbmc-mods/meta-common/recipes-core/systemd/obmc-targets.bbappend
index 3fe1c3f38..3d4e594a4 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/systemd/obmc-targets.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-core/systemd/obmc-targets.bbappend
@@ -1,6 +1,7 @@
# Remove these files since they are provided by obmc-intel-targets
SYSTEMD_SERVICE_${PN}_remove += " obmc-host-start@.target"
SYSTEMD_SERVICE_${PN}_remove += " obmc-host-stop@.target"
+SYSTEMD_SERVICE_${PN}_remove += " obmc-host-shutdown@.target"
SYSTEMD_SERVICE_${PN}_remove += " obmc-host-reboot@.target"
SYSTEMD_SERVICE_${PN}_remove += " obmc-host-startmin@.target"
SYSTEMD_SERVICE_${PN}_remove += " obmc-chassis-poweron@.target"
diff --git a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd-conf/journald.conf b/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd-conf/journald.conf
index 5d4134cbd..48c60d36b 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd-conf/journald.conf
+++ b/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd-conf/journald.conf
@@ -12,18 +12,18 @@
# See journald.conf(5) for details.
[Journal]
-Storage=persistent
+Storage=volatile
#Compress=yes
#Seal=yes
#SplitMode=uid
#SyncIntervalSec=5m
#RateLimitIntervalSec=30s
#RateLimitBurst=10000
-SystemMaxUse=6M
+#SystemMaxUse=6M
#SystemKeepFree=
-SystemMaxFileSize=512K
-# SystemMaxFiles=32
-#RuntimeMaxUse=32M
+#SystemMaxFileSize=512K
+#SystemMaxFiles=32
+RuntimeMaxUse=32M
#RuntimeKeepFree=
#RuntimeMaxFileSize=
#RuntimeMaxFiles=4
@@ -34,7 +34,7 @@ SystemMaxFileSize=512K
#ForwardToConsole=no
#ForwardToWall=yes
#TTYPath=/dev/console
-MaxLevelStore=notice
+#MaxLevelStore=notice
#MaxLevelSyslog=debug
#MaxLevelKMsg=notice
#MaxLevelConsole=info
diff --git a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd-conf_%.bbappend b/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd-conf_%.bbappend
index 8f26d784b..b3c318e15 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd-conf_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd-conf_%.bbappend
@@ -7,6 +7,5 @@ SRC_URI += "file://journald.conf \
FILES_${PN} += " ${systemd_system_unitdir}/systemd-timesyncd.service.d/systemd-timesyncd-save-time.conf"
do_install_append() {
- install -m 644 -D ${WORKDIR}/journald.conf ${D}${sysconfdir}/systemd/journald.conf
install -m 644 -D ${WORKDIR}/systemd-timesyncd-save-time.conf ${D}${systemd_system_unitdir}/systemd-timesyncd.service.d/systemd-timesyncd-save-time.conf
}